Unable to get display (SonyXBR900E 65") to display 1920x1080 @ 120hz

Hello all, recent Garuda convert here…I really hope someone is able to offer a solution as I’ve searched high & low on garuda/arch forums and reddit for 3-4 days now to no avail. Here is my inxi:

System:
  Kernel: 6.9.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=f5079725-5848-4839-8b48-f5e14744f2d6 rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0
    wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX Z390-E GAMING v: Rev 1.xx
    serial: <superuser required> part-nu: ASUS_MB_CNL uuid: <superuser required>
    UEFI: American Megatrends v: 1903 date: 07/08/2021
CPU:
  Info: model: Intel Core i5-9600K bits: 64 type: MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xFC
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
    desc: 1x9 MiB
  Speed (MHz): avg: 800 min/max: 800/4600 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800
    bogomips: 44398
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] vendor: Micro-Star MSI
    driver: nvidia v: 550.90.07 alternate: nouveau,nvidia_drm non-free: 550.xx+
    status: current (as of 2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none
    off: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0 chip-ID: 10de:2482
    class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia
    display-ID: 0
  Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia
    x11: drv: zink inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3070 Ti/PCIe/SSE2
    memory: 7.81 GiB display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 11 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3070 Ti driver: nvidia v: 550.90.07 device-ID: 10de:2482
    surfaces: xcb,xlib,wayland device: 1 type: cpu name: llvmpipe (LLVM
    17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM 17.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl, snd_soc_avs, snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228b
    class-ID: 0403
  Device-3: SteelSeries ApS Arctis Nova 7
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-5:3 chip-ID: 1038:2202 class-ID: 0300
  API: ALSA v: k6.9.3-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno2 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:7
    chip-ID: 8087:0aaa class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
  Local Storage: total: 3.64 TiB used: 20.09 GiB (0.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 35.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Western Digital
    model: WD BLACK SN770 2TB size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 731030WD temp: 33.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 620.97 GiB size: 620.97 GiB (100.00%)
    used: 20.06 GiB (3.2%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:8
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 26.1 MiB (27.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:4
  ID-3: /home raw-size: 620.97 GiB size: 620.97 GiB (100.00%)
    used: 20.06 GiB (3.2%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:8
  ID-4: /var/log raw-size: 620.97 GiB size: 620.97 GiB (100.00%)
    used: 20.06 GiB (3.2%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:8
  ID-5: /var/tmp raw-size: 620.97 GiB size: 620.97 GiB (100.00%)
    used: 20.06 GiB (3.2%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:8
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 62.71 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 6 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 45.9 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 64 GiB note: est. available: 62.71 GiB used: 4.37 GiB (7.0%)
  Processes: 276 Power: uptime: 45m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 25.04 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 2020 libs: 589 tools: octopi,paru Compilers:
    clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: Bash v: 5.2.26
    running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-06-07
  Last full system update: 2024-06-10
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

Anyhow, I’m having difficulty getting my display to run at 1920x1080 @ 120hz refresh rate within linux meanwhile it works fine in windows10 (however in order to utilize 1920x1080@120hz I need to create a custom resolution through the nvidia control panel using this method: Custom Resolutions | NVIDIA). So far I’ve tried using the xrandr utility to address this with the following commands (I’ll walk you all through step by step as to what I tried to make sure I’m not missing a step or messing up syntax):

  1. Run xrandr to see that my resolution/refresh isn’t natively supported:
Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
HDMI-A-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1440mm x 810mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   1152x720      59.97  
   960x600       59.63  
   928x580       59.88  
   800x500       59.50  
   768x480       59.90  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  
  1. I create a modeline using the cvt command:
cvt 1920 1080 120
# 1920x1080 119.93 Hz (CVT) hsync: 139.12 kHz; pclk: 369.50 MHz
Modeline "1920x1080_120.00"  369.50  1920 2080 2288 2656  1080 1083 1088 1160 -hsync +vsync
  1. I create this new mode to xrandr using the following:
xrandr --newmode "1920x1080_120.00"  369.50  1920 2080 2288 2656  1080 1083 1088 1160 -hsync +vsync

  1. I then add this newly created mode to xrandr of possible resolutions:
xrandr --addmode HDMI-A-1 1920x1080_120.00

  1. I run xrandr command again to verify it was applied & I see it at the bottom of the list (so far so good):
xrandr
Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
HDMI-A-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1440mm x 810mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   1152x720      59.97  
   960x600       59.63  
   928x580       59.88  
   800x500       59.50  
   768x480       59.90  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  
   1920x1080_120.00 119.93  

  1. I apply the new mode by running the following command:
xrandr --output HDMI-A-1 --mode 1920x1080_120.00 
  1. I run xrandr command again to see if the new resolution/refresh applied and no luck :frowning: :
xrandr
Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
HDMI-A-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1440mm x 810mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   1152x720      59.97  
   960x600       59.63  
   928x580       59.88  
   800x500       59.50  
   768x480       59.90  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  
   1920x1080_120.00 119.93  

So as you can see I believe I used the correct utility and syntax but it doesn’t seem to want to work for me…I have tried the xrandr method in both ‘wayland’ and ‘plasma’ (by changing the environment in the lower left at the login screen). Additionally, I have tried opening the nvidia software using the sudo nvidia-settings command but it doesn’t give me any option to change resolution or refresh rate (in fact it looks quite sparse). Should I have more options here? This is a screenshot of what I see:

The last thing I have yet to try is modifying the xorg.conf file as shown in the arch wiki here: xrandr - ArchWiki but I’m not hopeful this method will work if I can’t even temporarily change the resolution & rate using the xrandr method…So just to recap, this is a native 4k panel that runs at 240hz interpolated but only works at 120hz native if running at 1920x1080 and I create a custom nvidia profile through windows10/11 (note: this display is not detected as 120hz by windows OS until I create the profile through nvidia).

This is my first post to this community so please forgive me in advance for any formatting errors I made - please let me know and I’ll edit the post accordingly. I desperately hope you all are able to help me as I would love to finally break out of the windows ecosystem once and for all, but if unable will be forced to go back to windows as 60hz displays give me headaches :smiling_face_with_tear:…Thanks for your time.

Sincere Regards,
-DeLuXe

way back i had kinda the same issue i got it going one time but you have to use X11 which you can switch to at the login menu in like the bottom left. i never got it to work after that though :slightly_frowning_face:

Yeah I’ve tried doing the same changes using the xrandr utility in the X11 environment without any luck either…If you happen to remember what you did though please let me know!

However, one change I did notice while doing this on X11 is that I now have far more options in my nvidia-settings. I can now change the resolution and refresh rate within the nvidia-settings gui but still can only select up to 60hz.

yea there is no nvidia settings app for wayland as they haven’t made it yet(well a full one anyway) an wayland works fundamentally different. But looking at my old level1tech post someone gave me nvidia - Force refresh rate - Ask Ubuntu the
last comment I think is what helped me but dont quote me haha its been like 4 years.

At this point I’m willing to try anything, I’ll give it a shot as soon as I’m back in front of my PC, thanks for the tip! :+1:

It probably wont be of much help but I am dealing with a sort of similar issue myself but please note I am using a amd gpu and not nvidia, not sure how much that changes things.

I have a 4k 60hz tv, and when running KDE Plasma Wayland the TV would be locked to 30hz even after selecting 60hz and hitting apply nothing would happen. So after trying a bunch of stuff, I switched from KDE Wayland to Gnome Wayland and it works. So I say give Gnome a shot.

I was reviewing the link you sent and reading the 3rd comment, they say to modify the Xorg.conf file but it appears there are more than one (some in /usr/share/X11/xorg.conf.d & some in /etc/X11/) which one should I edit? Sorry if this is a noobie question.

You’re actually not the first person I’ve seen say this. I’ve read on multiple forums that Gnome apparently “plays nicer” with custom resolutions/rates. I will definitely give this a try as a last ditch effort simply because I’m a fan of the KDE Plasma desktop environment. If it comes to this, I will report back with my findings to hopefully help someone in the future that experiences a similar issue. Thanks for your response!

1 Like

edit /etc/X11/xorg.conf

if the above comment doesn’t work I think what i had done was use the nvidia control panel to save one then I edited that. iirc