Unable to enter bios

im pretty new to garuda and wanted to enable virtualization in my bios to set up a windows 10 virtual machine, however i noticed that no matter what f key i mash before the garuda linux launcher i cant get into my bios, i also cant access my windows installation since im dual booting, is there any way i could access my bios using Grub?

garuda-inxi
:question:

4 Likes

While you preparing your garuda-inxi try this to get to the BIOS -

sudo systemctl reboot --firmware-setup
4 Likes

results

System:
Kernel: 6.7.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=931da642-204d-43e5-b10d-6b2e1383046f rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: STGAUBRON product: STGAUBRON v: N/A
serial: <superuser required>
Mobo: STGAUBRON model: Intel B85 serial: <superuser required>
UEFI: American Megatrends v: 4.6.5 date: 03/27/2023
CPU:
Info: model: Intel Core i7-4790 bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3543 high: 3598 min/max: 800/3600 scaling:
driver: intel_cpufreq governor: ondemand cores: 1: 3598 2: 3592 3: 3592
4: 3592 5: 3592 6: 3197 7: 3593 8: 3592 bogomips: 57466
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Polaris 20 XL [Radeon RX 580 2048SP] driver: amdgpu v: kernel
arch: GCN-4 code: Arctic Islands process: GF 14nm built: 2016-20 pcie:
gen: 3 speed: 8 GT/s lanes: 16 ports: active: DP-1,DVI-D-1 empty: HDMI-A-1
bus-ID: 01:00.0 chip-ID: 1002:6fdf class-ID: 0300 temp: 42.0 C
Device-2: Razer USA Gaming Webcam [Kiyo] driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1.1:4
chip-ID: 1532:0e03 class-ID: 0102
Device-3: Logitech CrystalCam driver: snd-usb-audio,uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:5 chip-ID: 046d:0894
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
s-diag: 1055mm (41.54")
Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: left model: Dell E2214H
serial: <filter> built: 2014 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: DP-1 mapped: DisplayPort-0 pos: primary,right
model: LG (GoldStar) ULTRAGEAR serial: <filter> built: 2022 res: 1920x1080
dpi: 81 gamma: 1.2 size: 600x340mm (23.62x13.39") diag: 690mm (27.2")
ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.4-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 580 2048SP (radeonsi
polaris10 LLVM 16.0.6 DRM 3.56 6.7.1-zen1-1-zen) device-ID: 1002:6fdf
memory: 7.81 GiB unified: no
API: Vulkan v: 1.3.276 layers: 13 device: 0 type: discrete-gpu name: AMD
Radeon RX 580 2048SP (RADV POLARIS10) driver: mesa radv v: 23.3.4-arch1.2
device-ID: 1002:6fdf surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.4-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel 8 Series/C220 Series High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
class-ID: 0403
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-3: Razer USA Gaming Webcam [Kiyo] driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1.1:4
chip-ID: 1532:0e03 class-ID: 0102
Device-4: HP HyperX QuadCast driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-2:3
chip-ID: 03f0:0491 class-ID: 0300 serial: <filter>
Device-5: Logitech CrystalCam driver: snd-usb-audio,uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:5 chip-ID: 046d:0894
class-ID: 0102 serial: <filter>
Device-6: Razer USA RZ04-0318 Gaming Headset [Kraken Ultimate]
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-8:9 chip-ID: 1532:0527 class-ID: 0300
serial: <filter>
API: ALSA v: k6.7.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-7:8
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 1.38 TiB used: 617.55 GiB (43.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD BLACK SN770 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 731100WD temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Kingfast model: N/A size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
serial: <filter> fw-rev: 2A0 scheme: MBR
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 617.55 GiB (66.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 617.55 GiB (66.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 617.55 GiB (66.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 617.55 GiB (66.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.58 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 42.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 1049
Info:
Processes: 311 Uptime: 1m wakeups: 0 Memory: total: 16 GiB
available: 15.58 GiB used: 5.01 GiB (32.2%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: 1995 pm: pacman pkgs: 1985 libs: 556 tools: octopi,paru
pm: flatpak pkgs: 10 Shell: fish v: 3.7.0 running-in: konsole inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2024-01-03
Last full system update: 2024-02-08
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units: ~~~
1 Like
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text
2 Likes

thank you!

It’s not detecting your dual-boot though

1 Like
  • also, fwsetup on grub bootup, after pressing c → if memory serves me right

i tried this, but i was unable to access bios, even if dual booting isnt available (i must have messed the install up) i still need to get in to turn virtualization on

Isn’t there like a grub entry reboot to uefi or smth? or are they all failiing?

3 Likes

ill check this

this brings me to a screen with launch garuda with a 3 second timer until it auto boots
(the same screen as before) which im unsure if this “is” my bios but it doesnt look like my bios from before i switched to garuda (i dont see why it would change since the bios is part of the motherboard)

Well, thats peculiar… I can suggest something but you will probably have to wait for a far more technical answer from someone more smart…

  1. Remove your hard disk/ssd and check to see if you can access the bios [even when using a live usb].

  2. Look up your pc/laptop specs online and guide on upgrading or downgrading bios [also check to see if people experience this]

Probably what me, would have done.

I think in your case you need to press the “Delete” key.

5 Likes

It should be in the manual or at least on the manufacturer’s website.
Booting into the BIOS is also possible from grub.

image

5 Likes

Also most Garuda spins have this “Reboot to UEFI” app. Just click on it your pc will reboot to bios.

I’m not on the system at the moment, but if the GRUB option does not appear, you could comment out the final lines of this file /etc/grub.d/61_custom_leave_options and update-grub.
I see they were commented with a commit at a certain point but I don’t know why.

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.