Unable to do initial installation

I had successfully installed Garuda KDE on my laptop. But when I tried to restore a snapshot, it didn't booted again .
It said "Reboot immediately", and when rebooted it gave an error.
( I was able to see grub, but when I entered on the Garuda Linux entry, it gave an error(sorry, but I don't remember that)).
Since I dual booted it with windows earlier , I deleted the partition which I made during installation (root, grub, and swap)
I again made the pendrive bootable and tried to install it again,
But this time, after choosing "boot with open source drivers"
It shows the following :
(As I am a new user, I can't post the photo)
ERROR: /dev/disk/by-label/GARUDA_DR460NIZED_TALON' device did not show up after 30 seconds. Falling back to interactive prompt

You can try to fix the problem manually, log out when you are finished sh: can't access tty; job control turned off

[rootfs ]#


I tried using different pendrives too(samsung, SanDisk),
Made them bootable with different softwares too (Balena Etcher, Rufus, Ventoy).
I am on a HP laptop "HP-Probook 640 G2"
Processor - "Intel Core i7"
On the latest bios.

My previous distribution's neofetch:-

OS: Arch Linux x86_64

Host: HP ProBook 640 G2

Kernel: 6.0.2-arch1-1

Uptime: 6 mins

Packages: 1066 (pacman)

Shell: zsh 5.9

Resolution: 1366x768

DE: GNOME 42.5

WM: Mutter

W Theme: Adwaita Theme: Kali-Dark [GTK2/3]

Icons: Adwaita [GTK2/3]

Terminal: gnome-terminal

CPU: Intel 17-6500U (4) @ 3.400GHz

GPU: Intel Skylake GT2 [HD Graphics 520]

Memory: 1437M1B / 3175MiB

I have disabled Fastboot in BIOS,
also disabled fast start-up here "Control Panel\Hardware and Sound\Power Options\System Settings" in Windows.
I know 4 gb ram is less, but it was working fine and also I doesn't need any extra apps, only a browser, bitwarden, and VLC.

An inxi -Faz would be more helpful if Arch is still around.

How did you create the image? Please use dd next time, be careful though :wink:

1 Like

Or just use ventoy and check sha1sum.

cheksum matched.
Copied this error message when i booted with ventoy.

Arch was pain. I literally never used my laptop, just on the name of using it, I was fixing things here and there.
Only reason for shifting to Garuda

Due to storage limitations, I had to remove Arch.... :melting_face:

Does the interactive prompt work to check the contents of directories, e.g.

ls /dev/disk/by-label/


Really mysterious!!
This time I successfully booted.
I thought it booted successfully as my device was on charging this time.(I had enabled cpu overcloacking in bios while on A/C).
But I thought wrong. It booted when it was not on charging too.
( done these both tests now itself.)
I actually booted to run the command which you gave, but now I am in live environment. (sent this message from live environment :laughing: .)
It's fixed now, somehow, unknowingly.
I remember a thing, that when i was unable to boot,
"A start job is running for automatic driver installation via MHWD (BE patient!)"
It stucked here. After 1min 30 sec, the limit restarted again. This limiting resetting happend 3-4 times, and i get the prompt, which i posted at starting of this thread.

I have successfully installed Garuda again!!
Does you need any other information about my system?

No, I'll close the topic here.
Your issue is solved and, for future readers with the same problem (which is the most important thing in a community), we don't have and can't have further information on what happened and how to solve the same problem when occurring.
Patience was mentioned by the system :blush:, but it was clearly not enough, since the system failed (sometimes it is just a matter of waiting enough, in the mhwd phase).