Unable to build java-openjdk-ea-bin

Everything up to date.

pamac build java-openjdk-ea-bin
Preparing...
Cloning java-openjdk-ea-bin build files...
Checking java-openjdk-ea-bin dependencies...
Choose a provider for sh:
1:  bash       5.1.004-1  core
2:  dashbinsh  0.1-5      chaotic-aur

Enter a number (default=1): 

Resolving dependencies...
Checking inter-conflicts...
Warning: dependency cycle detected:
Warning: harfbuzz will be installed before its freetype2 dependency

To install (129):
  linux-api-headers        5.8-1                  (Required By: java-openjdk-ea-bin)  core   
  tzdata                   2021a-1                (Required By: java-openjdk-ea-bin)  core   395.3 kB
  iana-etc                 20201229-1             (Required By: fakeroot)             core   
  filesystem               2021.01.19-1           (Required By: fakeroot)             core   31.1 kB
  glibc                    2.32-5                 (Required By: java-openjdk-ea-bin)  core   
  gcc-libs                 10.2.0-4               (Required By: autoconf)             core   
  ncurses                  6.2-1                  (Required By: autoconf)             core   
  readline                 8.1.0-2                (Required By: autoconf)             core   
  bash                     5.1.004-1              (Required By: autoconf)             core   
  gmp                      6.2.1-1                (Required By: binutils)             core   
  attr                     2.4.48-3               (Required By: binutils)             core   
  acl                      2.2.53-3               (Required By: binutils)             core   
  tar                      1.33-1                 (Required By: libtool)              core   836.6 kB
  libtool                  2.4.6+42+gb88cebd5-14                                      core   
  zlib                     1:1.2.11-4             (Required By: binutils)             core   
  bzip2                    1.0.8-4                (Required By: binutils)             core   
  pcre                     8.44-1                 (Required By: gettext)              core   
  less                     563-1                  (Required By: gzip)                 core   
  gzip                     1.10-3                                                     core   
  gdbm                     1.19-1                 (Required By: autoconf)             core   
  db                       5.3.28-5               (Required By: autoconf)             core   
  libxcrypt                4.4.17-1               (Required By: binutils)             core   
  perl                     5.32.0-3               (Required By: autoconf)             core   
  texinfo                  6.7-3                                                      core   
  libunistring             0.9.10-3               (Required By: gettext)              core   
  gc                       8.0.4-4                (Required By: make)                 extra  
  libffi                   3.3-4                  (Required By: gettext)              core   
  guile                    2.2.6-2                (Required By: make)                 extra  
  make                     4.3-3                                                      core   
  libgpg-error             1.41-1                 (Required By: pacman)               core   
  libgcrypt                1.9.1-1                (Required By: pacman)               core   586.5 kB
  util-linux-libs          2.36.1-4               (Required By: binutils)             core   
  e2fsprogs                1.45.6-3               (Required By: binutils)             core   
  openssl                  1.1.1.i-2              (Required By: binutils)             core   
  libsasl                  2.1.27-3               (Required By: binutils)             core   
  libldap                  2.4.56-1               (Required By: binutils)             core   
  keyutils                 1.6.3-1                (Required By: binutils)             core   
  krb5                     1.18.3-1               (Required By: binutils)             core   1.4 MB
  libtirpc                 1.3.1-1                (Required By: binutils)             core   
  pambase                  20200721.1-2           (Required By: binutils)             core   
  libcap-ng                0.8.2-1                (Required By: binutils)             core   
  audit                    3.0-1                  (Required By: binutils)             core   381.9 kB
  pam                      1.5.1-1                (Required By: binutils)             core   581.1 kB
  sudo                     1.9.5.p2-1                                                 core   1.1 MB
  expat                    2.2.10-2               (Required By: binutils)             core   
  lz4                      1:1.9.3-1              (Required By: binutils)             core   
  xz                       5.2.5-1                (Required By: binutils)             core   
  zstd                     1.4.8-1                (Required By: binutils)             core   797.3 kB
  libarchive               3.5.1-1                (Required By: binutils)             core   
  libcap                   2.47-1                 (Required By: binutils)             core   61.7 kB
  coreutils                8.32-1                 (Required By: binutils)             core   
  findutils                4.7.0-2                                                    core   
  libtasn1                 4.16.0-1               (Required By: pacman)               core   
  libp11-kit               0.23.22-1              (Required By: binutils)             core   
  systemd-libs             247.2-1                (Required By: binutils)             core   
  p11-kit                  0.23.22-1              (Required By: binutils)             core   
  ca-certificates-utils    20181109-4             (Required By: binutils)             core   
  ca-certificates-mozilla  3.61-1                 (Required By: binutils)             core   323.6 kB
  ca-certificates          20181109-4             (Required By: binutils)             core   
  libssh2                  1.9.0-2                (Required By: binutils)             core   
  libidn2                  2.3.0-1                (Required By: binutils)             core   
  libpsl                   0.21.1-1               (Required By: binutils)             core   
  libnghttp2               1.41.0-1               (Required By: binutils)             core   
  curl                     7.74.0-1               (Required By: binutils)             core   
  npth                     1.6-2                  (Required By: pacman)               core   
  libksba                  1.4.0-2                (Required By: pacman)               core   
  libassuan                2.5.4-1                (Required By: pacman)               core   
  glib2                    2.66.4-2               (Required By: gettext)              core   
  libsecret                0.20.4-1               (Required By: pacman)               core   
  pinentry                 1.1.0-5                (Required By: pacman)               core   
  nettle                   3.7-1                  (Required By: pacman)               core   
  gnutls                   3.7.0-1                (Required By: pacman)               core   
  sqlite                   3.34.1-1               (Required By: binutils)             core   1.8 MB
  gnupg                    2.2.27-1               (Required By: pacman)               core   2.5 MB
  gpgme                    1.15.1-1               (Required By: pacman)               core   
  pacman-mirrorlist        20210110-1             (Required By: pacman)               core   
  archlinux-keyring        20210110-1             (Required By: pacman)               core   
  pacman                   5.2.2-1                                                    core   
  pkgconf                  1.7.3-1                                                    core   
  libseccomp               2.5.1-2                (Required By: file)                 core   
  file                     5.39-1                                                     core   
  m4                       1.4.18-3                                                   core   
  flex                     2.6.4-3                                                    core   
  sed                      4.8-1                                                      core   
  shadow                   4.8.1-4                (Required By: fakeroot)             core   
  util-linux               2.36.1-4               (Required By: fakeroot)             core   
  fakeroot                 1.25.3-1                                                   core   
  icu                      68.2-1                 (Required By: gettext)              core   
  libxml2                  2.9.10-8               (Required By: gettext)              extra  
  libcroco                 0.6.13-2               (Required By: gettext)              extra  
  gettext                  0.21-1                                                     core   
  groff                    1.22.4-3                                                   core   
  bison                    3.7.2-1                                                    core   
  mpfr                     4.1.0-1                (Required By: gawk)                 core   
  gawk                     5.1.0-1                                                    core   
  libmicrohttpd            0.9.72-1               (Required By: binutils)             core   
  libelf                   0.182-1                (Required By: binutils)             core   
  elfutils                 0.182-1                (Required By: binutils)             core   
  binutils                 2.35.1-1                                                   core   
  libmpc                   1.2.1-1                (Required By: gcc)                  core   
  gcc                      10.2.0-4                                                   core   
  grep                     3.6-1                                                      core   
  which                    2.21-5                                                     core   
  patch                    2.7.6-8                                                    core   
  automake                 1.16.2-3                                                   core   
  diffutils                3.7-3                  (Required By: autoconf)             core   
  autoconf                 2.70-1                                                     core   
  libpng                   1.6.37-3                                                   extra  
  graphite                 1:1.3.14-1                                                 extra  
  harfbuzz                 2.7.4-1                                                    extra  
  freetype2                2.10.4-1               (Required By: java-openjdk-ea-bin)  extra  
  xcb-proto                1.14.1-3               (Required By: java-openjdk-ea-bin)  extra  
  libxdmcp                 1.1.3-3                (Required By: java-openjdk-ea-bin)  extra  
  libxau                   1.0.9-3                (Required By: java-openjdk-ea-bin)  extra  
  libxcb                   1.14-1                 (Required By: java-openjdk-ea-bin)  extra  
  xorgproto                2020.1-1               (Required By: java-openjdk-ea-bin)  extra  
  libx11                   1.7.0-3                (Required By: java-openjdk-ea-bin)  extra  
  libxext                  1.3.4-3                (Required By: java-openjdk-ea-bin)  extra  
  libxi                    1.7.10-3               (Required By: java-openjdk-ea-bin)  extra  
  libxfixes                5.0.3-4                (Required By: java-openjdk-ea-bin)  extra  
  libxtst                  1.2.3-4                (Required By: java-openjdk-ea-bin)  extra  
  libxrender               0.9.10-4               (Required By: java-openjdk-ea-bin)  extra  
  alsa-topology-conf       1.2.4-2                (Required By: java-openjdk-ea-bin)  extra  
  alsa-ucm-conf            1.2.4-2                (Required By: java-openjdk-ea-bin)  extra  
  alsa-lib                 1.2.4-3                (Required By: java-openjdk-ea-bin)  extra  
  java-environment-common  3-3                    (Required By: java-openjdk-ea-bin)  extra  
  java-runtime-common      3-3                    (Required By: java-openjdk-ea-bin)  extra  
  nspr                     4.29-1                 (Required By: java-openjdk-ea-bin)  core   
  nss                      3.61-1                 (Required By: java-openjdk-ea-bin)  core   1.6 MB
To build (1):
  java-openjdk-ea-bin      16b34-1                                                    AUR

Total download size: 12.4 MB
Total installed size: 826.9 MB

Edit build files : [e] 
Apply transaction ? [e/y/N] y

[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/tzdata-2020f-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/filesystem-2020.09.03-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/pam-1.5.0-2-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/krb5-1.18.2-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/audit-2.8.5-9-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/zstd-1.4.5-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/libgcrypt-1.8.7-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/tar-1.32-3-x86_64.pkg.tar.xz[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/sudo-1.9.4.p2-2-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/sqlite-3.34.0-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/tzdata-2020f-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/filesystem-2020.09.03-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/krb5-1.18.2-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/audit-2.8.5-9-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/pam-1.5.0-2-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/libgcrypt-1.8.7-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/zstd-1.4.5-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/sqlite-3.34.0-1-x86_64.pkg.tar.zst[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/tar-1.32-3-x86_64.pkg.tar.xz[/url]: Error 404
[url]https://mirror.rackspace.com/archlinux/core/os/x86_64/sudo-1.9.4.p2-2-x86_64.pkg.tar.zst[/url]: Error 404
Error: Failed to commit transaction: failed to retrieve some files

Try again, path work here in browser.
Wait
http://mirror.rackspace.com/archlinux/core/
os/x86_64/filesystem-2021.01.19-1-x86_64.pkg.tar.zst

You use old files.

@linx you musr edit the build file to new links

URL not working here on web browser.


Pamac UI says "Your system is up-to-date"

Why should I have to update the build file myself? Isn't that a problem of package maintainers?

See, I edit my post

If the package maintainer hase no fun or time to do it, then it is your problem :smiley:

1 Like

I understand because it is AUR :ok_hand:

Ask him, maybe friendly, if he update. :wink:

1 Like

No need to build, its in repo now.

1 Like

sudo is currently (2021-01-30T00:00:00Z) 1.9.5.p2-1, so your local database is out-of-date.

@jonathon it says I'm up to date, already clicked Refresh.

With Arch I can build java-16 perfectly. It's Garuda problem.

That doesn't mean your mirror is up-to-date, just that your local database copy is the same as the mirror database copy.

You'd get the same issue on any Arch-based distro with an out-of-date mirror.

Try pacman -Syu and then trying a different mirror before blaming Garuda.

Using which approach? Pamac? makepkg? yay? aurutils?

2 Likes

For someone claiming to be an Arch user you sure don't understand how Arch updates work very well. You also have issues following the caveats given on the downloads page it seems. The downloads page specifically states it is not recommended to install Garuda in a VM, yet:

Your prior help request today was a direct result of running a program known to not work correctly with Garuda in a VM, in a VM, (against the distros reccomendations). To make matters worse, you weren't even up front about using a VM when you made your help request. You are simply wasting forum staff's support time with your malformed requests.

You created several help requests within minutes of each other today for no other reason than your poor understanding of how your system works, or a failure to heed distro warnings.

Both of your help requests today were a total waste of support resources. If you insist on running your Garuda system in a VM that is your prerogative. However, I would suggest you take your support requests to the Garuda Sub-Reddit in the future and waste their time rather than ours if running a VM.

Either that, or install your system to bare metal as is recommended if you'd like to receive support on the Garuda forum in the future.

The low quality of both the threads you created today almost comes off as trolling they are so poor. Complaining that Arch works properly and Garuda doesn't when it was your failure to update your mirrors correctly does not exactly endear you to support staff here. From a user claiming to be running Arch I would expect a far higher degree of self sufficiency. Perhaps you need to research your issues a little more carefully before opening help requests (as any Arch user should already be aware).

Don’t be “that guy”.

http://slash7.com/2006/12/22/vampires/

2 Likes

I understand that, however I must test things under a virtual machine first. Plus building openjdk successfully has nothing do to with a virtual machine. Other Arch-based distros do build this package under same vm.

I made the bug report about the Latte dock which is broken, and that's not some gimmick. I am a real user not a lamer.


I think also that Garuda can be run perfectly fine under a virtual machine, except that you have to do a PCI passthrough of a dedicated graphics card, which I can't do because I'm using a laptop. Using PC tower you can do that but I'm not there yet.

If you search the forum, that error generally does not affect things in most cases.

2 Likes

   

1 Like

Pamac 10.0.4-2