Unable to add users

I've tried the User Account GUI and the Users GUI but both failed. Wouldn't want to try useradd in terminal unless i know it won't break my current user settings

The only accounts i have is ant(me) and guest

inxi
System:
Kernel: 5.16.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=dfdecdea-88d7-4479-b2aa-bf6c80e3b362 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=8c28f056-80ec-48c1-9f41-d88f658149d2 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Hewlett-Packard product: HP EliteBook 8540w v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Hewlett-Packard model: 1521 v: KBC Version 32.36
serial: <superuser required> BIOS: Hewlett-Packard v: 68CVD Ver. F.60
date: 11/11/2015
Battery:
ID-1: BAT0 charge: 44.2 Wh (99.8%) condition: 44.3/44.3 Wh (100.0%)
volts: 12.5 min: 10.8 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: N/A
CPU:
Info: model: Intel Core i7 Q 840 bits: 64 type: MT MCP arch: Nehalem
family: 6 model-id: 0x1E (30) stepping: 5 microcode: 0xA
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1197 min/max: 1199/1867 boost: enabled scaling:
driver: acpi-cpufreq governor: schedutil cores: 1: 1197 2: 1197 3: 1197
4: 1197 5: 1197 6: 1197 7: 1197 8: 1197 bogomips: 29793
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Madison [Mobility Radeon HD 5730 / 6570M]
vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu
bus-ID: 01:00.0 chip-ID: 1002:68c0 class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: LVDS res: 1920x1080 hz: 60
OpenGL:
renderer: AMD REDWOOD (DRM 2.50.0 / 5.16.2-zen1-1-zen LLVM 13.0.0)
v: 3.3 Mesa 21.3.4 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:3b56 class-ID: 0403
Device-2: AMD Redwood HDMI Audio [Radeon HD 5000 Series]
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 1002:aa60 class-ID: 0403
Sound Server-1: ALSA v: k5.16.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel 82577LM Gigabit Network vendor: Hewlett-Packard
driver: e1000e v: kernel port: 6020 bus-ID: 00:19.0 chip-ID: 8086:10ea
class-ID: 0200
IF: enp0s25 state: down mac: <filter>
Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel
bus-ID: 44:00.0 chip-ID: 8086:4238 class-ID: 0280
IF: wlo1 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: docker0 state: down mac: <filter>
IF-ID-3: tap-easytether state: unknown speed: 10 Mbps duplex: full
mac: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 328.11 GiB (35.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0001
scheme: MBR
Partition:
ID-1: / raw-size: 916.59 GiB size: 916.59 GiB (100.00%)
used: 328.11 GiB (35.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 916.59 GiB size: 916.59 GiB (100.00%)
used: 328.11 GiB (35.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 916.59 GiB size: 916.59 GiB (100.00%)
used: 328.11 GiB (35.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 916.59 GiB size: 916.59 GiB (100.00%)
used: 328.11 GiB (35.8%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.56 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 14.92 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
System Temperatures: cpu: 56.0 C mobo: 0.0 C gpu: radeon temp: 62.5 C
Fan Speeds (RPM): N/A
Info:
Processes: 358 Uptime: 2h 14m wakeups: 2 Memory: 13.56 GiB
used: 4.62 GiB (34.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 2248 lib: 506 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12

I just made a test account on mine using the Garuda Settings GUI and it worked. Are you using the Garuda Settings GUI, or are you using a KDE thing?

2 Likes

I'm using the Garuda Settings GUI and i just tried it agian with, "Failed to add user"

image

Work here too, what did you change?
Maybe reboot help (most of the time in KDE :wink: )

BTW, System Settings from KDE not Garuda Settings GUI.

3 Likes

Figured it out. There was remaining lock files and they are usually removed but they weren't for some reason. I'll leave a link to where I found how to fix it

After that you can then mark this post as a solution :smiley: , maybe.

Summary

2 Likes

How do I do that?

Without link, no solution.

1 Like

How did you do it in the end? I have the same problem.

Hi there, welcome to the community.

You have to remove following files in above question.

passwd.lock , group.lock , gshadow.lock , shadow.lock

in /etc/ , if they exist.
So, command should look like this

cd /etc

Then,

sudo rm passwd.lock  group.lock  gshadow.lock shadow.lock

Also, you should create backup of these files too before removing them.

PS : It is preferred that you should create a new thread instead of necro bumping. But as it is just 4 days old, I would not move it to new thread.

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.