Unable go into desktop

The Issue

Whenever I boot my laptop, I'm presented with the option to log in with my user or a Guest account
After selecting my user, entering the password and confirming, it shows a black screen and comes back to screen with my user and guest account.

What I did that caused the problem

My laptop had all the chaotic-nvidia-... packages. I uninstaled them using pacman, and installed the dkms-package as instructed by NVIDIA acrh wiki instalation page.

Why did I do this?

My laptop has 2 GPU's:

  • Intel Onboard GPU - Intel HD Graphics 630 (rev04)
  • Discrete GPU - NVIDIA GP107M (GeForce GTX 1050 Ti Mobile) (rev a1)

Since about a month ago I started having some issues with Wine, where I was unable to open anything through it.
I solved half of that issue, and could now open things through wine. As long as It didn't need Vulkan.
After some research I came to the conclusion that the problem for this could be my GPU drivers.

In an attempt to solve the issue and at the same time install bumblebee. I did this.

What can I do to solve the issue?

Please, one problem = one topic

Use forum search function = prime

And then?

Read

please
and post

inxi -Fza

as text!

Even if you personally think it is unnecessary.

and
:slight_smile:

5 Likes

I am talking about a single issue here, I am presenting what is happening because of it what I did that caused the problem.
It is "one problem = one topic"

The 2 GPU's I mentioned are to give context of the machine and why I did it.

As of right now I cant enter in desktop, so using prime is useless.

What I need is to know how can I enter the desktop.

When I say [quote="XikoCat, post:1, topic:10092"]
it shows a black screen and comes back to screen with my user and guest account.
[/quote]

My inxi -Fza:

System:    Kernel: 5.12.13-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=1af946aa-7cac-477e-9635-572097cd1bf7 rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Console: tty 5 DM: GDM 40.0 Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: HP product: OMEN by HP Laptop 17-an0xx v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 8392 v: 40.28 serial: <filter> UEFI: American Megatrends v: F.19 date: 04/18/2019 
Battery:   ID-1: BAT0 charge: 58.9 Wh (79.3%) condition: 74.3/74.3 Wh (100.0%) volts: 15.6 min: 14.6 model: HP Primary 
           type: Li-ion serial: N/A status: Unknown 
CPU:       Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: 9 microcode: EA cache: L2: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798 
           Speed: 3673 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3673 2: 3602 3: 3719 4: 3601 5: 3805 6: 3601 7: 3601 
           8: 3601 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:591b 
           class-ID: 0300 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Hewlett-Packard driver: N/A alternate: nouveau 
           bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300 
           Device-3: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD Camera type: USB driver: uvcvideo bus-ID: 1-6:4 
           chip-ID: 05c8:03ab class-ID: 0e02 
           Display: server: X.org 1.20.11 compositor: gnome-shell driver: loaded: nvidia tty: 240x67 
           Message: Advanced graphics data unavailable in console. Try -G --display 
Audio:     Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           chip-ID: 8086:a171 class-ID: 0403 
           Device-2: Kingston HyperX 7.1 Audio type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 
           chip-ID: 0951:16a4 class-ID: 0300 serial: <filter> 
           Sound Server-1: ALSA v: k5.12.13-zen1-2-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.31 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: d000 bus-ID: 3b:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: d000 bus-ID: 3c:00.0 chip-ID: 8086:095a 
           class-ID: 0280 
           IF: wlo1 state: down mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:5 chip-ID: 8087:0a2a 
           class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 539.31 GiB (46.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLW256HEHP-000H1 size: 238.47 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: CXB73H1Q scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 4B6Q scheme: MBR 
Partition: ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 147.52 GiB (61.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 147.52 GiB (61.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 147.52 GiB (61.9%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 147.52 GiB (61.9%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 54.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 264 Uptime: 3h 12m wakeups: 1 Memory: 15.51 GiB used: 2.08 GiB (13.4%) Init: systemd v: 248 
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1830 lib: 512 Shell: fish (login) v: 3.2.2 
           running-in: tty 5 inxi: 3.3.04 

Have you tried restoring the latest working snapshot?
Alternatively, you could log in to a tty to uninstall or install what's needed.

4 Likes

I have restored now
Everything is fine now

Thank you

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.