UFW not installed though firewall enabled

Hello, complete newbie here, recently installed garuda dr46onized gaming, and in reading the wiki, I’m supposed to set up a firewall for security/privacy. but each time i run the command

sudo systemctl enable --now ufw & ufw enable

I get the reply

Failed to enable unit: Unit ufw.service does not exist

I did some light general searching on the forum and general fireDragon engine, but have not found anything useful, maybe I’ve not searched well enough?
How can i enable ufw for my firewall?

UFW is not installed by default.

sudo pacman -S ufw

Then you can enable the service.

sudo systemctl enable --now ufw.service

Set whatever rules you want.

sudo ufw default deny
sudo ufw allow from 192.168.0.0/24

And so on. Finally, bring up the firewall.

sudo ufw enable

See also this article: Uncomplicated Firewall - ArchWiki

9 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.