Two finger controls not working on touchpad after sleep?

Hello!

I've been using Garuda for a few days now and I'm really enjoying the OS!

That said, I've noticed issues when I put my laptop to sleep and then wake it.

The issue is that my touchpad stops working correctly. Sometimes tapping, scrolling and two finger controls don't work, but most of the time it's just the two finger gestures. So, scrolling, right click and so on do not work. The only solution I have found so far is restarting the laptop.

I'm using a ThinkPad T440, alongside a Synaptics Touchpad.

Operating System: Garuda Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.10-115-tkg-bmq
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-4300U CPU @ 1.90GHz
Memory: 7,5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4400

Let me know if I can provide any further information.

Any help would be much appreciated!

Thank you,
Olat

Hey, I got almost the same model (T440p with synaptics touchpad) which works without issues. What DE are you using?

1 Like

check if this works

3 Likes

@dr460nf1r3 Hey! Thanks for replying!
I use KDE, details are in the post, if that's what you're asking.
:slightly_smiling_face:

1 Like

Hi @librewish! Thanks for replying!

I've downloaded Qwikaccess and tried that option, but it did not help...

Sorry, kind of overread that lol.
Are you using libinput gestures? Its preinstalled on KDE and its usually one of the first things I get rid off because it just works without.

2 Likes

No worries :slight_smile:

If it's preinstalled with KDE, then I am.

Should I try removing all of these, or just something specific?

if it doesnt work after suspend then its a driver issue
try different kernels

2 Likes

Hello!

Unfortunately, none of the suggestions above worked.

What did fix the issue for me (at least it seems so, I'll test it out more) was opening:

/etc/default/grub

and modifying this line to look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.synaptics_intertouch=0 rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3"

I hope this helps someone else as well.

Thank you so much for your help!

2 Likes

Another update:

my laptop just went to sleep, when I turned it on, the touchpad does not work at all.
Not sure what the issue is now, but I can't consider this resolved at this time.

Any other suggestions would be awesome!

Thank you!

bumping this one up in hopes someone has any other suggestions

No miracles available.
Without logs, there is nothing to suggest.

Arch uses libinput by default.
You used a solution for synaptics.
You have to decide/find which one to use.
Find your current mouse module and maybe add to mkinitcpio.conf (MODULES), rebuilding kernel images afterwards.

journalctl -b -k -g $(lsmod | grep  mouse | cut -d\  -f1)

https://wiki.archlinux.org/index.php/Laptop#Touchpad
You may need a udev rule to not let mouse PM(sleep).

Reading is not a sin.


Maybe you get some idea from here.

3 Likes

If you cannot resolve by testing out different kernels or changing your power saving settings then there is always the possibility of using a systemd suspend service to workaround the issue.

2 Likes

Hello!
Thanks for replying!

I've read all that you've attached, but I could not understand most of it, nor did I understand your generalized instructions. As I mentioned, I am new to this.
If reading is a sin, then I'm a huge sinner.

For whoever has the same issue, this is what I did:

Installed Nano from the Software installer.
sudo nano /etc/default/grub
Edit this line to look like this:
GRUB_CMDLINE_LINUX_DEFAULT="psmouse.synaptics_intertouch=0 quiet splash"
(if something already exists within the parentheses, add the above first)
sudo update-grub
reboot

I've been using my laptop for 2 days now, without issues.
Hopefully this is it. If it's not, I'll try again on another forum.

Thank you everyone for your help!

2 Likes

Same model but different hardware installed?
Give micro a chance no nano needed :slight_smile:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.