Trying to learn why Garuda worked and other Arch forks did not?

Hi all -

one of the ways I’ve found that I learn best is to understand why a thing happened, so this leads me to my question:

I’ve spent the last several days evaluating different Arch forks - ArcoLinux, Manjaro, RebornOS - in each case I ran into the same problem: the liveISO worked as expected with my external monitor, but it would not work after installation. I tried a number of different methods - I know that the mix of an nVidia card with the Intel CPU is often problematic. The part that I’m trying to understand is why Garuda’s KDE install worked out of the box, where the others do not? I expect it’s due to some differences in the packages, but how to determine what the differences are?

inxi below:

╰─λ garuda-inxi
System:
Kernel: 6.9.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=eadfc307-71d4-4ed7-aa5d-76d2b5355e71 rw rootflags=subvol=@
quiet resume=UUID=9d084d63-d53b-437a-8383-f14c3c9f76d8 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ROG Zephyrus M16 GU604VZ_GU604VZ
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GU604VZ v: 1.0 serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends LLC. v: GU604VZ.312
date: 09/07/2023
Battery:
ID-1: BAT0 charge: 84.0 Wh (100.0%) condition: 84.0/90.0 Wh (93.3%)
volts: 17.4 min: 16.0 model: AS3GYFG3KC R220358 type: Unknown
serial: <filter> status: full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: 13th Gen Intel Core i9-13900H bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
microcode: 0x4121
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 472 high: 1054 min/max: 400/5200:5400:4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
5: 400 6: 400 7: 679 8: 400 9: 400 10: 400 11: 1054 12: 400 13: 400
14: 400 15: 400 16: 400 17: 915 18: 400 19: 400 20: 400 bogomips: 119807
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel alternate: xe arch: Gen-13 process: Intel 7 (10nm)
built: 2022+ ports: active: DP-2 empty: DP-3 bus-ID: 0000:00:02.0
chip-ID: 8086:a7a0 class-ID: 0380
Device-2: NVIDIA AD104M [GeForce RTX 4080 Max-Q / Mobile] vendor: ASUSTeK
driver: nvidia v: 550.90.07 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ ports: active: none off: eDP-1
empty: DP-1,HDMI-A-1 bus-ID: 0000:01:00.0 chip-ID: 10de:27e0
class-ID: 0300
Device-3: Sonix USB2.0 FHD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:6 chip-ID: 3277:0018
class-ID: 0e02
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia d-rect: 5147x2507 display-ID: 0
Monitor-1: DP-2 pos: primary,top-left res: 3440x1440 size: N/A modes: N/A
Monitor-2: eDP-1 pos: bottom-r res: 1707x1067 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: nvidia x11: drv: zink
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 4080 Laptop
GPU/PCIe/SSE2 memory: 11.71 GiB display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 4 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 4080 Laptop GPU driver: nvidia v: 550.90.07
device-ID: 10de:27e0 surfaces: xcb,xlib,wayland device: 1
type: integrated-gpu name: Intel Graphics (RPL-P) driver: mesa intel
v: 24.1.1-arch1.1 device-ID: 8086:a7a0 surfaces: xcb,xlib,wayland
device: 2 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits)
driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Raptor Lake-P/U/H cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_avs,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:51ca class-ID: 0403
Device-2: NVIDIA AD104 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:22bc
class-ID: 0403
Device-3: Realtek LG Monitor Headset MIC driver: hid-generic,usbhid
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1.3:25
chip-ID: 0bda:4cb6 class-ID: 0300
Device-4: Razer USA Nari Ultimate driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1
bus-ID: 3-5.2.2.2.1.4:15 chip-ID: 1532:051a class-ID: 0300
API: ALSA v: k6.9.4-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f1 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek USB 10/100/1G/2.5G LAN driver: r8152 type: USB rev: 3.2
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 4-2.4.2.1:5
chip-ID: 0bda:8156 class-ID: 0000 serial: <filter>
IF: eth0 state: up speed: 2500 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:7 chip-ID: 8087:0033
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c010c
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Drives:
Local Storage: total: 4.57 TiB used: 12.96 GiB (0.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 990 PRO with
Heatsink 4TB size: 3.64 TiB block-size: physical: 512 B logical: 512 B
speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: 4B2QJXD7
temp: 49.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:6 vendor: SK Hynix model: HFS001TEJ9X101N
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 51000A20 temp: 44.9 C
scheme: GPT
Partition:
ID-1: / raw-size: 256 GiB size: 256 GiB (100.00%) used: 3.94 GiB (1.5%)
fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 2 GiB size: 2 GiB (99.80%) used: 584 KiB (0.0%)
fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3
ID-3: /home raw-size: 380.42 GiB size: 380.42 GiB (100.00%)
used: 2.82 GiB (0.7%) fs: btrfs dev: /dev/nvme1n1p8 maj-min: 259:14
ID-4: /usr raw-size: 1000 GiB size: 1000 GiB (100.00%)
used: 6.2 GiB (0.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/log raw-size: 256 GiB size: 256 GiB (100.00%)
used: 3.94 GiB (1.5%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-6: /var/tmp raw-size: 256 GiB size: 256 GiB (100.00%)
used: 3.94 GiB (1.5%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.97 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme1n1p7 maj-min: 259:13
Sensors:
System Temperatures: cpu: 44.0 C mobo: N/A
Fan Speeds (rpm): cpu: 2200
Info:
Memory: total: 32 GiB note: est. available: 30.97 GiB used: 3.59 GiB (11.6%)
Processes: 438 Power: uptime: 38m states: freeze,mem,disk suspend: s2idle
avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.35 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1477 libs: 421 tools: octopi,paru Compilers:
gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole
inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-06-15
Last full system update: 2024-06-15 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:
1 Like

Apart from the fact that this is surely a trade secret,
why should we examine three other distributions for differences and errors?

5 Likes

My mistake - I presumed that this was likely a case of a mistake on my part - a missing package, or additional configuration necessary to allow one Arch fork to work similarly to Garuda. Apologies if I was stepping on trade secrets - it was simply an effort to understand why one thing worked when another did not. If the answer is proprietary, that’s good enough for me :slight_smile:

I am certain SGS is joking about the trade secret–the entire project is open source, of course. :face_with_hand_over_mouth:

He has a point about the other distributions though. If something isn’t working on those other installations, you should follow up with those specific projects. Maybe there is a problem they need to fix.

Off the top of my head, the primary difference I would think of is Garuda Linux uses a different kernel by default (the Zen kernel) than a standard Arch installation, and because of that you are using a different Nvidia driver package (nvidia-dkms). Sometimes when something hardware-related isn’t working right, just changing to a different kernel can yield a different result.

The live environment may have a different kernel version than the final installation, after the updates and all are pulled down. It may be as simple as running into a kernel regression, or a problem with the standard nvidia driver package that for whatever reason is not affecting nvidia-dkms

If you are very curious, it would be interesting to see what result you get on those other distros if you install the Zen kernel and nvidia-dkms.

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.