Troubleshooting graphics issues

Hello all
Here is my garuda-inxi

  Kernel: 6.1.11-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8a404225-49ce-4c8d-a40f-9a82f0f45d62 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
  Mobo: ASUSTeK model: ROG STRIX B550-F GAMING v: Rev X.0x serial: <filter>
    UEFI: American Megatrends v: 2006 date: 03/19/2021
  Info: model: AMD Ryzen 9 5950X socket: AM4 bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
  Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
    L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 2350 high: 3400 min/max: 2200/5083 boost: enabled
    base/boost: 3400/5050 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 2200 2: 2200 3: 2200 4: 2200
    5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
    13: 2200 14: 2200 15: 2200 16: 2200 17: 3400 18: 2200 19: 3400 20: 2200
    21: 2200 22: 2200 23: 2200 24: 2200 25: 3400 26: 2200 27: 2200 28: 2200
    29: 3400 30: 2200 31: 2200 32: 2200 bogomips: 217180
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX] vendor: XFX
    driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
    built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-2,DP-3,HDMI-A-1 empty: DP-1 bus-ID: 0d:00.0 chip-ID: 1002:744c
    class-ID: 0300
  Device-2: MACROSILICON ShadowCast type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 3-1:2
    chip-ID: 298f:1996 class-ID: 0300
  Device-3: Microsoft Modern Webcam type: USB
    driver: hid-generic,usbhid,uvcvideo bus-ID: 5-3:4 chip-ID: 045e:0840
    class-ID: 0300 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6400x1440 s-dpi: 96 s-size: 1688x380mm (66.46x14.96")
    s-diag: 1730mm (68.12")
  Monitor-1: DP-2 mapped: DisplayPort-1 pos: center model: AAA built: 2012
    res: 1920x1080 hz: 60 dpi: 85 size: 575x323mm (22.64x12.72") modes:
    max: 1920x1080 min: 720x400
  Monitor-2: DP-3 mapped: DisplayPort-2 pos: right model: Asus VE228
    serial: <filter> built: 2015 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-3: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left
    model: LG (GoldStar) HDR WFHD serial: <filter> built: 2020 res: 2560x1440
    hz: 60 dpi: 81 gamma: 1.2 size: 798x334mm (31.42x13.15")
    diag: 869mm (34.2") modes: max: 2560x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.4 renderer: AMD Radeon Graphics (gfx1100
    LLVM 15.0.7 DRM 3.49 6.1.11-zen1-1-zen) direct-render: Yes
  Device-1: AMD driver: snd_hda_intel v: kernel bus-ID: 3-1:2 pcie: gen: 4
    chip-ID: 298f:1996 class-ID: 0300 speed: 16 GT/s lanes: 16 bus-ID: 0d:00.1
    chip-ID: 1002:ab30 class-ID: 0403
  Device-2: MACROSILICON ShadowCast type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
  Sound API: ALSA v: k6.1.11-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp7s0 state: up mac: <filter>
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 0a:00.0
    chip-ID: 8086:15f3 class-ID: 0200
  IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
    bus-ID: 6-1:2 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: enp15s0f3u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-153b2748496c state: down mac: <filter>
  IF-ID-2: br-15ba0926c9ea state: down mac: <filter>
  IF-ID-3: br-7421d839c2f0 state: down mac: <filter>
  IF-ID-4: br-9cbb2be322df state: down mac: <filter>
  IF-ID-5: br-a123b540d91e state: down mac: <filter>
  IF-ID-6: docker0 state: down mac: <filter>
  IF-ID-7: virbr0 state: down mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-7.2:5 chip-ID: 8087:0032 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 5.91 TiB used: 2.68 TiB (45.3%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS500G3X0C-00SJG0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 111110WD temp: 41.9 C scheme: GPT
  SMART: yes health: PASSED on: 1y 166d 6h cycles: 100
    read-units: 4,844,744 [2.48 TB] written-units: 2,022,779 [1.03 TB]
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Crucial model: CT4000P3PSSD8
    size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: P9CR40A temp: 35.9 C scheme: GPT
  SMART: yes health: PASSED on: 6d 21h cycles: 12
    read-units: 1,046,794 [535 GB] written-units: 5,796,833 [2.96 TB]
  ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-08WN4A0 family: Blue size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: 1A02 temp: 28 C
  SMART: yes state: enabled health: PASSED on: 1y 301d 5h cycles: 102
  ID-4: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000BX500SSD1
    family: Micron Client SSDs size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B sata: 3.3 speed: 6.0 Gb/s type: SSD serial: <filter>
    rev: 056 temp: 26 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 7d 11h cycles: 12
    written: 511.72 GiB
  ID-1: / raw-size: 465.47 GiB size: 465.47 GiB (100.00%)
    used: 18.48 GiB (4.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 3.64 TiB size: 3.64 TiB (100.00%)
    used: 1.65 TiB (45.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p1
    maj-min: 259:4
  ID-4: /var raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
    used: 372.17 GiB (40.0%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
    maj-min: 8:17
  ID-5: /var/log raw-size: 465.47 GiB size: 465.47 GiB (100.00%)
    used: 18.48 GiB (4.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-6: /var/tmp raw-size: 465.47 GiB size: 465.47 GiB (100.00%)
    used: 18.48 GiB (4.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 62.68 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 39.2 C mobo: N/A gpu: amdgpu temp: 52.0 C
    mem: 66.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 564
  Processes: 589 Uptime: 17h 47m wakeups: 0 Memory: 62.68 GiB
  used: 11.18 GiB (17.8%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1737
  libs: 539 tools: octopi,paru,yay Shell: garuda-inxi (sudo) default: Bash
  v: 5.1.16 running-in: terminology inxi: 3.3.25
Garuda (2.6.14-1):
  System install date:     2023-02-06
  Last full system update: 2023-02-11
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

I have looked around online to see where to look for these details required for troubleshooting my desktop environment freezing while playing one particular wine game. After the lock-up everything closes and goes to the login screen. This is an improvement after refreshing with a nightly test build posted on Feb 4 2023. Prior to that, I had to hard reset the computer and boot it again. Since the graphics card shown above worked fine and I have updated and reinstalled most of the packages after setting up the nightly I do not think reinstalling with a newer installer will do the trick.

I'm trying for the first step of resolving the issue, where to look in the logs. Through googling on my phone I have looked in demesg after the freeze and the x logs but haven't found anything that would point me to what is triggering the problem. Are there other places I can't find/didn't think of where I could look? While typing this I am tempted to see if it's a temp issue with the card. I'll be testing that while seeing if I could get some pin pointed help here!

I'm assuming the issue has to do with X, but I haven't tried installing KDE wayland on this newer install to see if the issue persists while using wayland.

steam-native &| tee ~/log.txt if running fish OR steam-native | tee ~/log.txt if running bash will show you ALOT of the output of steam and the game it tries to run. simply run either command(based on which is the default on your garuda(dragonized kde uses fish by default)) and you will end up with a log file of the entire session. i don't know if that would be valuable or not however, if it is it will be quite valuable.

BE WARNED!!!! that log file could end up huge, so if you don't have alot of free space on your home partition modify the tee command to have it use a different partion, or knock off the ~/ and run it on another partition with lots of free space.


Thanks for the suggestion, but I'm running this outside of steam. When I have steam issues I do have the steam launcher running in terminal on a different monitor.

you could then add the &| tee ~/log.txt to the end of either you're wine launch, or if you launch it directly from konsole. the &| (or just | in bash) just pipes the output of a command. tee will copy the output to your terminal window(STDOUT) AND a file(or elsewhere, but that is a bit more than this conversation). this will NOT stop a game from running, you just gotta get it into the command that is run.

[ 76355.766] (EE) Backtrace:
[ 76355.766] (EE) 0: /usr/lib/Xorg (dri3_send_open_reply+0xdd) [0x5567d37159ad]
[ 76355.766] (EE) 1: /usr/lib/ (__sigaction+0x50) [0x7ff46df3af50]
[ 76355.767] (EE) 2: /usr/lib/ (pthread_setaffinity_np+0x4) [0x7ff46df8e194]
[ 76355.767] (EE) 3: /usr/lib/dri/ (__driDriverGetExtensions_d3d12+0x1457d) [0x7ff46b6bda9d]
[ 76355.767] (EE) 4: /usr/lib/dri/ (__driDriverGetExtensions_d3d12+0x598101) [0x7ff46bc41621]
[ 76355.767] (EE) 5: /usr/lib/dri/ (__driDriverGetExtensions_d3d12+0xc146f) [0x7ff46b76a98f]
[ 76355.767] (EE) 6: /usr/lib/dri/ (__driDriverGetExtensions_d3d12+0x1c71a5) [0x7ff46b8706c5]
[ 76355.767] (EE) 7: /usr/lib/xorg/modules/ (glamor_change_window_attributes+0x2358) [0x7ff46b5e85a8]
[ 76355.768] (EE) 8: /usr/lib/Xorg (RRXineramaExtensionInit+0x300c) [0x5567d368919c]
[ 76355.768] (EE) 9: /usr/lib/xorg/modules/ (glamor_name_from_pixmap+0xc26d) [0x7ff46b5e5b8d]
[ 76355.768] (EE) 10: /usr/lib/xorg/modules/ (glamor_name_from_pixmap+0xc6f8) [0x7ff46b5e6018]
[ 76355.768] (EE) 11: /usr/lib/Xorg (ChangePicture+0x1d9a) [0x5567d369276a]
[ 76355.768] (EE) 12: /usr/lib/Xorg (SProcXkbDispatch+0x27e3) [0x5567d35f8ebf]

I found a backtrace after the lockup in Xorg logs. it seems like the radeon driver crashed. The is part of mesa which is up to date. It seems I need to come up with another log to find.

This seems to have panned out with new mesa, vulkan, llvm, and a power state update on kernel 6.2.0

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.