Touchpad Scrolling sensitivity too high

Hello guys,

I have a SynPS/2 Synaptics TouchPad and I have installed xf86-input-synaptics drivers which allows me to change a lot. But the scrolling sensitivity/speed is too high and I can't find an option to reduce that.

Is there a way I can reduce it?

Thank you

Please provide your inxi -Faz as text and formatted, as per new topic template.

1 Like
System:    Kernel: 5.14.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 

parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=fe1af568-2885-4a8e-bc9a-c6b70a7e48bf 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 

Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 

Distro: Garuda Linux base: Arch Linux 

Mobo: WALTON model: WTEX4105SL serial: <filter> UEFI: INSYDE v: 1.07.03TWM date: 08/22/2019 

Battery:   ID-1: BAT0 charge: 34.4 Wh (98.6%) condition: 34.9/35.3 Wh (98.9%) volts: 12.6 min: 11.4 

model: Notebook BAT type: Li-ion serial: <filter> status: Discharging 

CPU:       Info: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP arch: Kaby Lake note: check 

family: 6 model-id: 8E (142) stepping: C (12) microcode: EA cache: L2: 6 MiB 

flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33599 

Speed: 1593 MHz min/max: 400/1600 MHz Core speeds (MHz): 1: 1593 2: 1487 3: 1578 4: 1549 
5: 1585 6: 1598 7: 1575 8: 1595 

Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 

Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
Type: srbds mitigation: TSX disabled 
Type: tsx_async_abort status: Not affected 

Graphics:  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel 

bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300 
Device-2: Chicony Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-7:3 
chip-ID: 04f2:b649 class-ID: 0e02 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7") diag: 354mm (13.9") 
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.2 direct render: Yes 
Audio:     Device-1: Intel Comet Lake PCH-LP cAVS vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:02c8 class-ID: 0403
Sound Server-1: ALSA v: k5.14.7-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.37 running: yes
Network:   Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel port: 5000
bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280

IF: wlp0s20f3 state: up mac: <filter>

Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK

driver: r8169 v: kernel port: 3000 bus-ID: 06:00.1 chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0f1 state: down mac: <filter>

Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8

bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001

Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
hardware: no software: yes address: <filter>

Drives:    Local Storage: total: 476.94 GiB used: 12.1 GiB (2.5%)

SMART Message: Unable to run smartctl. Root privileges required.

ID-1: /dev/sda maj-min: 8:0 model: IM3D B16A SSD size: 476.94 GiB block-size: physical: 512 B

logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 7A0 scheme: GPT

Partition: ID-1: / raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 12.07 GiB (30.9%) fs: btrfs
dev: /dev/sda7 maj-min: 8:7
ID-2: /boot/efi raw-size: 99 MiB size: 95 MiB (95.96%) used: 28.2 MiB (29.7%) fs: vfat
dev: /dev/sda2 maj-min: 8:2
ID-3: /home raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 12.07 GiB (30.9%) fs: btrfs
dev: /dev/sda7 maj-min: 8:7
ID-4: /var/log raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 12.07 GiB (30.9%) fs: btrfs
dev: /dev/sda7 maj-min: 8:7
ID-5: /var/tmp raw-size: 39.06 GiB size: 39.06 GiB (100.00%) used: 12.07 GiB (30.9%) fs: btrfs
dev: /dev/sda7 maj-min: 8:7
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)

ID-1: swap-1 type: zram size: 7.46 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0

Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A

Fan Speeds (RPM): N/A

Info:      Processes: 261 Uptime: 3m wakeups: 2 Memory: 7.46 GiB used: 2.31 GiB (30.9%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1271 apt: 1 pacman: 1270
lib: 336 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

First off, I'd check touchpad in system settings and relevant options.
But I guess you already did it.
You then could check here.
https://wiki.archlinux.org/title/Touchpad_Synaptics#Frequently_used_options
E.g., but not limited to:
If your touchpad is too sensitive, use higher values for FingerLow and FingerHigh and vice versa. Remember that FingerLow should be smaller than FingerHigh

1 Like

Hello,

Thanks for that.

I realized that the config file is not working. I disabled touchpad and it is still working. What am I doing wrong? Do I need to do a restart after editing a config file?

I think a reboot is always the best solution, although after xorg changes you have to restart the X server (so maybe a logoff/logon would be ok, even just a startx).

Maybe it is not working due to this initial warning in the wiki?

This article details the installation and configuration process of the Synaptics input driver for Synaptics (and ALPS) touchpads found on most notebooks.

Warning: xf86-input-synaptics is no longer actively updated. If possible, use libinput. For some reasons why you might still prefer xf86-input-synaptics, see, e.g. [1] and [2].

Note: If you want to configure touchpad via GNOME Settings, you need to use the libinput driver.[3]

4 Likes

Yes thank you.

Changing VertScrollDelta did the trick for me. I set it to around -260.

PS:
This article also helped me - Finally real smooth scrolling on Linux with the touchpad and Chrome 54

1 Like

Sure, so the wiki for synaptics worked :wink:.
Should be this part
https://wiki.archlinux.org/title/Touchpad_Synaptics#Natural_scrolling

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.