Timeshift crash during setup after snapshot restore

Hi, I'm stuck with this so any help greatly appreciated. After a bungled pamac/pacman update I needed to do a system restore from snapshot; did as follows:

  1. booted into my selected snapshot from grub
  2. fired up timeshift gui and selected the next previous snapshot, clicked restore - no errors returned.
  3. rebooted into newly restored system
  4. fired up timeshift again and it looked as if it hadn't been set up (ie no snapshots visible)
  5. clicked into timeshift "wizard" and clicked "btrfs" as preferred snapshot type.
  6. timeshift crashed and exited. This behaviour happens on every try.
  7. launched from cli - sudo timeshift-launcher to find out what errors might be occuring. After clicking "btrfs" as prefered snapshot type same crash occured and the following was visible in the terminal:

/dev/sda2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

/usr/bin/timeshift-launcher: line 30: 380166 Segmentation fault (core dumped) ${app_command}

Additionally (and possibly less important) - prior to the above error on crashing, the following was produced while timeshift is still running:

(timeshift-gtk:380166): Gtk-WARNING **: 18:41:17.856: Theme parsing error: gtk-dark.css:6342:10: 'height' is not a valid property name

** (timeshift-gtk:380166): WARNING **: 18:41:17.889: Unable to connect to dbus: Error spawning command line β€œdbus-launch --autolaunch=05d1bb4b8266422a868697742a504ed8 --binary-syntax --close-stderr”: Child process exited with code 1
[Warning] Deleted invalid lock
App config loaded: /etc/timeshift/timeshift.json

/dev/sda2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

(timeshift-gtk:380166): GLib-GIO-CRITICAL **: 18:41:18.076: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

Please help me fix my timeshift! Cheers :smiley:

Did you read


Post in- and output from terminal as text.

sudo timeshift --list
lsblk --paths --tree --include 8 --output ptuuid,pttype,partuuid,partlabel,name,fstype,label,mountpoint

Did you install Garuda on Btrfs file system?

Why nobody fix this? :wink:

it must be 'min-height' not 'height'

1 Like

Thanks for reply. Of course this is a btrfs install! :wink: .I did not read prior Restoring System Back To Working State | Garuda Linux wiki
However I just read it now and looks like I did exactly per instruction set. FYI as requested:

$ sudo timeshift --list
[sudo] password for rob:
Another instance of this application is running (PID=183884)

This is a strange response as I looked through the applications and processes of "System Monitor" plasma app and could not find the "Another instance" running. then I did:

$ lsblk --paths --tree --include 8 --output ptuuid,pttype,partuuid,partlabel,name,fstype,label,mountpoint
9310ea40-f63b-e44d-ae4d-e896c3cd7788 gpt /dev/sda
9310ea40-f63b-e44d-ae4d-e896c3cd7788 gpt 71cfd429-f957-9f4c-b43e-d99d202a494c β”œβ”€/dev/sda1
β”‚ vfat NO_LABEL
β”‚ /boot/efi
9310ea40-f63b-e44d-ae4d-e896c3cd7788 gpt ece7908f-e7af-524e-82b1-94705ecf71f8 └─/dev/sda2
btrfs /run/times

Additionally the output of snapshots are as follows (the .snapshot ones are from Snapper which I also tried briefly when I discovered Timeshift wasn't working):

$ sudo btrfs subvolume list /
[sudo] password for rob:
ID 256 gen 60762 top level 5 path timeshift-btrfs/snapshots/2021-07-03_11-08-12/@
ID 257 gen 62744 top level 5 path @home
ID 258 gen 61929 top level 5 path @root
ID 259 gen 60881 top level 5 path @srv
ID 260 gen 62740 top level 5 path @cache
ID 261 gen 62744 top level 5 path @log
ID 262 gen 61945 top level 5 path @tmp
ID 487 gen 61770 top level 5 path timeshift-btrfs/snapshots/2021-06-17_10-22-22/@
ID 490 gen 61770 top level 5 path timeshift-btrfs/snapshots/2021-06-17_15-12-30/@
ID 571 gen 61723 top level 5 path timeshift-btrfs/snapshots/2021-07-03_11-28-43/@
ID 575 gen 61723 top level 5 path timeshift-btrfs/snapshots/2021-08-21_15-07-23/@
ID 694 gen 61723 top level 5 path timeshift-btrfs/snapshots/2021-08-22_10-30-56/@
ID 699 gen 61723 top level 5 path timeshift-btrfs/snapshots/2021-08-21_16-18-06/@
ID 700 gen 61724 top level 5 path timeshift-btrfs/snapshots/2021-08-21_16-42-01/@
ID 701 gen 61723 top level 5 path timeshift-btrfs/snapshots/2021-08-21_18-24-10/@
ID 702 gen 60823 top level 5 path timeshift-btrfs/snapshots/2021-08-22_10-47-24/@
ID 703 gen 62740 top level 5 path @
ID 709 gen 62692 top level 703 path .snapshots
ID 710 gen 61346 top level 709 path .snapshots/1/snapshot
ID 711 gen 61348 top level 709 path .snapshots/2/snapshot
ID 712 gen 61349 top level 709 path .snapshots/3/snapshot
ID 713 gen 61354 top level 709 path .snapshots/4/snapshot
ID 714 gen 61355 top level 709 path .snapshots/5/snapshot
ID 715 gen 61437 top level 709 path .snapshots/6/snapshot
ID 716 gen 61368 top level 709 path .snapshots/7/snapshot
ID 717 gen 61517 top level 709 path .snapshots/8/snapshot
ID 718 gen 61519 top level 709 path .snapshots/9/snapshot
ID 719 gen 61534 top level 709 path .snapshots/10/snapshot
ID 720 gen 61535 top level 709 path .snapshots/11/snapshot
ID 721 gen 61550 top level 709 path .snapshots/12/snapshot
ID 722 gen 61672 top level 709 path .snapshots/13/snapshot
ID 723 gen 61692 top level 709 path .snapshots/14/snapshot
ID 724 gen 61694 top level 709 path .snapshots/15/snapshot
ID 725 gen 61816 top level 709 path .snapshots/16/snapshot
ID 757 gen 61887 top level 709 path .snapshots/17/snapshot
ID 758 gen 61889 top level 709 path .snapshots/18/snapshot
ID 790 gen 62185 top level 709 path .snapshots/19/snapshot
ID 799 gen 62691 top level 709 path .snapshots/20/snapshot

Thanks :smiley:

Please read also :slight_smile:

I fixed your terminal output's, now we can use the copy icon upper right.

and post terminal in- and output from

inxi -Faz

as text!

killall timeshift
killall timeshift-launcher

But there are timeshift snapshots.

Try restore with

sudo timeshift --restore

There are a lot of snapper snapshots (I think, never seen before), Garuda do not use snapper, because the experience with it was not so good.

Thanks. FYI as request:

$ inxi -Faz                                                                                                                        22.Aug.2021   9.26pm
System:    Kernel: 5.13.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0                                                                           
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=68c70d59-7ec4-47a5-bc2d-451cdf643b2d rw  
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux  
base: Arch Linux  
Machine:   Type: Laptop System: Hewlett-Packard product: HP EliteBook 850 G2 v: A3008C510B03 serial: <filter> Chassis:  
type: 10 serial: <filter>  
Mobo: Hewlett-Packard model: 2216 v: KBC Version 96.5B serial: <filter> UEFI: Hewlett-Packard v: M71 Ver. 01.31  
date: 02/24/2020  
Battery:   ID-1: BAT0 charge: 30.8 Wh (60.7%) condition: 50.7/50.7 Wh (100.0%) volts: 11.0 min: 11.4  
model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Discharging  
CPU:       Info: Dual Core model: Intel Core i5-5300U bits: 64 type: MT MCP arch: Broadwell family: 6 model-id: 3D (61)  
stepping: 4 microcode: 2F cache: L2: 3 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18356  
Speed: 2675 MHz min/max: 500/2900 MHz Core speeds (MHz): 1: 2675 2: 2674 3: 2656 4: 2666  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable  
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard ZBook 15u G2 Mobile Workstation driver: i915 v: kernel  
bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300  
Device-2: Advanced Micro Devices [AMD/ATI] Opal PRO [Radeon R7 M260X] vendor: Hewlett-Packard driver: radeon  
v: kernel alternate: amdgpu bus-ID: 04:00.0 chip-ID: 1002:6605 class-ID: 0300  
Device-3: Cheng Uei Precision Industry (Foxlink) HP EliteBook integrated HD Webcam type: USB driver: uvcvideo  
bus-ID: 2-7:5 chip-ID: 05c8:0374 class-ID: 0e02  
Display: wayland server: X.Org compositor: kwin_wayland driver: loaded: ati,intel,radeon  
unloaded: modesetting alternate: fbdev,vesa display-ID: :1 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: XWAYLAND0 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")  
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.2.1 direct render: Yes  
Audio:     Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:03.0  
chip-ID: 8086:160c class-ID: 0403  
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel  
bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403  
Sound Server-1: ALSA v: k5.13.12-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.33 running: yes  
Network:   Device-1: Intel Ethernet I218-LM vendor: Hewlett-Packard driver: e1000e v: kernel port: 6080 bus-ID: 00:19.0  
chip-ID: 8086:15a2 class-ID: 0200  
IF: enp0s25 state: down mac: <filter>  
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: ef80 bus-ID: 03:00.0 chip-ID: 8086:095a  
class-ID: 0280  
IF: wlo1 state: up mac: <filter>  
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 2-4:3 chip-ID: 8087:0a2a  
class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>  
Drives:    Local Storage: total: 238.47 GiB used: 184.93 GiB (77.5%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD7SB6S-256G-1006 size: 238.47 GiB block-size: physical: 4096 B  
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1006 scheme: GPT  
Partition: ID-1: / raw-size: 238.22 GiB size: 238.22 GiB (100.00%) used: 184.87 GiB (77.6%) fs: btrfs dev: /dev/sda2  
maj-min: 8:2  
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 61.5 MiB (24.4%) fs: vfat dev: /dev/sda1  
maj-min: 8:1  
ID-3: /home raw-size: 238.22 GiB size: 238.22 GiB (100.00%) used: 184.87 GiB (77.6%) fs: btrfs dev: /dev/sda2  
maj-min: 8:2  
ID-4: /var/log raw-size: 238.22 GiB size: 238.22 GiB (100.00%) used: 184.87 GiB (77.6%) fs: btrfs dev: /dev/sda2  
maj-min: 8:2  
ID-5: /var/tmp raw-size: 238.22 GiB size: 238.22 GiB (100.00%) used: 184.87 GiB (77.6%) fs: btrfs dev: /dev/sda2  
maj-min: 8:2  
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)  
ID-1: swap-1 type: zram size: 15.5 GiB used: 2.57 GiB (16.6%) priority: 100 dev: /dev/zram0  
Sensors:   System Temperatures: cpu: 59.0 C mobo: 0.0 C gpu: radeon temp: 48.0 C  
Fan Speeds (RPM): N/A  
Info:      Processes: 350 Uptime: 2h 31m wakeups: 4 Memory: 15.5 GiB used: 4.18 GiB (27.0%) Init: systemd v: 249  
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1941 lib: 527 Shell: fish v: 3.3.1  
running-in: konsole inxi: 3.3.06


$ killall timeshift                                                                                                                                                                                            
timeshift: no process found
[email protected]:~
$ killall timeshift-launcher                                                                                                                                                                              
timeshift-launcher: no process found
[email protected]:~
$ sudo timeshift --list                                                                                                                                                                                   
[sudo] password for rob:
/dev/sda2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

Device : /dev/sda2
UUID   : 68c70d59-7ec4-47a5-bc2d-451cdf643b2d
Path   : /run/timeshift/backup
Mode   : RSYNC
Status : No snapshots on this device
First snapshot requires: 22.7 GB

No snapshots found


$ sudo timeshift --restore                                                                                                                                                                                1 :( 22.Aug.2021  10.11pm
[Warning] Deleted invalid lock

/dev/sda2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

Select backup device:

Num     Device         Size   Type  Label
0    >  /dev/sda2  255.8 GB  btrfs

Enter device name or number (a=Abort): 0

/dev/sda2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

E: No snapshots found on device: '/dev/sda2'

There are different UUID for sda2, why?

I am out.

Maybe you could try resetting the configuration with

sudo mv /etc/timeshift.json /etc/timeshift.json.bak

And restart it

Thanks :

$ sudo mv /etc/timeshift.json /etc/timeshift.json.bak 
[sudo] password for rob:
mv: cannot stat '/etc/timeshift.json': No such file or directory

No idea. I've been copying word-for-word the outputs you asked for. Okay, and thanks for your help this far - looks like I'll have to be going for system reinstall .

If it's only mismatched UUIDs don't you think a reinstall might be a bit excessive?

It's kind of a useless pursuit posting a help request if the best tool found is a new installation. Nobody learns anything from that other than to reinstall.

I'm very happy to keep posting outputs but the last response I got was "i'm out" so I just naturally presumed this was a terminal problem (as in death not cli ). Do you have any suggestion about how we can progress this?

Maybe you could try reinstalling timeshift
This will not affect your snapshots

Thanks. I've reinstalled timeshift three times now trying to fix this. I even went as far as trying to swap to Snapper until I discovered what the Garuda devs discovered - Snapper isn't that great except on paper.

Ascertain the correct UUID and employee it, would be my first step. That's an error that could lead to a whole cascade of others. As you've been experiencing.

Look, you've made a major investment in troubleshooting and have well described your steps so far. If it were me I'd follow the posted suggestions on down the rabbit hole. What's it hurt?

You've got @filo's interest. That's a good start.

Thanks for that, appreciated. I just cranked up KDE Partition Manager and that reports the UUID for sda2 as 68c70d59-7ec4-47a5-bc2d-451cdf643b2d. How can I use that info to fix Timeshift?

You gotta be kidding me, huh? :wink::smiley:
I can't do much today. I'll be driving all day on my way back from vacation.
Good thing the kids pee all the time....

About the uuids, if they changed (I didn't read the details :blush:) it seems to me that they were in the info.json files in each snapshot folder?


hmmm, thanks for that - and thank your kids for their bathroom break so you can write to me :smiley:
I actually do not care about the previous snapshots at all, and maybe they are the reason for Timeshift crashing when I click "btrfs" as snapshot type when re-setting-up. Is there an easy way to clear/delete all snapshots and start again with clean slate?

This is strange, maybe it is
/etc/timeshift/timeshift.json ?

Just did the following, worked :

$ sudo mv /etc/timeshift/timeshift.json /etc/timeshift/timeshift.json.bak


$ sudo timeshift-launcher  

Unfortunately I still get the same segmentation fault crash as before when clicking "btrfs" option.
...anyway I'm off to bed it's past midnight here in New Zealand. I'll pick this up tomorrow.

Reinstall grub

sudo grub-install


sudo update-grub