Thumbnails are not showing in NTFS partations

Thumbnails are not showing in Dolphin. I have tested both Dolphin and Gnome Files (Nautilus) in BTRFS, exFAT and NTFS fs type partition. GNOME Files is showing thumbnails of images, videos, pdf etc accurately in all those 3 file systems. But, in Dolphin (version 22.04.0), I can see thumbnails of BTRFS and exFat file system, but can't in NTFS. I should note that I upgraded my full system 3 days ago and didn't change any settings. Everything was fine and sound before. I have been using Garuda Linux with Plasma and Dolphin since November 2021.


(image description: (1)above: thumbnails are showing in exFat fs; (2)middle: thumbnails are not showing in NTFS fs; (3)below: in NTFS partition, thumbs are showing in Gnome Files but not showing in Dolphin)

garuda-inxi output:

System:
Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4248322c-d06e-4806-933d-b8b6ee79be14 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M-A PRO MAX (MS-7C52) v: 1.0
serial: <superuser required> UEFI: American Megatrends LLC. v: 3.C0
date: 05/19/2021
CPU:
Info: model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64
type: MT MCP arch: Zen/Zen+ note: check family: 0x17 (23)
model-id: 0x18 (24) stepping: 1 microcode: 0x8108109
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2563 high: 3069 min/max: 1400/3700 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2982 2: 2058
3: 3053 4: 3067 5: 2019 6: 1227 7: 3034 8: 3069 bogomips: 59092
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DP-1,DP-2,DVI-D-1 bus-ID: 2a:00.0
chip-ID: 1002:15d8 class-ID: 0300
Device-2: SN0002 1080P Web Camera type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 3-4.3:5
chip-ID: 2bdf:0284 class-ID: 0300 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1360x768 s-dpi: 96 s-size: 359x203mm (14.13x7.99")
s-diag: 412mm (16.24")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: LG (GoldStar) W1953
serial: <filter> built: 2009 res: 1360x768 hz: 60 dpi: 85 gamma: 1.2
size: 406x229mm (15.98x9.02") diag: 466mm (18.4") ratio: 16:9 modes:
max: 1360x768 min: 720x400
OpenGL: renderer: AMD Radeon Vega 11 Graphics (raven LLVM 13.0.1 DRM 3.44
5.17.5-zen1-1-zen)
v: 4.6 Mesa 22.0.2 direct render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 2a:00.1 chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 2a:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-3: SN0002 1080P Web Camera type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 3-4.3:5
chip-ID: 2bdf:0284 class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.21 running: no
Sound Server-4: PulseAudio v: 15.0 running: no
Sound Server-5: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: down mac: <filter>
Device-2: Ralink RT5370 Wireless Adapter type: USB driver: rt2800usb
bus-ID: 3-4.2:7 chip-ID: 148f:5370 class-ID: 0000 serial: <filter>
IF: wlp42s0f3u4u2 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-5.2:3 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: N/A
Drives:
Local Storage: total: 2.34 TiB used: 1.92 TiB (82.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Transcend model: TS128GMTE110S
size: 119.24 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S1111A0L
temp: 50.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: HD321KJ
size: 298.09 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: N/A serial: <filter> rev: 0-11 scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Apacer model: AS340 120GB
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3.S scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
model: WD20SPZX-22UA7T0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 5400 serial: <filter> scheme: MBR
Partition:
ID-1: / raw-size: 116.75 GiB size: 116.75 GiB (100.00%)
used: 66.3 GiB (56.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 501 MiB size: 500 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3
ID-3: /home raw-size: 116.75 GiB size: 116.75 GiB (100.00%)
used: 66.3 GiB (56.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 116.75 GiB size: 116.75 GiB (100.00%)
used: 66.3 GiB (56.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 116.75 GiB size: 116.75 GiB (100.00%)
used: 66.3 GiB (56.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.64 GiB used: 47 MiB (0.3%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 45.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 381 Uptime: 2h 22m wakeups: 1 Memory: 13.64 GiB
used: 5.88 GiB (43.1%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 2461 lib: 630 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-04-29
Last full system update: 2022-04-29 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            anbox-container-manager.service systemd-guest-user.service systemd-networkd-wait-on
line.service

I have made a bug report to KDE. Bug no 453186 (link: 453186 – thumbnails are not showing in NTFS partations)

2 Likes

I would tend to believe this is related to Dolphin, yes. Nice action you took by opening the request at KDE.

2 Likes