The bootloader could not be installed

Hello guys, I know there are a lot of topics about this but I have checked on all of them but there isnt a single one addressing the issue on a Macbook Air 2015. I tried most of the solutions but non seem to work for me, when I install Linux Mint it works nine, but both Garuda Dragonized and Cinnamon bring the same error.

The installation command

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force

returned error code 1

No idea if you found it already nor if it's helpful: Okay so EFI is broken or what? -- TD;DR: try the gaming edition.


Welcome :slight_smile:

no matter what hardware, we would always like to have the

─garuda@garuda in ~ as 🧙 
 ╰─λ garuda-inxi
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda misolabel=GARUDA_CINNAMON_TALON quiet
    systemd.show_status=1 ibt=off systemd.unified_cgroup_hierarchy=1
    driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Cinnamon v: 5.4.12 tk: GTK v: 3.24.34 wm: Mutter vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBookAir7,2 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-937CB26E2E02BB01
    serial: <superuser required>
  Mobo: Apple model: Mac-937CB26E2E02BB01 v: MacBookAir7,2
    serial: <superuser required> UEFI: Apple v: 430. date: 03/16/2022
  ID-1: BAT0 charge: 51.0 Wh (97.7%) condition: 52.2/54.3 Wh (96.0%)
    volts: 8.4 min: 7.6 model: SMP bq20z451 type: Li-ion serial: N/A
    status: full cycles: 86
  Info: model: Intel Core i5-5250U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1210 high: 2700 min/max: 500/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 840 2: 2700 3: 801
    4: 500 bogomips: 12799
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 6000 vendor: Apple driver: i915 v: kernel
    arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1626
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.00x9.37")
    s-diag: 449mm (17.69")
  Monitor-1: eDP-1 model: Apple Color LCD built: 2015 res: 1440x900 hz: 60
    dpi: 128 gamma: 1.2 size: 286x179mm (11.26x7.05") diag: 337mm (13.3")
    ratio: 16:10 modes: 1440x900
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF: wlp3s0 state: dormant mac: <filter>
  IF-ID-1: enp0s20u2 state: unknown speed: -1 duplex: half mac: <filter>
  Device-1: Samsung Galaxy series misc. (tethering mode) type: USB
    driver: rndis_host v: kernel bus-ID: 1-2:9 chip-ID: 04e8:6863
    class-ID: 0a00 serial: <filter>
  Device-2: Apple Bluetooth USB Host Controller type: USB driver: btusb
    v: 0.8 bus-ID: 1-3.3:7 chip-ID: 05ac:828f class-ID: fe01
  Report: ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 127.84 GiB used: 6 GiB (4.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0128G
    size: 113 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 3A0Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: USB Flash size: 14.84 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
    rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.67 GiB used: 1.06 GiB (13.9%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 58.0 C pch: 58.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 242 Uptime: 2h 25m wakeups: 4 Memory: 7.67 GiB used: 3.64 GiB
  (47.4%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1223 libs: 307
  tools: paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.22
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.8-1):
  System install date:     2022-11-03
  Last full system update: 2022-11-03 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            snapper-cleanup.service 

There is no

Gaming version for Cinnamon. :wink:

Let me download it and try. Thank you.

Wrong assumption perhaps (we know assumption is the mother of all screwups) but I assumed that was an option. :man_shrugging:

1 Like

I have actually downloaded both of then and booted, they do bring the same error, I am now downloading the gaming edition as per a solution for one person using a macbook.

It could be that --removable should be used there. See:
I think you could try chrooting from the live USB into your installed system (should be there after your last attempt, grub installation should be the last step) and give a:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --removable

Before that, make sure that your EFI System Partition is mounted on /boot/efi, of course. E.g.

mount /dev/sda1 /boot/efi

The ESP (/dev/sda1 in the example) could be found with:

parted -l | grep -iE "^Disk /|esp" | grep -B1 esp

When I run this command

mount /dev/sda1 /boot/efi

This is what I get, I even tried re-partitioning the drive multiple times

mount: /boot/efi: mount point does not exist.
dmesg(1) may have more information after failed mount system call

When I run

sudo parted -l | grep -iE "^Disk /|esp" | grep -B1 esp

I get

Disk /dev/sda: 121GB
1      2097kB  317MB  315MB   fat32                 boot, esp
Disk /dev/sdb: 15.9GB
2      4309MB  4313MB  4194kB  primary               esp

can someone just remote assist me please because I am probably doing something wrong and not realizing because I am a newbie in Linux.

Have you been able to chroot, either with the relevant button in the Garuda welcome or with this tutorial?
If so, when inside chroot, check that /boot/efi directory exists. If not, create it. Then /dev/sda1 is ok to be mounted there.

Wait, the method above is valid if you still have a partition where you tried installing but the process failed at the end. If you deleted your btrfs partition, that won’t apply.

Same story. Looks like imma just give up and return to Mint because even the Gaming edition does the same thing.

Why don't we go back to basics...

  • Which ISO are you trying to install--what's the name/number?
  • Have you checked the ISO for errors?
  • How are you writing the ISO to USB? This may be very important, since Mint may/used to use a procedure that was incompatible with Arch/Arch-based distributions.

Ive been trying different methods and this is happening now...
when I mount the path below it works

sudo mount /dev/sda1 /boot/efi/

and also when I run

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --removable

I get

Installing for x86_64-efi platform.
Installation finished. No error reported.

But then when I unmount and restart the laptop it does not show any available OS on the boot menu so it doesn't boot up. What am I missing?

You should try

sudo update-grub 
1 Like

I have rebooted and it opened the grub menu..

I followed the steps to select the boot drive. Now it is telling me :

You need to load the kernel first

There was no Garuda option to be selected?
You could try chrooting again and give a

pacman -S linux-zen linux-zen-headers

But there’s probably still something wrong…

I saw on some other forum they suggested..

linux /boot/vmlinuz-4.2.0-16-generic root=/dev/sda1 ro

Is there a version of that, that can work for me.

I think that stuff is needed when you drop into an emergency shell, not in this case.
I see now and agree with the comment of @Bro or even start from scratch: download a new ISO, verify checksum, burn it one the USB possibly with Ventoy, fast boot and secure boot disabled in the BIOS, boot ISO and install.
If I can give you also a general advice, I suggest you always make clear in your posts what you have done, provide the relevant input and output whenever possible (eg when in terminal or chroot), otherwise it becomes difficult to follow and understand the actions and what's going on.


Okay so let me recap. I have 3 iso images, dragonized, gaming edition and cinnamon. I've been using usb image writer from my linux mint v20 to create a bootable usb.

so all the versions when show the same above error, with I realize that its caused by the default installation command

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force

so after the installation fails I mount run the fish command line

sudo mount /dev/sda1 /boot/efi

after successful mounting I run this command

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --removable

which gives me the results

Installing for x86_64-efi platform.
Installation finished. No error reported.

Then I reboot and it boots up to GNU Grub 2:2, when I type in the boot command it returns an error: you need to select kernel first.

I tried following the steps for manually fixing the grub which involved


set root=

insmod normal 


But then when it comes to selecting the kernel I get stuck.
I really want to install this linux that is why i've been trying relentlessly. even

sudo update-grub


/usr/bin/grub-probe: error: failed to get canonical path of `overlay'.

I know its probably stupid but I was wondering if there is a way we could just modify the iso so that it comes with the --removable command instead of the --force

I appreciate your time. Thank you.