System-wide intermittent audio

I have two systems running garuda that both suffer from the same issue of audio intermittently failing to start, causing me to have to close and reopen applications or refresh web pages to resolve. This issue has been ongoing for several months, on my second computer since about the time I installed Garuda.

I notice this mostly browsing, because its something I do on both computers more than anything else, but I've also noticed in VLC. I have also tested in multiple browsers such as Vivaldi, so I do not believe it to be the browser or application.

Example behavior would be clicking a link to open a video on youtube in a new tab. Video loads, starts and plays but without audio. Refresh video, usually audio returns. Occasionally it does not and requires multiple refreshes.

Both computers running Garuda do this. I believed it to be EasyEffects at fault because I ran global volume normalizers and equalizers. I disabled EasyEffects on both computers and issue persists when no active easyeffects process, including after restart with no flag to launch easyeffects at startup. When this issue occurs, I can mouse wheel my volume and hear sound, so its very brief and seems like just a failure for something to initialize after a period of no audio activity.

What might I want to change or reinstall to resolve?

System:
Kernel: 6.0.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=eaa1f1c6-9940-4c37-9baf-9750aa94737c rw [email protected]
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
splash
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: MAXIMUS VIII HERO v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 3802
date: 03/15/2018
CPU:
Info: model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake
gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 9 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 4425 high: 4801 min/max: 800/4800 scaling:
driver: intel_pstate governor: performance cores: 1: 4200 2: 4801 3: 4200
4: 4200 5: 4800 6: 4200 7: 4801 8: 4200 bogomips: 67200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
vendor: XFX Speedster MERC 319 driver: amdgpu v: kernel arch: RDNA-2
code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: DP-1,DP-2 empty: DP-3,HDMI-A-1
bus-ID: 03:00.0 chip-ID: 1002:73bf class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 5120x1440 s-dpi: 96 s-size: 1354x381mm (53.31x15.00")
s-diag: 1407mm (55.38")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,right
model: LG (GoldStar) ULTRAGEAR serial: <filter> built: 2022 res: 2560x1440
hz: 165 dpi: 93 gamma: 1.2 size: 697x392mm (27.44x15.43")
diag: 800mm (31.5") ratio: 16:9 modes: max: 2560x1440 min: 640x480
Monitor-2: DP-2 mapped: DisplayPort-1 pos: left model: AOC AG271QG4
serial: <filter> built: 2016 res: 2560x1440 dpi: 109 gamma: 1.2
size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
max: 2560x1440 min: 720x400
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon RX 6800 XT (navi21
LLVM 14.0.6 DRM 3.48 6.0.8-zen1-1-zen) direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
class-ID: 0403
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Sound API: ALSA v: k6.0.8-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth type: USB driver: btusb
v: 0.8 bus-ID: 1-10:6 chip-ID: 0b05:17cb class-ID: fe01 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 10.68 TiB used: 5.22 TiB (48.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: Rocket 4.0 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: RKT401.3 temp: 24.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Sabrent model: Rocket 4.0 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: RKT401.3 temp: 28.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Toshiba model: HDWE150 size: 4.55 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: FP2A scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST240HM000-1G5152
size: 223.57 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: C675 scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD40EZRX-00SPEB0 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-6: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 850 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3B6Q scheme: MBR
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 516.46 GiB (55.5%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:6
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 592 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:5
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 516.46 GiB (55.5%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:6
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 516.46 GiB (55.5%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:6
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 516.46 GiB (55.5%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.29 GiB used: 1.27 GiB (4.1%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 41.0 C mobo: N/A gpu: amdgpu temp: 32.0 C
mem: 32.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1516
Info:
Processes: 361 Uptime: 5d 8h 1m wakeups: 0 Memory: 31.29 GiB
used: 7.76 GiB (24.8%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: 1977
pm: pacman pkgs: 1964 libs: 528 tools: octopi,pamac,paru pm: flatpak
pkgs: 13 Shell: fish v: 3.5.1 running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-06-13
Last full system update: 2022-11-14 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift
Failed units:            mnt-Josie-Videos.mount shadow.service

Please check if you have jamesdsp in autostart, and, if so, close it and remove if from autostart.
It caused some similar problems in the past.

1 Like

I will try removing again. I stopped both easyeffect and jamesdsp and still noticed this without them. Not 100% on this though so I will try again.

Just in case. The link to the issue I mentioned.
It seems to be fixed in wireplumber (not yet releases, only in the git version).

1 Like

Just to clarify, I was not using jamesDSP on either device when this issue arose. However, I suspect since they do a lot of the same things that this issue can happen with either.

Ok, let's see. The fix was done in the underlying wireplumber (pipewire) and they say "the cause is still not understood", so there might be in my opinion different scenarios, not necessarily only the jamesdsp one.
If the issue is very frequent and annoying for you, and you want to follow this "route", you could try installing wireplumber-git, which will replace wireplumber.

4 Likes

Going to give the wireplumber-git a try if its on a newer version with attempted fixes in place.

This probably happens half a dozen or so times a day on each device. Not enough to be infuriating, but enough to be a problem.

The wireplumber git does not resolve issue soon as jamesDSP is back on, problem is something there. With jamesdsp and easyeffects off I dont seem to have the issue. I just wish there was a simple system-wide volume normalizer in Linux. Everything is either too loud or too quiet without one.

Hmm, this is interesting o_o

I think wireplumber-git has this fix included, but just to double check (if you're open to a manual fix):
Try editing /usr/share/wireplumber/scripts/policy-node.lua to look like this: scripts: policy-node: wait for unactivated links instead of removing (d4a22c8c) · Commits · P V / wireplumber · GitLab

and if that doesn't work, try copying policy-node.lua into your /etc/wireplumber/scripts folder. Hopefully this works ^^;

3 Likes

Don't know if this will help in the troubleshooting or not but have found that when this happens on my setup if i go to the sound settings and make sure the correct output is set then do a test sound and it starts working immediately even as it is testing the left speaker for me this works every time. Makes me think in the sound initiation protocal is broken mine seems to work then not work every time systemd is updated as in one update it works then the next it doesn't then next one it starts working again. I hope this will provide those much more knowledgeable than me any much needed info to point to a possible solution to this.