System Time not set correctly

One issue with a fresh installation of Garuda Linux: system time isn't set correctly.

I set timezone -5, "Set date and time automatically" was checked, and it was giving time 7:30AM instead of 12:30AM. I had to uncheck that box, set the time manually, and now it keeps it.

Clicking help says: "On a computer without systemd the NTP utilities rdate or ntpdate are used. If these utilities are missing please install them."

rdate isn't recognized in the console. Perhaps missing core app?

As a separate issue, when clicking save in the time and date window, sometimes it displays an error that it cannot save, and sometimes it asks for the password. Seems random.

But Garuda has systemd, what you have to do is simply timedatectl set-ntp true in order to use NTP synchronization.

2 Likes

So it it not done automatically ? :smiley:

You can check it using the timedatectl command, it should output something like it:

              Local time: Fri 2021-11-26 13:24:29 -05
           Universal time: Fri 2021-11-26 18:24:29 UTC
                 RTC time: Fri 2021-11-26 18:24:29
                Time zone: America/Bogota (-05, -0500)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no

The important line for you is NTP service: active

1 Like

As i asked why is this just not set automatically to be active?

It's activated via systemd-timesyncd, why are you saying that it isn't activated by default when the original question was about some dependencies on a non-systemd distro? I just pointed to how it works and how to enable it if you are using systemd. Typical XY problem.

2 Likes

I'm sorry you are rite :grinning:
I was seeing it as timedatectl set-ntp true
is not set as default :grinning:
It maybe now

timedatectl set-ntp true is the equivalent to enabling systemd-timesyncd that's what we do in the installation process. Basically when you run timedatectl set-ntp true it enables the service in the background.

2 Likes

NTP service is active

and it reverted back a wrong time!? It is 5:53PM, but it is considering 5:53PM to be UTC time? Could there be a conflict with Windows in the way it handles BIOS time?

Look up...

RealTimeIsUniversal

it's a 32 bit dword value for the windows registry.

1 Like

It is well known that Windows messes with Linux time.

Search is your friend.

1 Like

OK the solution is here. They do not recommend setting Windows to Universal Time; but rather to change Linux to local time.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.