System stuck on boot after installing Nvidia driver

I installed Garuda dragonized and my graphics card (Nvidia gt 720) wasn't used and the GPU fan was on 100% all the time, so I went to the hardware settings and clicked on my graphics card and then on install. I rebooted and now I'm stuck at "Loading initial ramdisk" I tried to reinstall garuda and install the driver again but it's the same result. Installing the driver breaks my system :< Also I can't use the "Boot allowing proprietary drivers (NVIDIA)" install option because it freezes on "Starting Terminate Playmouth Boot Screen..." and when I use "Boot with open source drivers" it works but my GPU isn't being used and the GPU fan is on 100%
Can anyone please help me this is driving me insane :<

It looks like the most recent driver series that support this chipset is 418 (which is also EOL and not present in the repos or the AUR), NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver

410xx is in the AUR, and 390xx is also an option in both the AUR and ChaoticAUR. You'll have to test these and see which works better, but also keep in mind that, assuming you're talking about a laptop here, you'll need to do some additional setup (e.g. install bumblebee or optimus-manager) to be able to switch between the two iGPU and dGPU.