System sounds where there were none before?

System:
  Kernel: 5.15.81-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=1f80aaea-55c3-4ffe-8c84-4a6fc13c03ba rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2501
    date: 04/07/2014
CPU:
  Info: model: AMD FX-9370 bits: 64 type: MT MCP arch: Piledriver level: v2
    built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 2 stepping: 0
    microcode: 0x6000852
  Topology: cpus: 1x cores: 8 smt: enabled cache: L1: 384 KiB
    desc: d-8x16 KiB; i-4x64 KiB L2: 8 MiB desc: 4x2 MiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3129 high: 4366 min/max: 1400/4400 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3759 2: 4366
    3: 2576 4: 2331 5: 3642 6: 3728 7: 2762 8: 1874 bogomips: 70641
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 525.60.11
    alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1
    driver: N/A display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 5760x1080 s-dpi: 96 s-size: 1524x286mm (60.00x11.26")
    s-diag: 1551mm (61.05")
  Monitor-1: DP-3 pos: center res: 1920x1080 hz: 60 dpi: 102
    size: 477x268mm (18.78x10.55") diag: 547mm (21.54") modes: N/A
  Monitor-2: DVI-D-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 102
    size: 477x268mm (18.78x10.55") diag: 547mm (21.54") modes: N/A
  Monitor-3: HDMI-0 pos: right res: 1920x1080 hz: 60 dpi: 69
    size: 708x398mm (27.87x15.67") diag: 812mm (31.98") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce GTX
    1070/PCIe/SSE2 direct render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: ZOTAC
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Device-3: Creative Labs CA0110 [Sound Blaster X-Fi Xtreme Audio]
    driver: snd_hda_intel v: kernel bus-ID: 03:00.0 chip-ID: 1102:0009
    class-ID: 0403
  Sound API: ALSA v: k5.15.81-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: c000 bus-ID: 0a:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
    bus-ID: 8-2:2 chip-ID: 0a5c:21e8 class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 7.74 TiB used: 3.64 TiB (46.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT512MX100SSD1
    size: 476.94 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: MU01 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD20EARX-00PASB0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: AB51
    scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Toshiba model: DT01ACA300
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: GPT
  ID-4: /dev/sdd maj-min: 8:48 vendor: Smart Modular Tech.
    model: SHGS31-1000GS-2 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0Q00
    scheme: GPT
  ID-5: /dev/sde maj-min: 8:64 type: USB vendor: Seagate model: BUP Slim BK
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B type: N/A
    serial: <filter> rev: 0302 scheme: MBR
Partition:
  ID-1: / raw-size: 442.29 GiB size: 442.29 GiB (100.00%)
    used: 293.79 GiB (66.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
    used: 594 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 442.29 GiB size: 442.29 GiB (100.00%)
    used: 293.79 GiB (66.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 442.29 GiB size: 442.29 GiB (100.00%)
    used: 293.79 GiB (66.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 442.29 GiB size: 442.29 GiB (100.00%)
    used: 293.79 GiB (66.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.25 GiB used: 5 MiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 46.1 C mobo: N/A gpu: nvidia temp: 58 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 38%
Info:
  Processes: 376 Uptime: 8m wakeups: 0 Memory: 31.26 GiB
  used: 5.68 GiB (18.2%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1699 libs: 508 tools: pamac,paru Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.23
e[1;34mGaruda (2.6.10-1):e[0m
e[1;34m  System install date:e[0m     2022-08-20
e[1;34m  Last full system update:e[0m 2022-12-11 e[1;31m↻
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m No/Undetected
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m 

Hello,

I updated my system (it'd been at least a month or two, been busy with life and was trying to get Horizon Zero Dawn working under steam, so tried updating. Still no luck on that)
After updating, suddenly hitting the power options, backspacing one to many times on the main menu, or similar things gives me a loud sound (much like windows system sounds). Except that in all settings i can find (only one i can find ANY event sounds in is Appearance), they are turned off.

The only option i have is to mute system sounds, but i hadn't had to do that before, so i was hoping someone might have some idea what program might have turned that on in a recent update.

Most likely not a solution but a reboot seems to be pending after your last update.

Have rebooted twice, with all the things i've been trying to get the one game running, and it still had sounds that i couldn't find a way to disable :frowning: I'm not expecting anything, was more a shot in the dark in case anyone else had had such and had an answer. (the only new software was gamemoderun, as posts suggested it, but that was after running the updates to try to get HZD to work, and hearing sounds)

Ok sure.
Just out of curiosity, the description reminds a little bit of the old PC speaker beep.
Do you still have the file /usr/lib/modprobe.d/nobeep.conf blacklisting pcspkr?
I think it could go also in /etc/modprobe.d/ or you could even try sudo rmmod pcspkr to see if that's the problem.

1 Like

nobeep.conf has blacklist pcspkr. it doesn't sound like a pc speaker, more like some of the windows sound themes for certain options. almost like a bloop sound.

There is another place in the GUI where sound events are enabled by default. I'm not sure if this will be a fix or not, but it's worth a shot.

Settings -> Settings Editor -> xsettings, in the Net submenu there is a setting called EnableEventSounds which can be unticked.

2 Likes

Sadly, that was also disabled. looks like that matches the main setting i found in settings manager as it switchs if i select that setting.

Thanks for the attempts though :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.