System looking for an unmounted drive and delaying boot process

inxi
System:    Kernel: 5.14.14-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=1d67776a-b95b-41a2-93c9-796f08af0b8f rw splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           resume=UUID=dcce535a-0b0d-460f-b66d-6a103fb37f8a loglevel=3
           Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Desktop System: Gigabyte product: B450 AORUS PRO v: N/A serial: <filter>
           Mobo: Gigabyte model: B450 AORUS PRO-CF v: x.x serial: <filter> BIOS: American Megatrends LLC. v: F61c
           date: 05/10/2021
CPU:       Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 1 stepping: 1
           microcode: 8001138 cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76688
           Speed: 3194 MHz min/max: N/A Core speeds (MHz): 1: 3194 2: 3194 3: 3194 4: 3194 5: 3194 6: 3194 7: 3194 8: 3194
           9: 3194 10: 3194 11: 2902 12: 3194
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Tul
           driver: amdgpu v: kernel bus-ID: 07:00.0 chip-ID: 1002:67df class-ID: 0300
           Display: x11 server: X.org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting
           alternate: fbdev,vesa resolution: <missing: xdpyinfo>
           OpenGL: renderer: AMD Radeon RX 470 Graphics (POLARIS10 DRM 3.42.0 5.14.14-arch1-1 LLVM 12.0.1) v: 4.6 Mesa 21.2.4
           direct render: Yes
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Tul driver: snd_hda_intel v: kernel
           bus-ID: 07:00.1 chip-ID: 1002:aaf0 class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
           bus-ID: 09:00.3 chip-ID: 1022:1457 class-ID: 0403
           Device-3: ZOOM Handy Recorder stereo mix type: USB driver: snd-usb-audio bus-ID: 3-3:3 chip-ID: 1686:0045
           class-ID: 0102 serial: <filter>
           Sound Server-1: ALSA v: k5.14.14-arch1-1 running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel port: f000 bus-ID: 04:00.0
           chip-ID: 8086:1539 class-ID: 0200
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 3.18 TiB used: 978.14 GiB (30.0%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P1SSD8 size: 465.76 GiB block-size: physical: 512 B
           logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P3CR013 temp: 38.9 C scheme: GPT
           ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size:
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 1A01 scheme: GPT
           ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate model: Expansion size: 1.82 TiB block-size: physical: 4096 B
           logical: 512 B type: N/A serial: <filter> rev: 0708 scheme: MBR
Partition: ID-1: / raw-size: 390.75 GiB size: 383.61 GiB (98.17%) used: 187.74 GiB (48.9%) fs: ext4 dev: /dev/nvme0n1p4
           maj-min: 259:3
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 46.0 C
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 2325
Info:      Processes: 344 Uptime: 11m wakeups: 0 Memory: 15.57 GiB used: 4.87 GiB (31.3%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1787 pacman: 1777 lib: 514 flatpak: 10 Shell: fish v: 3.3.1
           default: Bash v: 5.1.8 running-in: alacritty inxi: 3.3.08

While booting, my PC waits for 10 seconds looking for a device by the name/mountpoint /dev/disk/by-uuid/dcce535a-0b0d-460f-b66d-6a103fb37f8. Also i recently disabled swap because it was giving me a bit of performance issues. i masked the systemd swap target(systemctl mask swap.target) and removed the swap partition from fstab (/etc/fstab)

Check your /etc/fstab
or post it as text :slight_smile:

3 Likes
Fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>                           <mount point>  <type>  <options>        <dump>  <pass>
UUID=1d67776a-b95b-41a2-93c9-796f08af0b8f /              ext4    defaults,noatime   0       1

As you can see it only has my main boot drive. (forgive me for using ext4 installer threw some errors while using btrfs). Crypttab also is empty so that also is not an issue. Sorry for the late reply, had some other work(exams etc).

Hi @pupperemeritus , nice to see you again. How are you?

Regarding your question, post output of

blkid

Also, it might be looking for the swap partition that you removed from etc/fstab.
As far as I can understand, your issue is that you didn't disable swap, so system will try to look for it while booting. But as you removed it from fstab, it didn't automatically Mount it. So, it looks for it.

3 Likes

Im doing pretty good but under the stress of many choices, you can understand the situation of a person who didnt ace JEE but isnt a full dumb dumb either.

blkid
/dev/nvme0n1p2: LABEL="New Volume" BLOCK_SIZE="512" UUID="3A60BA9F60BA6175" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="79ab0eff-b669-43ca-bfd0-927e3a088d7b"
/dev/sdb1: LABEL="Seagate Expansion Drive" BLOCK_SIZE="512" UUID="B674C4EA74C4AF05" TYPE="ntfs" PARTUUID="f5b69747-01"
/dev/sda4: BLOCK_SIZE="512" UUID="90A04131A0411EDA" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="462a1fef-eae2-4c75-9f81-c4bbea0b4fa9"
/dev/sda2: UUID="5C3E-EB55" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="a7457394-c4c5-48cc-89cf-51db6e891a0d"
/dev/sda7: LABEL="Media" BLOCK_SIZE="512" UUID="88A4A1CEA4A1BF56" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="4279bbb3-a61d-43f0-9ac9-71992b156560"
/dev/sda5: BLOCK_SIZE="512" UUID="3CC6A43BC6A3F376" TYPE="ntfs" PARTUUID="0caf9b8d-e21c-48fe-a168-21c4a2a7a196"
/dev/sda1: BLOCK_SIZE="512" UUID="8C4A26974A267DD8" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="7f0c903e-f52b-4b1a-b612-0cd2fd115a07"
/dev/sda8: LABEL="Games 2" BLOCK_SIZE="512" UUID="2E3AA7313AA6F54D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="3452d8be-1909-4ffe-bc50-55e37ab9acb6"
/dev/sda6: LABEL="Games" BLOCK_SIZE="512" UUID="3E8A82A78A825AF3" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ad040094-729b-4e86-b3c5-ed47a138deb4"

i've masked systemctl swap.target. and swapoff -a
also deleted the swap partition.

Hi, does mount -a say something?

Also, post output of journalctl after rebooting.

And btw, in my opinion, you should focus more on JEE. Just leave your laptop/desktop for a few months and focus more on studies. We will be there after a few months too.

2 Likes

I am only on my cell and I find things hard to read on such a small screen with my vision. However, something seems drastically amiss with your fstab. How is it that you are using ext4 as your root partition format. Garuda should be installed with btrfs, with numerous btrfs subvolumes in any proper default Garuda installation.

Your fstab does not appear to be from a valid default Garuda installation. Installing Garuda in any format other than btrfs is non-standard and unsupported.

What are we really looking at here? Your other 7 partitions are all in Windows format. Are you sure you are posting on the correct forum?

3 Likes

I am infact using ext4 since garuda refused to install with btrfs a year back when I installed this. I tried my hardest to get it installed with btrfs but it refused. (pretty much 0 issues over the past year, i recently disabled swap and cant seem to completely disable it from my system,as a hard stop i deleted the swap partition, so its looking for the swap partition everytime and realising its not there)

mount -a doesnt say anything
i think journalctl lists everything after the boot. journalctl -b lists boot journal.
Just journalctl is around 2.6 million lines long.
journalctl -b[PrivateBin]
Technically only the ext4 part is unsupported so only that part is a valid refusal of help :stuck_out_tongue:

Btw I am done with my jee. I decided to move on. Don't have the energy to study the same things again. As a side product imma learn coding. And one day contribute to garuda.

2 Likes

Since you have already removed the swap partition from the fstab, why don't you try unmasking swap.target?
Maybe other units are using After=swap.target to run after swap setup and this is creating problems...

I have unmasked it now. it said removed /etc/systemd/system/swap.target

its still searching for it

I think that the system is configured with hibernation on swap partition (not existing anymore)

1 Like
  1. systemd
    Create the following files:
  • /etc/systemd/sleep.conf.d/no-hibernate.conf
  • Add:
# disable hibernation
# doc : https://archived.forum.■■■■■■■.org/t/turn-off-disable-hibernate-completely/139939
AllowHibernation=no
AllowHybridSleep=no
AllowSuspendThenHibernate=no

/etc/systemd/logind.conf.d/no-hibernate.conf

Add:

# disable hibernation
HibernateKeyIgnoreInhibited=no

Turn off energy saving things in kde settings.

in /etc/default/grub
in the line which says GRUB_CMDLINE_LINUX_DEFAULT
remove the words resume = /disk/by-uuid/.........
in /etc/mkinitcpio.conf
remove the word resume
then do
sudo update-grub
sudo mkinitcpio --allpresets
Credit:[HowTo] Disable / Turn off Hibernate completely! - Tutorials - Manjaro Linux Forum

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.