System freezes, presumably related to wayland

Hey again,
It turns out that I have more problems; This time the issue that I want to address is, that my linux installation sometimes fully freezes when launching Garry's mod.
I have looked at journalctl, and that revealed nothing. I looked at the dmesg output, but nope. I set vm.overcommit_memory to 2 since I thought that this kind of full lockup could only be caused by 100 ram usage, but turns out I was wrong. Finally I tried switching kernels, but guess what.
I want to mention, that I even tried sysrq stuff while my system was frozen, but that didn't work even though I can confirm it working when the system is not frozen.
Now I am out of ideas. This is a very weird issue and I think it's somehow related to wayland, though I fully expect this to now happen on x11 as well.
Does anyone have an idea about this?

inxi -Fart (still immature)
  Host: lolcat Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 compiler: gcc
    v: 11.1.0 parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6e6211b4-cfb4-44c0-8970-5e4a826e0c5e rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 sysrq_always_enabled=1
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 2 dm: Ly Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F50a
    date: 11/27/2019
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 4108 high: 4150 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4108 2: 4150
    3: 4125 4: 4081 5: 4115 6: 4111 7: 4112 8: 4110 9: 4068 10: 4084 11: 4116
    12: 4121 bogomips: 86226
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Baffin [Radeon RX 550 640SP / RX 560/560X] vendor: ASUSTeK
    driver: amdgpu v: kernel bus-ID: 08:00.0 chip-ID: 1002:67ff class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 3-3:5 chip-ID: 046d:0825 class-ID: 0102 serial: 248009E0
  Display: server: X.Org compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3600x1200 s-dpi: 96 s-size: 952x317mm (37.5x12.5")
    s-diag: 1003mm (39.5")
  Monitor-1: HDMI-A-0 res: 1680x1050 hz: 60 dpi: 90
    size: 474x296mm (18.7x11.7") diag: 559mm (22")
  Monitor-2: DVI-D-0 res: 1920x1200 hz: 60 dpi: 99
    size: 495x310mm (19.5x12.2") diag: 584mm (23")
  OpenGL: renderer: AMD Radeon RX 560 Series (POLARIS11 DRM 3.42.0
    5.15.12-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.3 direct render: Yes
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 08:00.1
    chip-ID: 1002:aae0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media USB Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.4:6 chip-ID: 0d8c:9700
    class-ID: 0300 serial: 201605
  Device-4: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 3-3:5 chip-ID: 046d:0825 class-ID: 0102 serial: 248009E0
  Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel port: f000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: e0:d5:5e:4f:57:57
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
    bus-ID: 3-1.1:4 chip-ID: 0a5c:21e8 class-ID: fe01 serial: 5CF3708E8F4F
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up
    address: 5C:F3:70:8E:8F:4F
  Local Storage: total: 2.96 TiB used: 1012.01 GiB (33.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: S4CSNX0N713306T rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: S3YJNX0K332437P rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
    serial: WD-WCC4M1ZHTZTK rev: 0A82 scheme: GPT
  ID-1: / raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 55.53 GiB (28.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 736.18 GiB size: 736.18 GiB (100.00%)
    used: 145.87 GiB (19.8%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 55.53 GiB (28.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 55.53 GiB (28.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.36 GiB used: 2.8 MiB (0.0%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 36.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1446
  Packages: apt: 0 pacman: 1885 lib: 473
  Active pacman repo servers in: /etc/pacman.d/chaotic-mirrorlist
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
  CPU top: 5 of 377
  1: cpu: 22.7% command: firefox pid: 6227 mem: 99.8 MiB (0.3%)
  2: cpu: 21.7% command: firefox pid: 4038 mem: 756.1 MiB (2.3%)
  3: cpu: 8.2% command: firefox pid: 79733 mem: 411.3 MiB (1.2%)
  4: cpu: 3.4% command: kwin_x11 pid: 3800 mem: 223.5 MiB (0.6%)
  5: cpu: 3.1% command: xorg pid: 3231 mem: 138.9 MiB (0.4%)
  System RAM: total: 31.36 GiB used: 6.78 GiB (21.6%)
  Memory top: 5 of 377
  1: mem: 756.1 MiB (2.3%) command: firefox pid: 4038 cpu: 21.7%
  2: mem: 411.3 MiB (1.2%) command: firefox pid: 79733 cpu: 8.2%
  3: mem: 344.8 MiB (1.0%) command: firefox pid: 5735 cpu: 2.9%
  4: mem: 333.8 MiB (1.0%) command: latte-dock pid: 5634 cpu: 1.1%
  5: mem: 317.7 MiB (0.9%) command: firefox pid: 5864 cpu: 1.3%
  Processes: 377 Uptime: 45m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Shell: fish v: 3.3.1
  running-in: alacritty inxi: 3.3.11

Based on what I read lately i wouldn't use this game as comparison Stone :eyes:


Well I'm a pretty big fan of gmod since I bought it like a week ago. I guess it's broken, yeah, but nobody else seems to have these problems xD

I wonder what's going on

EDIT: I didn't have to install lib32-gconf, gconf itself worked fine for me

Sorry but when you start this way I can smell troubles :joy:


For gmod freezing try this please Need Lib32-Gconf in order to run Garry's Mod on Steam - #7 by noop


Oh interesting - I actually already (just) switched to the chromium branch, since it seems that most issues are related to awersomium in some way

Awesomium is a pile of shit :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.