Switching for bash to fish shell. Missing dependancy

I am trying to switch from bash to fish in the shell. However I am running up against this error. fish-autopair is not found by ptopairacman while searching exclusively either.

sudo pacman -S garuda-fish-confige
resolving dependencies...
warning: cannot resolve "fish-autopair", a dependency of "garuda-fish-config"
:: The following package cannot be upgraded due to unresolvable dependencies:
garuda-fish-config

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'fish-autopair' required by garuda-fish-config
System:
Kernel: 6.3.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=c5e4442b-4955-4f7d-8b31-4213d59d44df
rw rootflags=subvol=@ quiet loglevel=3 ibt=off
Console: pty pts/1 DM: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Kvm Mobo: QEMU model: Standard PC (i440FX + PIIX, 1996) v: pc-i440fx-4.1
serial: <superuser required> BIOS: N/A v: N/A date: N/A
CPU:
Info: model: Westmere E56xx/L56xx/X56xx (Nehalem-C) bits: 64 type: MCP arch: Nehalem level: v2
built: 2008-10 process: Intel 45nm family: 6 model-id: 0x2C (44) stepping: 1 microcode: 0x1
Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB
L2: 8 MiB desc: 2x4 MiB L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3192 min/max: N/A cores: 1: 3192 2: 3192 bogomips: 12768
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities: <filter>
Graphics:
Device-1: Red Hat QXL paravirtual graphic card driver: qxl v: kernel ports: active: Virtual-1
empty: Virtual-2,Virtual-3,Virtual-4 bus-ID: 00:02.0 chip-ID: 1b36:0100 class-ID: 0300
Display: server: X.org v: 1.21.1.8 driver: X: loaded: N/A unloaded: modesetting
alternate: fbdev,vesa gpu: qxl tty: 110x28
Monitor-1: Virtual-1 size-res: N/A in console modes: max: 1024x768 min: 640x480
API: OpenGL Message: GL data unavailable in console and glxinfo missing.
Audio:
Device-1: Intel 82801FB/FBM/FR/FW/FRW High Definition Audio vendor: Red Hat QEMU Virtual Machine
driver: snd_hda_intel v: kernel bus-ID: 00:04.0 chip-ID: 8086:2668 class-ID: 0403
API: ALSA v: k6.3.9-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.72 status: active with: 1: pipewire-pulse status: active
2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel 82371AB/EB/MB PIIX4 ACPI vendor: Red Hat Qemu virtual machine
type: network bridge driver: piix4_smbus v: N/A modules: i2c_piix4 port: N/A bus-ID: 00:01.3
chip-ID: 8086:7113 class-ID: 0680
Device-2: Red Hat Virtio network driver: virtio-pci v: 1 modules: virtio_pci port: c0e0
bus-ID: 00:03.0 chip-ID: 1af4:1000 class-ID: 0200
IF: ens3 state: up speed: -1 duplex: unknown mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
IF-ID-2: docker_gwbridge state: up speed: 10000 Mbps duplex: unknown mac: <filter>
IF-ID-3: veth9d23a11 state: up speed: 10000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 40 GiB used: 5.13 GiB (12.8%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/vda maj-min: 254:0 model: N/A size: 40 GiB block-size: physical: 512 B
logical: 512 B speed: <unknown> tech: N/A serial: N/A scheme: MBR
Partition:
ID-1: / raw-size: 39.99 GiB size: 39.99 GiB (100.00%) used: 5.13 GiB (12.8%) fs: btrfs
dev: /dev/vda1 maj-min: 254:1
ID-2: /home raw-size: 39.99 GiB size: 39.99 GiB (100.00%) used: 5.13 GiB (12.8%) fs: btrfs
dev: /dev/vda1 maj-min: 254:1
ID-3: /var/log raw-size: 39.99 GiB size: 39.99 GiB (100.00%) used: 5.13 GiB (12.8%) fs: btrfs
dev: /dev/vda1 maj-min: 254:1
ID-4: /var/tmp raw-size: 39.99 GiB size: 39.99 GiB (100.00%) used: 5.13 GiB (12.8%) fs: btrfs
dev: /dev/vda1 maj-min: 254:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 926 MiB used: 96.2 MiB (10.4%) priority: 100 dev: /dev/zram0
Sensors:
Src: lm-sensors+/sys Message: No sensor data found using /sys/class/hwmon or lm-sensors.
Info:
Processes: 137 Uptime: 3d 17h 54m wakeups: 975 Memory: available: 927 MiB used: 553 MiB (59.7%)
Init: systemd v: 253 default: graphical tool: systemctl Compilers: N/A Packages: pm: pacman
pkgs: 859 libs: 264 Shell: Bash v: 5.1.16 running-in: pty pts/1 (SSH) inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-06-30
Last full system update: 2023-07-04 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:

No problem with these packages here.

sudo pacman -S garuda-fish-config fish-autopair
warning: garuda-fish-config-1.5.15-1 is up to date -- reinstalling
warning: fish-autopair-1.0.4-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (2)                Old Version  New Version  Net Change

chaotic-aur/fish-autopair  1.0.4-1      1.0.4-1        0.00 MiB
garuda/garuda-fish-config  1.5.15-1     1.5.15-1       0.00 MiB

Total Installed Size:  0.02 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(2/2) checking keys in keyring                                                        [-------------------------------------------------] 100%
(2/2) checking package integrity                                                      [-------------------------------------------------] 100%
(2/2) loading package files                                                           [-------------------------------------------------] 100%
(2/2) checking for file conflicts                                                     [-------------------------------------------------] 100%
(2/2) checking available disk space                                                   [-------------------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 181
:: Processing package changes...
(1/2) reinstalling fish-autopair                                                      [-------------------------------------------------] 100%
(2/2) reinstalling garuda-fish-config                                                 [-------------------------------------------------] 100%
:: Running post-transaction hooks...
(1/6) Arming ConditionNeedsUpdate...
(2/6) Foreign/AUR package notification
=> No foreign/AUR packages found.
(3/6) Orphaned package notification...
=> No orphans found.
(4/6) Checking for .pacnew and .pacsave files...
(5/6) Performing snapper post snapshots for the following configurations...
==> root: 182
(6/6) Syncing all file systems...

Maybe an issue with your virtual machine. :man_shrugging: Looks like you are due for a reboot as well.

Do you have the Chaotic repo enabled? After your reboot, paste the full input-output of garuda-update.

4 Likes

Thanks.... I did not have the chaotic-aur enabled. I followed the instructions on the Chaotic-AUR website. All is working now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.