Sweet Kvantum Theme breaks with latest update (bug with solution)

After the latest update of kvantum-theme-sweet-git(r212.ab6a7d3-1), the theme will no longer show up in kvantum manager and will be disabled.

This is because the latest package puts the folders for both themes (Sweet and Sweet-transparent-toolbar) in /usr/share/Kvantum/Sweet instead of /usr/share/Kvantum/ so kvantum doesn't detect the Sweet theme anymore.

This is either a simple bug with the latest update or an issue with the PKGBUILD

Here is my current brute force solution is:
sudo mv /usr/share/Kvantum/Sweet/ /usr/share/Kvantum/Sweet.bak/

sudo cp -r /usr/share/Kvantum/Sweet.bak/* /usr/share/Kvantum/
Then, you can go into Kvantum and re-enable the Sweet theme!

On further inspection, the latest commit does appear to have changed the location of relevant theme files KDE Improve appearance of sliders and progressbars · EliverLara/[email protected] · GitHub . The PKGBUILD in the AUR needs to be updated or the maintainer of the theme needs to fix the files back to how it was


Thanks for reporting, we will need to fix the PKGBUILD to reflect the changes that happened to filenames.


Alright, should be solved by now. For those who already updated - sudo pacman -Syu kvantum-theme-sweet-git, for others updating should be enough :slight_smile:


I am getting package corrupted error for this. Screenshot

Left is after proceeding from octopi notification. Right side is me manually doing it. Tried Y and N both options.

I even ran the keyring update from Garuda Assistant. Keyring

Perhaps, clear your package cache and retry updating.

If no love, then please open your own help request.

Yup did that as well. So I assume it is just me facing this issue then :confused:

Change your mirrors, you may have an outdated one being used.

When running "System Update" from Garuda Assistant, it does update the mirrors right? Assistant

I did run clear package cache again from the Assistant before running "System Update". The error remains the same.

Also the main problem was that just because of this single package, nothing was getting updated. So I did pacman -Syu --ignore=sweet-kde-git
That at least got the other packages to get updated. I did that before my first comment here.

Edit: I apologise in advance if me editing this comment makes the status open again. Just wanted to share how I solved it.
I noticed this package was coming from chaotic repo. So I edited the chaotic mirrorlist from /etc/pacman.d and commented the geo-mirror server by placing a "#" before it. Then ran pacman -Syu and that worked flawlessly. Then I went back and removed the "#" from the geo-mirror server. (It is to distribute bandwidth geographically, so users don't burden a single server)

Yes, but you can still have a stale mirror in the list. Usually resolves itself if you wait, but testing new mirrors is always worth a try.

I guess we'll close this one out now as the OP's issue is resolved and yours has been worked around.

1 Like