Surfshark-vpn-gui missing

Trying to install surfshark-vpn-gui in order to update. Removed the old version and cleared my cache.
Trying to install it and it is missing. Anyone know how to install it and what happened to the package? It seems to be missing? Surfshark only seems to support deb files.

  Kernel: 6.1.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=f8ed4bcf-36f3-424d-a4df-031651f7603b rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
  Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM v: 43.0
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: X79-DELUXE v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 4805
    date: 02/02/2016
  Device-1: hidpp_battery_0 model: Logitech Wireless Solar Keyboard K750
    serial: <filter> charge: 100% rechargeable: yes status: full
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse M525
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Core i7-4930K bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 4 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3E (62) stepping: 4 microcode: 0x42E
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3440 high: 3900 min/max: 1200/3900 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 2016 2: 2999 3: 2850
    4: 3900 5: 3900 6: 3900 7: 3900 8: 3900 9: 3900 10: 3900 11: 2226 12: 3900
    bogomips: 81649
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA GK104 [GeForce GTX 770] vendor: driver: nvidia
    v: 470.161.03 alternate: nouveau,nvidia_drm non-free: series: 470.xx+
    status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx
    process: TSMC 28nm built: 2012-18 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 2 speed: 5 GT/s bus-ID: 01:00.0 chip-ID: 10de:1184
    class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 2-1.4:5 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: N/A display-ID: :1 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x572mm (40.00x22.52")
    s-diag: 1166mm (45.9")
  Monitor-1: DP-1 res: 3840x2160 hz: 60 dpi: 157
    size: 621x341mm (24.45x13.43") diag: 708mm (27.89") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 470.161.03 renderer: NVIDIA GeForce GTX
    770/PCIe/SSE2 direct render: Yes
  Device-1: Intel C600/X79 series High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 2-1.4:5 chip-ID: 046d:0825
    bus-ID: 00:1b.0 class-ID: 0102 chip-ID: 8086:1d20 class-ID: 0403
    serial: <filter>
  Device-2: NVIDIA GK104 HDMI Audio vendor: driver: snd_hda_intel
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0e0a class-ID: 0403
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Device-4: Logitech Blue Microphones type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 9-1:2 chip-ID: 046d:0ab7
    class-ID: 0300 serial: <filter>
  Sound API: ALSA v: k6.1.8-zen1-1-zen running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.64 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp9s0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-1.6:3 chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 1.8 TiB used: 293.82 GiB (15.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: BB6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Intel model: SSDSC2BP480G4
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0420 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-1: / raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
    used: 293.57 GiB (65.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 596 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
    used: 293.57 GiB (65.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-4: /var/log raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
    used: 293.57 GiB (65.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-5: /var/tmp raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
    used: 293.57 GiB (65.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.29 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 52 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 48%
  Processes: 403 Uptime: 1h 1m wakeups: 35 Memory: 31.29 GiB
  used: 4.25 GiB (13.6%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1693 libs: 506 tools: gnome-software,pamac,paru,yay pm: flatpak
  pkgs: 0 Shell: fish v: 3.6.0 default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.24
Garuda (2.6.14-1):
  System install date:     2023-01-29
  Last full system update: 2023-01-29
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

paru surfshark-vpn-gui
1 aur/surfshark-vpn-gui-git r31.6d8a821-1 [+1 ~0.00]
GUI client for connecting to the SurfShark VPN
:: Zu installierende Pakete(z.B: 1 2 3, 1-3):

Or ask there :slight_smile:

You pay for the service there, don't you?


I asked them I will see there response. The GUI.git does not support wireguard and is not the official surfshark gui app. I want the official surfshark app. Will look into installing deb in arch.

I solve my problem. Or to be more exact the problem solved itself to a degree. The package surfshark-vpn and surfshark-gui has been now replaced with surfshark-client. Yesterday the package was not available since it was broken, but I see that it has been fixed and now it works and it installs the official surfshark graphical user interface and VPN software. The old packages still exist as git but actually bring in an open source version of the gui and a separate version of surfshark command client. Unfortunately the command line client of surfshark does not allow connection through wireguard but uses the old very slow tcp and tdp standards only. The graphical user interface also does not support wireguard. In the end the package get updated and my problem is solved by uninstalling the other two packages and installing surfshark-client from AUR.

yay -S surfshark-client

WireGuard also uses UDP. WireGuard is not faster than OpenVPN because of the Internet Protocol it uses (OpenVPN uses both TCP and UDP), rather it is faster because it has faster cryptographic primitives, a leaner code base, and support has been built directly into the kernel.

Have you seen this? GitHub - Incognito-Coder/Wiregen: a script for generate wireguard configs from surfshark vpn service,based on mobile API


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.