Sudo/I3/Floating window

I have noticed when a something requiring sudo (polkit I think only) pops up, the terminal window I'm using converts to a floating window. Why is this? Never noticed this before on other distros, but maybe I just didn't pay proper attention.
For instance doing 'systemctl stop ' displays this behavior.

Same here, only at the first sudo passwd, I "fixed" it with super + space :smiley:

Well, it's good to know it's replicable and not just something stupid I did on my configuration.

1 Like

I haven't had time to check the i3 configuration yet :wink: or somthing else :smiley:

I found something interesting with regard to this (by accident).
I triggered this via 'ps -aux| grep sudo' (repeatedly but only once per terminal).
I also noticed...graphical corruption which would be either against the background OR possibly polybar. I'll look some more.
Edit: Doesn't appear to be polybar, since killing polybar and grepping sudo still causes the issue. I have a couple of other ideas...will test real quick.
Pretty sure it's the powerline setup for oh-my-zsh. I haven't poked around, but if I invoke /bin/bash before sudo, the problem doesn't occur. Being as I really don't know much about powerline, I'll stop there.

1 Like

Are you using another language on your computer?

If so, which one (if you don't mind me asking)


Nope. American English.


Hi, I also have this issue with an almost brand new Garuda install. Has anyone been able to fix it?

Since I just solve it with Super+Space I didn't investigate.
Possibly you can catch it somewhere in the i3 conf but the effort is somehow not worth it as rarely as that occurs with me :slight_smile:


Thank you!

I have just uninstalled oh my zsh and that seems to have fixed it.


UPDATE: I found the issue. There is a line in the i3 config file that sets all windows with "sudo" in the title to floating mode. Search "tile=sudo" in your config to find it.

The whole line to remove is:
for_window [title="sudo"] floating enable border normal

Hope this helps people that stumble across this page.


I will fix today, thank you :slight_smile:

I wonder why I never found that...oh, probably because I was mostly using sway, which also sources i3 files (forgot that) in an attempt to be fully compatible.