Sudo command Time-out

What should I do

I'm not allowed to get supper user access what's the reason

My terminal shows at startup [Ctrl + Alt + T]

[WARN] - (starship::utils): Executing command " /usr/bin/sudo " timed out.
[WARN] - (starship::utils): You can set command_timeout in your config to a higher value to allow longer-running commands to keep executing.

It happened after updating the system how can I set higher value in the config

Can I downgrade sudo package :arrow_double_down:

So there is no problem with Long delay and failure with sudo

Any one please suggest me !

:pray::pray: Thanks for the help @filo and others

The best solution :fire: I ever found and worked now no :no_entry_sign: warning in terminal !
I got into this line in ~/.config/starship.toml file

In line

24 # Fouth param
25 [sudo]
26 disabled = true

Editor is KDE kate

Below is the solution suggested by @filo

Check if extending this value helps (I don't think you have to reinstall starship like in that thread).

1 Like

What command is your terminal trying to run with sudo every time you open it?

1 Like

I simply opened terminal

After system update this error occurred

That doesn't answer my question. According to what you wrote, something is configured in your terminal or shell startup scripts that is trying to run a command using sudo. I do not think that is a Garuda default, because it would be a stupid thing to have as a default, and the edition maintainers are not stupid.

2 Likes

I mean the full system updates not Garuda linux update regular arch update

It happened after running update command in terminal

Also I'm not blaming any maintainers

Simply I'm not getting acess in sudo command even if type password correctly

I got into this line in ~/.config/starship.toml file

In line

24 # Fouth param
25 [sudo]
26 disabled = false

After Edit

24 # Fouth param
25 [sudo]
26 disabled = false
27 command_timeout = 1000

But no success on that

My terminal got new warning
[WARN] (starship:: config::sudo): Unknown config key "command_timeout"

I think that's correct.
disabled is false for sudo, so you can use it.

I think that prompt config do exist. See also upstream site:

Probably it should be added in another section of the file.

1 Like

Just I want to remove that warning

I think the problem is elsewhere.
That starship thing should just let you know if you run a command with sudo privileges (which I gather, you are unable to because some other problem).
I'd check /etc/sudo.conf, /etc/sudoers, /etc/sudoers-d/* as first step (you'll have to su first to do that).
Other than that I have no idea, sorry.

Just revert command_timeout = 1000, I'm not familiar with starship config but it's complaining it doesn't understand that directive.

Still I have this message

[WARN] - (starship::utils): You can set command_timeout in your config to a higher value to allow longer-running commands to keep executing.```

I'm really not sure, but command_timeout is a valid directive in /etc/sudoers.
I don't know if that is what the warning message refers to though, I'm just trying to guess.

edit: write down all the steps you take and keep backups, I screwed my setup more than once while trying things out...

I'm really new to linux
Not a experienced user I used linux just three months

And I'm satisfied all my work is done with linux in gimp, LaTeX, pandoc etc ...

Same here, so take my words with a lot of caution.
Can you remember anything that could have caused this problem besides the update?
Last resort is to restore a working snapshot, careful with that too, perhaps wait for better advice.

edit: nevermind, I see I was wrong after all... duh.

I missed the point a little bit... :blush:
Is the sudo problem still there or does it just remain the second warning?
In the second case have you tried rebooting?

2 Likes

Ya, rebooted after update and updating the file
Still warning appears

Can I get my old file through snapshot please tell me so that I can make changes

The default starship.toml file is here: starship.toml · master · Garuda Linux / Themes and Settings / Settings / garuda-starship-prompt · GitLab

But, I'm pretty certain that's not the problem

3 Likes

You can also reset the starship default config with the Garuda Assistant.

3 Likes

Hi, I have 2 laptops. one has sudo --version 1.9.8p2 <this one works.
laptop2 after update Sudo version 1.9.9 which doesnt work.
no root access so cant revert back it seems.

3 Likes

There's a configuration file format change with 1.9.9; if anyone has made any changes to the default /etc/sudoers then they will need to merge the pacnew.

3 Likes