Sudden GDM freeze, now fixed but

I’m opening this mostly for my own curiosity because although I fixed the issue I didn’t understand why or what exactly happened so maybe you can shed some light on it.

So, today I booted up my pc and gdm froze on me (Gnome and Gnome only install, no other DE or login manager), basically loading up the top bar but NOT the actual username/login field.

Nothing relevant happened yesterday, I tried to remember what I installed and it was only reshade, but I did reboot few times after that and it was all normal. So I tried to load up some snapshots and gdm kept freezing. I noticed that gdm acted a lil weird, like it was stopping the loading process unexpectedly without completing all the proper steps, and just throwing a black background at me before freezing (generally the background is kinda bluish). As if it was waiting to find something that it couldn’t find and having some sort of hiccup there.

And so I realized what changed: the network interface! I changed internet provider last monday and so I have a new router now and I’m using an ethernet cable instead of the wireless interface. That’s why I decided to phisycally remove it (it was a PCI interface). But that was last monday, today is thursday. I rebooted many times in between and never had any problem, although I noticed gdm was taking longer than usual to load up.

So, finally I unplugged the ethernet cable and plugged back in the PCI wireless adapter and gdm loaded again as fast as before the change.

Now, I logged in, I upgraded the system (new kernel today, not sure if it matters) and went back to the cable setup, unplugging the PCI wireless thing once again. Now things work, gdm loads up and I can login, but it’s again slower than usual.

TL;DR: afaik NetworkManager should be able to detect which interface to activate (and which not to) but is there a service or something else to change, maye an udev rule, in order to tell the system it shouldn’t be looking for an interface that is not even plugged in?

My garuda-inxi here

1 Like

Aaaaand..... it did it again! The 'wifi interface hack' worked again, but when I swapped back to cable and rebooted... guess what? It did it again :expressionless:
But this time for whatever reason it prompted me into an 'emergency mode' I wasn't even aware of and I had the chance to login as root and check the journal.

Turns out the real problem was a usb hub where I had my keyboard and mouse plugged in. Don't ask me why the wireless interface hack worked as it did, don't ask me why the problem happened only sometimes and not every single one, don't ask me what's wrong with the damn usb hub... I have no idea. What I think though is that we can pin this whole thing as a 'systemd screwup' v0v

Anyway... I'd like to mark the thread as SOLVED but I can't edit the OP :thinking:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.