Stuck on fresh installation

Hey guys, I’ve ran into an issue installing Garuda Dragonized Gaming Edition on a laptop. I flashed my drive, disabled secureboot, loaded into installation and no matter which option I chose (open source drivers or Nvidia) I get

dracut Warning: Could not boot
GARUDA_…_RAPTOR does not exist

And then it drops to debug shell after waiting for aprox. 3-4 mins on

Starting systems-udevd…

What could be the problem? Should I switch to discrete or integrated graphics in uefi in order to complete installation or is there other problem that persists?
P.S. This is my first time installing a Linux OS on a laptop.

Laptop Model Number: 82JW00F9PB

Hola friend !

I want you to do these steps and see if issue is resolved.

1.Download the latest Garuda iso once again .

2.Verify checksum of iso.

4.Format the usb drive as fat32.

Use Rufus , balena to create the live media.

See if this solves it.

Because it seems that the iso or installation got corrupted somehow.


Alright, will do.
I used rufus and then switched to balena cause I saw other tutorial video of installation that showed it.
Also, what if I didn’t format drive as fat32 at first, could that be the problem?
Does rufus/balena format the drive automatically from ntfs to fat32?
I’m sorry if I ask too many questions, it’s just really interesting and I’m genuinely curious cause I want to make it work and switch to Garuda :smiley:

1 Like

Nah formatting to fat32 isn’t necessary but try that as a precaution if the drive’s partition table got messed somehow.

1 Like

Did you try the latest iso ?


Yes, I downloaded the latest Dragonized Gaming Edition.

1 Like

Ok then try the steps and tell me if it works.


Downloaded .iso, checked sum sha256, checksum is the same, flashed, chose NVIDIA drivers this time and same thing, I waited a couple minutes on

Starting systems-udevd version 254.5-1-arch

And got the same thing.

dracut Warning: /dev/disk/by-label/GARUDA_DR460NIZEDGAMING_RAPTOR does not exist

I’m confused…

Hi @w1ldac3 , Please DISABLE secureboot and fast boot if it is enabled

Am I understanding correctly fastboot is in the OS settings?
Also I did disable secureboot, otherwise it wouldn’t even let me boot into my live drive.

Nevermind, I searched on the net that it’s supposed to be in UEFI/BIOS, but, looking at my UEFI right now, I don’t see any option that resembles fastboot.

One thing you could do is to try Ventoy to burn your USB.
Since with Ventoy you simply drang&drop / copy&paste as many iso on the USB as you like, you could download also the Dr460nized (non-gaming) edition.
If it works, from there, there is a tool to install all the gaming stuff you need.


Try a different usb device or post a complete photo of your BIOS settings privately to me.

Yeah, Gaming Edition just doesn’t want to install for me (tried normal and grub2 in Ventoy), going to download regular Dragonized now and try it.

1 Like

Just use the normal edition and install what you need through the assistant and Garuda Welcome .

1 Like

Alright, so, after trying regular Dragonized and getting the same error, I came to conclusion to just buy another USB drive.

One in the BIOS, another in Windows. Search on posts by @BluishHumility. One has a screenshot of the fastboot settings available via Windows Control Panel. :slight_smile:

I don’t have any option that resembles fastboot in bios, only instant boot which is disabled by default. Let me try disabling fast load in windows then…

UPD: Didn’t change a thing.

I have a link now actually, check it out:

Yeah, I did that, it didn’t change a thing. I ordered new usb drive and gonna try once again when it comes.
Thanks a lot everybody for your help!