Stuck on boot with a blackscreen

Hello,

I have just downloaded Garuda for my PC, but the problem is that I can't boot up if I just power it up. Because when doing so my computer just gets stuck on a lightened black screen right after the logo of my motherboard and I never get to see grub. (the same btw goes for the USB stick where I installed the OS from.) So to avoid this I found out that if I go to the boot menu and manually launch the OS from there, everything works. But I don't want to do this every time when start my PC.
Just to make it clear: My BIOS is definitely supposed to boot Garuda. But apparently it just works when launching from the boot menu.

My Motherboard is the GIGABYTE ga-h87-hd3

To solve the issue:

-I have already tried to reinstall and repair grub via the tool on the USB stick with the Garuda installer

-It also came across my mind to update the Nvidia graphics driver, but I am not 100% sure if I even updated it (I did this in the settings and chose Proprietary Driver). The Idea only came because the Garuda Installer on the USB only ran with open source drivers instead of the Nvidia ones(it got stuck after a Line about plymouth or something )

Apart from that I played a little bit with the settings of the BIOS as well as the Garuda Boot Options, but nothing worked so far.

I would be very grateful if someone could help me.

Benjamin

I seem to recall that with gigabyte mobo's kernel boot parameter iommu=soft might help.
Maybe you could just try, although as said it is just something I remember, no real reference available

1 Like

I'm sorry. I'm new to this. So how do I do this?

Actually if you cannot even reach the grub, there are few chances this will work, anyway...
To add the argument to grub, open a terminal, and type the following:

  1. sudo micro /etc/default/grub
  2. Add the kernel argument to the following line: GRUB_CMDLINE_LINUX_DEFAULT
  3. ctrl+x to exit and “Y” to save.
  4. sudo update-grub
2 Likes

It didn't work but still thank you.
At least I found out that I can also go into the BIOS, leave and it works as well as going into the boot menu.

And grub would be reachable too if I need