Stuck at boot KDE Gaming

About Garuda Desktop Enviroments
I try to install the KDE Gaming version but somehow cant get it to boot

I used Balena Etcher as well as Rufus to write the image on the USB drive.

I also tried the nonfree as well as the free driver option on the Grub menu.

My System:
AMD Threadripper 1920x
nVidia RTX 2080 Super
48 GB ram
1tb SSD

Can someone may help me please?

Check this, please :slightly_smiling_face:

1 Like

I haven't even installed Garuda yet. It stucks at the logo with the cycling dots. No matter which drivers I use.

Press ESC on cycling dots and post as text the output, mhwd need up to 4 min. so wait if you see this.


Thanks! It worked. Yes the mhwd took some time to start. Additionally I noticed that I had my VR headset plugged in so I unplugged the video cable of it to make sure, that it doesnt interfere at any time. I got to the live Desktop now. Thank you again!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.