Strange reboot fail

I am having trouble getting Black Eagle to reboot properly. Specifically, it takes longer than it should, and then bypasses the BIOS, and bypasses grub - and boots straight into Garuda. The obvious workaround is to shutdown instead - which works fine (and is quick too). After a shutdown, BIOS is shown briefly, then boot choices appear normally.

As Garuda sets up a btrfs/Timeshift combo, that adds grub entries for each Timeshift instance - having it skip grub completely is a PITA.
Any ideas what to watch for - extract - try next? Nothing shows on screen until the login manager, so no clues that way - just the long wait while it 'resets' - and then a longer than usual time between that and being ready to login. (based on the backlit keyboard going dark as the marker for reset actually happening).

Thanks for any ideas - it's the only thing not working so far!

GNOME, KDE, Cinnamon .... ???
VM?
Press ESC on boot?

Your spezial ext4 version :smiley: :slight_smile: ?

Of course my translation apps often failed, so I am better out here.

2 Likes

Does garuda use grub-silent aur?

2 Likes

Not on my install.

1 Like

I'm pretty sure it's regular grub

1 Like

I'd see if there is a way to see if it's actually rebooting or just going back to the last session or it's just logging you out when you choose reboot. I can't speak to Linux but I have seen that happen on a Windows machine.

@SGS is right please post desktop version.

Sorry - desktop is XFCE - version is the Black Eagle. I ran into this (sort of) with an install of a much earlier eagle - which is why I ended up with an ext4 install to replace it (at least everything worked, except of course no Timeshift and autosnap capability. The slow down was much worse, too - but I suspect most of that was grub os-prober. In this case I have disabled os-prober, so things autosnap reasonably quickly - and If I could get it to find grub on a reboot, all would be very good.

I have been trying to hit ESC and other measures to see what is going on (such as CTLALT#- but nothing but black screen until login shows up so far.

I am assuming that a boot takes place, because the keyboard and mouse lighting go off, then return (as they do on reboot from other distros). It is interesting that shutdown works, but not shutdown -r - but it could be that systemctl reboot gets called anyway (don't know the precise mechanisms).

To me the weirdest is that is actually quicker to go with shutdown, repower to the boot manager, select Garuda and login than to wait out a 'reboot' - so something must be getting triggered. I have tried removing all 'extras' on the kernel command line without discernable effect, too.

I know it isn't the hardwarel, or Arch base, because the other 4 distros on here (including the ext4 Garuda) all behave normally...