Strange live usb login behaviour

Hello guys,

Some context

I’m a relatively new Garuda user, I ran it as my main OS for a while back in 2021, and now I’m trying to come back :slight_smile: Needless to say that I’ve searched for existing posts/googled/redditted/etc but couldn’t find any reference to the specific problem I’m enountering and I describe below.

Machine details

Also as per the nature of the problem, I’m not able to provide garuda-inxi or similar, as I’m pre-installation.

I can give you details of my machine, which is an iMac 27" late 2013, 3,5GHz 4-core i7 with 8GB DDR3 and a bloody Nvidia GTX 780M - 128GB SSD (that I have split for garuda/macOS dualboot) with an existing systemdboot that is loading primarily an EndevourOS that I installed to teach my daughter some things (and that I’m intending to replace Garuda Hyprland)

Enough novel-length context

The issue


I downloaded the Hyprland version burnt it and went straight to install via usb. I’m going as mentioned for a dual boot alongside Mac OS, I did this several times before way back, shouldn’t have any problems, but unfortunately the issue I’m reporting here happens before I get to the installer - This is something I didn’t see before


When booting the live session and I introduce the login details (garuda/garuda) I see for a split second the terminal background with some [OK] green processes and then I’m thrown back to the login UI, that I can pass. I’ll attach here the screengrab I took from the poor video I recorded from my Phone :stuck_out_tongue:

Also trying to transcribe it the best I can after a huge zoom (is a bit blurred, might have needed some CSI picture post-processing as seen in movies lol) -

what I don’t read clearly will leave it with ... and what I’m gessing I’ll surround with {}

[ OK ] Starting User Runtime Diretory /run/user/{988}
[ OK ] Finished User Runtime Diretory /run/user/{988}
Starting User Manager for {UID 988}
[ OK ] Started User Manager for {UID 988}
... ... ... of User ...
[ OK ] Finishing  {LiveMedia} {Merging slurp?} :smile: 

This lasts I guess like 50/100 milliseconds, maybe less, then as explained I’m back to the login UI. Also called my attention that the logs are not left aligned as usual, but looking as a staircase :man_shrugging:

What I’ve tried

  • Reset NVRAM / PRAM in my iMac - it fixes some weird things many times, wouldn’t harm to try
  • Intentionally introduced wrong password → confirming that I get the expected “wrong password” red message, and also confiming that I’m logging in with correct credentials when the issue ocurrs
  • Tried booting with both Nvidia and free drivers, no difference at all

What I think I’ll try next

As soon as I find some free time and meanwhile I get some hints from you guys

  • Although I believe it doesn’t have anything to do with the problem I have, I’m thinking on destroying the temporary partition system I have with Endevour and it’s systemdb, leave my macOs only there with it’s native EFI and either:
    • leave the space either unalloacated for Garuda so I gpart it within the live usb and configure
    • give all the space back to macOS (for a install alongside option)
  • Try with a bare Arch installation and build the lego parts one by one (feeling lazy to do this, I really really like the way Garuda in general, and Hyprland version in particular) have been awesomely mounted by you guys :star: - I don’t wanna give up !

Thanks a lot in advance for your help, apologies for the long text (I rather get too much information than too little when receiving support requests on my job :stuck_out_tongue: so I apply the same to others)

Really looking forward for your help!!

Edit: After posting realised you allow markdown, thanks! this looks now like one of my merge requests in gitlab lol

1 Like

Have you tried booting with the open source drivers? I guess this could be an nvidia issue.


Thanks for answering @NaN (love the nickname)

yup I did :frowning: I didn’t have much free time these past days, I’m trying this weekend again, and also on another machine :crossed_fingers:

This could also be a corrupt ISO issue. Do re-download the ISO check it’s sha256sum and use either balena or ventoy to flash your USB.

Thankyou. :smile_cat:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.