Steam can't access another partition

For the past week, Steam has not been working correctly, and I think it’s related to my other partition.
Garuda is on sdc6
I have a storage drive on sdb3 (ext4), mounted at /media/noviri/StorageDrivev3/ where I have my Blizzard Games & my steam library stored.

The issue:
If I have the second library set up in Steam, it hangs on “Loading user data” when I start. (I can get around this by going offline, and removing the second library).
Once I get steam running, I can add the library, but when I do it doesn’t pick up any of my games. If I try close steam with the second library, it hangs and does not respond to SIGTERM. I have to use kill -9 to end it, and then it doesn’t save the new library.

I’m guessing it’s an issue with the partition. I ran fsck and it came back clean, and I’ve tried making sure that I own it with “sudo chown noviri:noviri /media/noviri/StorageDrivev3 -R”.

I’m still pretty new to Linux, and Garuda/Arch specifically, so I’m hoping that there’s something I’m missing.

I have searched, but I can’t find anyone with this same issue.

I would consider mounting it in /etc/fstab so that you establish ownership at boot. It’s ext4, as you say, so I wouldn’t envision any particular problems arising.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.