Starting audacity causes system to freeze

System:    Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=622586c4-6f82-4957-a50c-3aa9ab09c772 rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: Cinnamon 5.0.7 tk: GTK 3.24.30 wm: muffin vt: 7 dm: LightDM 1.30.0
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 82JY v: Legion 5 17ACH6H
           serial: <superuser required> Chassis: type: 10 v: Legion 5 17ACH6H
           serial: <superuser required>
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <superuser required>
           UEFI: LENOVO v: GKCN46WW date: 10/01/2021
Battery:   ID-1: BAT0 charge: 82.8 Wh (100.0%) condition: 82.8/80.0 Wh (103.5%) volts: 16.7
           min: 15.4 model: Celxpert L20C4PC2 type: Li-poly serial: <filter> status: Full
           cycles: 4
CPU:       Info: 6-Core model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64 type: MT MCP
           arch: Zen 3 family: 19 (25) model-id: 50 (80) stepping: 0 microcode: A50000C cache:
           L1: 384 KiB L2: 3 MiB L3: 16 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
           bogomips: 79050
           Speed: 1722 MHz min/max: 1200/3300 MHz boost: enabled Core speeds (MHz): 1: 1722
           2: 2530 3: 2217 4: 2797 5: 3220 6: 1499 7: 4049 8: 2794 9: 3211 10: 1794 11: 2087
           12: 3177
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP:
           always-on, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Lenovo
           driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
           chip-ID: 10de:2560 class-ID: 0300
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:3
           chip-ID: 04f2:b6c2 class-ID: 0e02 serial: <filter>
           Display: x11 server: X.Org 1.21.1.1 driver: loaded: nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
           s-diag: 583mm (23")
           Monitor-1: DP-4 res: 1920x1080 hz: 144 dpi: 128 size: 382x215mm (15.0x8.5")
           diag: 438mm (17.3")
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:228e
           class-ID: 0403
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo
           driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x bus-ID: 05:00.5
           chip-ID: 1022:15e2 class-ID: 0480
           Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
           bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo
           driver: r8169 v: kernel port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
           chip-ID: 8086:2723 class-ID: 0280
           IF: wlp4s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-4:3
           chip-ID: 8087:0029 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
           rfk-block: hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 520.27 GiB used: 42.08 GiB (8.1%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
           model: PC SN530 SDBPMPZ-512G-1101 size: 476.94 GiB block-size: physical: 512 B
           logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 21160001
           temp: 37.9 C scheme: GPT
           ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Kingston model: DT microDuo 3.0
           size: 28.88 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
           rev: PMAP scheme: GPT
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
           ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Toshiba model: USB FLASH DRIVE
           size: 14.45 GiB block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 24.81 GiB (49.6%) fs: btrfs
           dev: /dev/nvme0n1p7 maj-min: 259:7
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 28.9 MiB (11.3%)
           fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
           ID-3: /home raw-size: 50 GiB size: 50 GiB (100.00%) used: 24.81 GiB (49.6%) fs: btrfs
           dev: /dev/nvme0n1p7 maj-min: 259:7
           ID-4: /var/log raw-size: 50 GiB size: 50 GiB (100.00%) used: 24.81 GiB (49.6%)
           fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
           ID-5: /var/tmp raw-size: 50 GiB size: 50 GiB (100.00%) used: 24.81 GiB (49.6%)
           fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 15.54 GiB used: 2.2 MiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 363 Uptime: 7m wakeups: 1 Memory: 15.54 GiB used: 3.26 GiB (21.0%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages:
           pacman: 1420 lib: 336 Shell: Zsh v: 5.8 running-in: alacritty inxi: 3.3.09

Hello! I recently moved to Garuda Cinnamon and stumbled across a very strange issue; attempting to start Audacity causes the entire system to freeze, i.e. frozen screen, looping sound (if any), no TTYs or REISUB. I even tried enabling sshd to check if I could connect after the freeze. Only cutting the power works. I also installed rsyslog, all logs seem normal. How can I even troubleshoot this any further? How could a program cause such problems? I still have my old installation (KDE Dragonized) in another partition, if that's of any help.

Edit: Memory usage seems fine while running Audacity. I tried reinstalling Audacity too.

Maybe try Sneedacity instead (in Chaotic AUR):

Sneedacity (formerly Audacity) is an easy-to-use, multi-track audio editor and recorder for Windows, Mac OS X, GNU/Linux and other operating systems. Sneedacity aims to provide a telemetry-free experience while otherwise being up-to-date with Audacity's original codebase, with minor improvements being added as (s)needed by contributors and volunteers like you at large. Sneedacity is free software licensed under GPL, version 2

3 Likes

I would move to sneedacity sooner or later, but I thought it would suffer from the same issue. I was wrong apparently, sneedacity works fine. Should I mark this as a solution though?

Not having telemetry included sounds like a better solution than having it included. :rofl:

However, it is more of a workaround, (but hey if it works). :man_shrugging:

The choice is yours to mark it as solved if you wish.

2 Likes

Just for the sake of curiosity, can anyone reproduce the crash/freeze (fully updated system as of now)? It's possible that most people using Garuda/Arch moved away from Audacity, so no one experienced this.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.