Spotify Doesn't allow to play music

Hello,My First post , I'm using garuda linux for past few months , I am facing a issue with spotify for past few days where it does not allow me to login and say's that firewall is blocking it also does not allow me to play song's . Where the web app work's .

Any Help is appreciated

Here is ,
inxi -Faz

System:    Kernel: 5.13.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2e3e23e7-4679-4805-939e-86bd2fc1d55d  
rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Convertible System: HP product: HP Pavilion x360 Convertible 14-ba1xx  
v: Type1ProductConfigId serial: <filter> Chassis: type: 31 serial: <filter>  
Mobo: HP model: 83C4 v: 31.61 serial: <filter> UEFI: Insyde v: F.55 date: 06/08/2020  
Battery:   ID-1: BAT0 charge: 9.4 Wh (23.2%) condition: 40.6/40.6 Wh (100.0%) volts: 11.1 min: 11.6  
model: 333-54-5D BK03041XL type: Li-ion serial: <filter> status: Discharging  
Device-1: hid-0018:04F3:2522.0004-battery model: ELAN0732:00 04F3:2522 serial: N/A charge: N/A  
status: N/A  
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: A (10) microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800  
Speed: 3401 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 3401 2: 3401 3: 3401 4: 3400  
5: 3401 6: 1046 7: 1832 8: 3354  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:5917 class-ID: 0300  
Device-2: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo bus-ID: 1-4:3  
chip-ID: 04f2:b5d6 class-ID: 0e02  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 120 s-size: 406x228mm (16.0x9.0") s-diag: 466mm (18.3")  
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7") diag: 354mm (13.9")  
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.6 direct render: Yes  
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel  
v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403  
Sound Server-1: ALSA v: k5.13.7-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.32 running: yes  
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3040 bus-ID: 02:00.0  
chip-ID: 8086:095a class-ID: 0280  
IF: wlo1 state: up mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-5:4
chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:    Local Storage: total: 931.51 GiB used: 108.49 GiB (11.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 1TB size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q scheme: GPT
Partition: ID-1: / raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 108.49 GiB (11.7%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 108.49 GiB (11.7%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 108.49 GiB (11.7%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 108.49 GiB (11.7%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 46.0 C mobo: 40.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 314 Uptime: 28m wakeups: 6 Memory: 15.51 GiB used: 2.76 GiB (17.8%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1466 lib: 382
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06~~~

Hi there, welcome!
This is definitely an application issue, I don't think Garuda can do much here.
If you use a VPN, try disabling it.
If you have a firewall configured, allow the spotify traffic.
But above all, search on the Internet, I see there are many hits for that (e.g. change country in your profile, etc.).


Thanks , I tested the app in gnome version of garuda and it worked . I think there is some conflict between the application which is forcing spotify to crash or not allowing it to play ...... :sweat_smile:

1 Like

OK, I see, the package scenario is quite weird, there's a version in the AUR but also the snap one could be possible.
If you used the AUR one, you could give a look at the comments, all quite recent: in the (current) second page a user claims to have solved the issue by simply reinstalling, in the first page someone installed in addition qt4-bin.


Ya , I think there is a conflict between the package for now i'm using the web version of it , I need to do a fresh install of garuda on my laptop next week.

Well , I found that clearly there is some conflict between the packages in my machine because when i tried it with garuda dragonised versionin a VM (I know it is not supported) and it worked . Thanks @filo for solving my issue !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.