Spectacle: error while loading shared libraries: libavcodec.so.60

Spectable has been broken since a while; I thought it might fix itself with updates but it doesn’t. Ran all system updates and cleaned up AUR repos.

spectacle returns

spectacle: error while loading shared libraries: libavcodec.so.60

Inxi

System:
Kernel: 6.8.8-1-cachyos arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
root=UUID=58203bda-e2e2-4c32-a006-c91d933cad4e rw rootflags=subvol=@
loglevel=3 quiet intel_iommu=on iommu=pt ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: Acer product: Predator PH315-53 v: V2.04
serial: <superuser required>
Mobo: CML model: QX50_CMS v: V2.04 serial: <superuser required>
part-nu: 0000000000000000 uuid: <superuser required> UEFI: Insyde v: 2.04
date: 08/20/2021
Battery:
ID-1: BAT1 charge: 43.5 Wh (99.8%) condition: 43.6/58.8 Wh (74.2%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: not charging
CPU:
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xFA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 1942 high: 2477 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 2238 2: 2200 3: 2292
4: 2340 5: 2007 6: 800 7: 800 8: 1700 9: 2361 10: 2477 11: 2289 12: 1800
bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none off: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 550.54.14
alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of
2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s ports: active: none off: HDMI-A-2 empty: DP-1
bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-1-0 note: disabled pos: primary
model: Samsung serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 40
gamma: 1.2 size: 1210x680mm (47.64x26.77") diag: 1168mm (46") ratio: 16:9
modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 note: disabled model: AU Optronics 0x82ed built: 2018
res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: iris
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.6-arch1.2.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9bc4 memory: 15.09 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 11 device: 0 type: integrated-gpu
name: Intel UHD Graphics (CML GT2) driver: mesa intel v: 24.0.6-arch1.2.1
device-ID: 8086:9bc4 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 2060 driver: nvidia v: 550.54.14
device-ID: 10de:1f15 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.6-arch1.2.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-3: Texas Instruments PCM2900B Audio CODEC
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-1.3:8 chip-ID: 08bb:29b0 class-ID: 0300
API: ALSA v: k6.8.8-1-cachyos status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks Dual Band
Wi-Fi 6 Killer AX1650i 160MHz 2x2 driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek Killer E2600 GbE vendor: Acer Incorporated ALI
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 08:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
IF-ID-2: virbr1 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-networkd,
systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:9 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Drives:
Local Storage: total: 3.19 TiB used: 1.63 TiB (51.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Western Digital
model: WD Blue SN570 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234200WD temp: 68.8 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
SDBQNTY-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 11101100 temp: 24.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3J0 scheme: GPT
Partition:
ID-1: / raw-size: 1.81 TiB size: 1.81 TiB (100.00%) used: 562.25 GiB (30.4%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 51.2 MiB (53.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
ID-3: /home raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 562.25 GiB (30.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 562.25 GiB (30.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 562.25 GiB (30.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 11.72 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:4
ID-2: swap-2 type: zram size: 15.45 GiB used: 18 MiB (0.1%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 59.0 C pch: 80.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB available: 15.45 GiB used: 6.47 GiB (41.8%)
Processes: 384 Power: uptime: 6m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.14 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2255 libs: 575 tools: octopi,pamac,paru
pm: appimage pkgs: 0 Compilers: clang: 17.0.6 gcc: 13.2.1 alt: 11
Shell: garuda-inxi default: Bash v: 5.2.26 running-in: konsole
inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2021-11-24
Last full system update: 2024-05-04
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:            systemd-networkd-wait-online.service

that can sometimes happen with updates. Sometimes a library updates and a package using that library hasn’t yet been compiled with the new library.

using yay -F libavcodec.so.60 I see that it’s part of the ffmpeg package (which is currently on version 2:6.1.1-7). If you don’t have that installed (which is unlikely) then install that.

Since you also aren’t partially upgraded I can only really suggest to update again. Maybe with a mirror refresh too. Sometimes mirrors are really out of date

Edit: Just noticing that you also have octopi installed. Try reinstalling spectacle with pacman directly. If I remember correctly octopi has its own selection of mirrors so that might cause problems too

2 Likes

garuda-update automatically refreshes mirrors.

sudo pacman -R spectacle
sudo pacman -S spectacle
spectacle

spectacle: error while loading shared libraries: libavcodec.so.60: cannot open shared object file: No such file or directory

Nope.

It is used by:

extra-x86-64-v3/ffmpeg 2:6.1.1-7.1
    usr/lib/libavcodec.so.60
extra/ffmpeg 2:6.1.1-7
    usr/lib/libavcodec.so.60
chaotic-aur/ffmpeg-full 6.1.1-3
    usr/lib/libavcodec.so.60
chaotic-aur/ffmpeg-obs 6.1.1-10
    usr/lib/libavcodec.so.60
chaotic-aur/lib32-ffmpeg 2:6.1.1-2
    usr/lib32/libavcodec.so.60
chaotic-aur/losslesscut-bin 3.59.1-4 [installed]
    usr/share/losslesscut/resources/libavcodec.so.60

Try reinstalling ffmpeg and spectacle:

sudo pacman -S ffmpeg spectacle
3 Likes

What repo is that? It certainly overrides the extra I know with a higher package version.
Neither of them list the package as installed.

also what about ldd /usr/bin/spectacle?

Have an issue with Spectacle crashing on launch getting this error message.

the message recipient disconnected from the message bus without replying

Was having other issues with Spectacle not loading before this which seemed to have been fixed in recent patches likely caught by user feedback in KDE.

Much appreciated.

ALHP v4 compilations

That solved it!

ffmpeg-git was the issue.

Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.