Some updates are breaking the system

Whenever I do this set of updates and reboot I get “Failed To Start Simple Desktop Manager”. the last try I didn’t even get that, it just sat at loading zen… I know there is another pack of 48 updates after this one. A second issue is I rolled-back to 17:45 and it went great, I attempted the updates again and same issues as above, chose to rollback to 17:45 again and got the above message again. That is a snapshot no matter how many times I choose it if it booted once it should boot every time. It’s like some how by choosing it it got changed some how. I posted the entire Konsole output cause of the database errors, even though I just updated the databases.

Garuda Linux 5.8.2-zen1-1-zen x86_64

18:45:09  [email protected]  ~ 
$ topgrade

―― 18:45:16 - System update ――――――――――――――――――――――――――――――――――――――――――――――――――――
[sudo] password for alienprober:
:: Synchronizing package databases…
error: failed retrieving file ‘core.db’ from arch.mirror.square-r00t.net : Protocol “rsync” not supported or disabled in libcurl
core is up to date
error: failed retrieving file ‘extra.db’ from arch.mirror.square-r00t.net : Protocol “rsync” not supported or disabled in libcurl
extra is up to date
error: failed retrieving file ‘community.db’ from arch.mirror.square-r00t.net : Protocol “rsync” not supported or disabled in libcurl
community is up to date
error: failed retrieving file ‘multilib.db’ from arch.mirror.square-r00t.net : Protocol “rsync” not supported or disabled in libcurl
multilib is up to date
herecura is up to date
chaotic-aur is up to date
:: Starting full system upgrade…
warning: subtitlecomposer: local (0.7.0-4) is newer than herecura (0.7.0-3)
resolving dependencies…
looking for conflicting packages…

Packages (11) lib32-nvidia-utils-450.66-1 lib32-opencl-nvidia-450.66-1
libspeechd-0.10.1-1 libxnvctrl-450.66-1 nvidia-dkms-450.66-1
nvidia-settings-450.66-1 nvidia-utils-450.66-1
opencl-nvidia-450.66-1 pcsx2-git-1.7.0.r165.328e358b2-1
proton-tkg-git-5.15.2.r5.g4242749b-1 speech-dispatcher-0.10.1-1

Total Download Size: 685.81 MiB
Total Installed Size: 1752.98 MiB
Net Upgrade Size: 16.01 MiB

:: Proceed with installation? [Y/n]

1 Like

Looks like nvidia update is causing problems for you

When you restore a snapshot it gets replaced with current state

So you have to make a new snapshot before update

And the timing will change since it will be a new snapshot

2 Likes

still seems strange to me cause that 10 or 11 updates were done after 1800 which means i should of had a snapshot newer than 1745 from the snapshot done prior to the updates being applied. I’m currently on one from just after 1300. So with that said how do we go about trying to resolve this? Also if I do a snapshot now it should boot to it if I need it, right? I have not done those updates again cause wanted to wait to see what you guys think.

When you restore the snapshot i t gets deleted or replaced

So to have your this working state preserved

You can go to timeshift and make a new snapshot.

So current state will be snapshotted.

As for this problem I think you wait a day or two

As arch has just released the package.

We might see a new version which will fix this problem.

1 Like

So snapshots I manually make outside of the update process do not get deleted? You have the updates coming straight from Arch without vetting them before they get to us?

Yes we don’t have a middle man

That is why we use btrfs and timeshift
To deal with updates causing problems

As usually the problem gets fixed quickly

So what we need to do is just restore the snapshot and wait.

Well yes snapshots you make manually does not get deleted

1 Like

OK, seems to be another issue. Now the 2 times I did do the updates I watched it create the snapshot and it said they were successful. Now I try to manually create one the popup stays open for a couple of seconds and then closes just leaving the main Timeshift app open.

Try

timeshift --create
1 Like

I swear sometimes, cause I’d just got done trying that just as you have it and got told it didn’t recognize the command. now try it again after you made your post it worked.

 19:35:20  ✘  [email protected]  ~ 
$ sudo su                   
[sudo] password for alienprober:                   
[[email protected] alienprober]# timeshift --create
Using system disk as snapshot device for creating snapshots in BTRFS mode

/dev/nvme0n1p3 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

Creating new backup...(BTRFS)
Saving to device: /dev/nvme0n1p3, mounted at path: /run/timeshift/backup
Created directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2020-08-21_19-35-43
Created subvolume snapshot: /run/timeshift/backup/timeshift-btrfs/snapshots/2020-08-21_19-35-43/@
Created control file: /run/timeshift/backup/timeshift-btrfs/snapshots/2020-08-21_19-35-43/info.json
BTRFS Snapshot saved successfully (0s)
Tagged snapshot '2020-08-21_19-35-43': ondemand

Always do

sudo update-grub

After creating snapshots so your snapshots get listed on grub menu

1 Like

cool thanks for that

You could write a service to do that (will delay shutdown aprox 5 secs).

Create the service file:

/etc/systemd/system/update-grub-shutdown.service

With the following contents:

# cat /etc/systemd/system/update-grub-shutdown.service
# systemctl enable --now update-grub-shutdown.service
# systemctl start update-grub-shutdown.service
# systemctl status update-grub-shutdown.service
# systemctl stop update-grub-shutdown.service
# systemctl disable --now update-grub-shutdown.service
# systemctl daemon-reload

[Unit]
Description=update-grub before shutdown
Before=shutdown.target halt.target poweroff.target reboot.target

[Service]
Type=simple
ExecStart=/bin/bash -c "update-grub"

[Install]
WantedBy=shutdown.target halt.target poweroff.target reboot.target

2 Likes

Thanks but this was 1 install ago, plus no one thought to think that manually making a snapshot does only take a quick second under BTRFS and then the dialog box does close automatically.