[SOLVED] Wayland + GDM 42.0+r11 not working


I use Gnome + Wayland. I was set that in Garuda-Assistant.
Wayland does not start after updating GDM to v. 42.0+r11. I get an error:

Failed to create wl_display (No such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

I noticed that the file /lib/udev/rules.d/61-gdm.rules changed after updating GDM from v. 42.0-1 and this is why Wayland not starting.

Temporarily downgrade gdm but how to fix completely ?

Hi, welcome in! :wave:

I recently authored a wiki page that goes into broader detail on some of this. GNOME 42 is very new and as you may know GNOME likes to throw everyone for a loop every 6 months. Garuda's GNOME edition hasn't seen a lot of attention for a cycle or two, but I've just become a maintainer for the spin and I'm working on things.

On that note, reports like these are important to me, so I'll try to help you out! I may ask for a bit more detail than usual for my own work, so I hope you'll bear with me.

First, could you share some of the relevant details?

  1. The output of garuda-inxi and printenv, and if the breaking upgrade was your most recent upgrade, rip as well.
  2. The contents of /etc/gdm/custom.conf, /lib/udev/rules.d/61-gdm.rules, and /etc/environment. You can copy-paste from the files or use cat /path/to/file for each.
  3. Do you have any themes or extensions enabled?

If you haven't downgraded GDM yet, I'd also appreciate printenv and the files listed in no.2 before and after.

EDIT: sorry, one more - does pacman's post-install log give any warnings about .pacnew or .pacsave files?



  1. garuda-inxi
    JustPaste.it - Share Text & Images the Easy Way
    JustPaste.it - Share Text & Images the Easy Way

JustPaste.it - Share Text & Images the Easy Way

  1. Adw-gtk3 for olders GTK3 Apps

After up

cat /lib/udev/rules.d/61-gdm.rules


Ah, thank you for the swift response! Real quick, could you edit your posts to separate those into formatted code blocks with ``` or ~~~ on either side? Just like you did for the error in your first post, makes it more readable. Already looking into it but yeah, would appreciate it! :slight_smile:

1 Like

Follow the Arch wiki instructions: https://wiki.archlinux.org/title/GDM#Wayland_and_the_proprietary_NVIDIA_driver


Thanks. Solved :slight_smile:


Just to be sure, ln -s /dev/null /etc/udev/rules.d/61-gdm.rules is what did the trick?

1 Like

Yup, so simple...shame :wink:

1 Like

All good! Glad it was easy to sort, and this is a valuable contribution for me because I don't have NVIDIA hardware myself. @jonathon's suggestion was next up, just wanted to have a look at the situation. I'll add a note on the wiki for NVIDIA users.

Once again, thanks for the responsiveness!

(btw, this forum has its own pastebin up in the top bar, formatting comes out the same as code blocks in posts - no criticism, ya got me the info either way, but so you know for the future :slight_smile: )


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.