[Solved] Warning: removing 'pulseaudio'

I'm having something similar, also a fresh install. KDE light, but the same was happening in KDE Ultimate. (I'm also kind of a newbie, I have a decent amount of experience with Ubuntu but pacman is new to me) Here's my output:

āÆ sudo pacman -Syu

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.
  
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from mirror.pkgbuild.com : Protocol "rsync" not supported or disabled in libcurl
 core is up to date
error: failed retrieving file 'extra.db' from mirror.pkgbuild.com : Protocol "rsync" not supported or disabled in libcurl
 extra is up to date
error: failed retrieving file 'community.db' from mirror.pkgbuild.com : Protocol "rsync" not supported or disabled in libcurl
 community is up to date
error: failed retrieving file 'multilib.db' from mirror.pkgbuild.com : Protocol "rsync" not supported or disabled in libcurl
 multilib is up to date
 chaotic-aur          1616.2 KiB  2.04 MiB/s 00:01 [-------------------] 100%
:: Starting full system upgrade...
:: Replace garuda-bluetooth with chaotic-aur/bluetooth-support? [Y/n] n
:: Replace garuda-gstreamer with chaotic-aur/gstreamer-meta? [Y/n] n
:: Replace garuda-input with chaotic-aur/input-devices-support? [Y/n] n
:: Replace garuda-network with chaotic-aur/networkmanager-support? [Y/n] n
:: Replace garuda-printer with chaotic-aur/printer-support? [Y/n] n
:: Replace garuda-samba with chaotic-aur/samba-support? [Y/n] n
:: Replace garuda-scanner with chaotic-aur/scanner-support? [Y/n] n
:: Replace garuda-settings-samba with chaotic-aur/garuda-samba? [Y/n] n
:: Replace garuda-settings-samba with chaotic-aur/samba-support? [Y/n] n
resolving dependencies...
looking for conflicting packages...
warning: removing 'pulseaudio' from target list because it conflicts with 'pipewire-pulse'
:: garuda-samba and garuda-settings-samba are in conflict. Remove garuda-settings-samba? [y/N] y
:: pipewire-pulse and pulseaudio are in conflict. Remove pulseaudio? [y/N] y
:: pipewire-pulse and pulseaudio-modules-bt-git are in conflict (pulseaudio-bluetooth). Remove pulseaudio-modules-bt-git? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'pulseaudio=14.0-1' required by pulseaudio-jack
:: unable to satisfy dependency 'pulseaudio=14.0-1' required by pulseaudio-lirc
:: unable to satisfy dependency 'pulseaudio=14.0-1' required by pulseaudio-rtp
:: unable to satisfy dependency 'pulseaudio=14.0-1' required by pulseaudio-zeroconf

Aside from this, I love the look and feel of the KDE version, really beautiful!

1 Like

and

:slight_smile:

5 Likes

This worked, thank you for the quick reply!

3 Likes

Welcome to the forums @sam :wave:

4 Likes

Was having this exact problem. Thanks

2 Likes

4 Likes

Welcome to the forums @DittoGod :wave:

3 Likes

Not sure what is causing this but I had the problem too, and your suggestion worked. Thank you!!!

3 Likes

error: target not found: garuda-pipewire
error: target not found: pipewire-alsa
error: target not found: pipewire-pulse

This is the error after u suggested that. Now what can be done?

This means that you have already removed Pipewire.

Also, new problem new thread.

2 Likes