[Solved] Virtualbox Broken

Hi all,

At some point my Virtualbox stop working with both lts and zen kernels. When I try to start a VM I get a message like this:

My linux headers are installed for both kernels (zen and LTS) -- dkms builds the kernel modules correctly but for some reason it doesn't work. I've alse tested with linux-arch kernel and the arch modules for VirtualBox. No luck either, always the same result. I've downgraded the kernels, I've downgraded VirtualBox, and still no luck.

I've even tested signing the modules. I've also tryed removing the safe boot in my laptop with no luck. Always the same message in VirtualBox logs: ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={85632c68-b5bb-4316-a900-5eb28d341 3df} aComponent={MachineWrap} aText={The virtual machine 'arco' has terminated unexpectedly during startup with exit code 1 (0x1)}, preserve=false aResultDetail=0

However, If I download VirtualBox from Virtualbox's download website (Downloads – Oracle VM VirtualBox) it works without problems.

Any further hint on this, please?

Sorry, we can't fix any closed or open source software in the world.

Post to https://virtualbox.org/

1 Like

Thank you for your response. I really understand your point. However, software from Virtualbox works when I download it from their site.

Is your OS up-to-date?


Maybe ask the package manager about.


1 Like

Thank you. Yes it is updated from today.

There is an Arch package bug report, not sure if it is related.