[SOLVED] Unable to move windows in full screen

Hello. Before anything, my system.

System:    Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=309d0b58-7356-446b-bc9a-2b464dd2fcba
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: Dell product: XPS 8940 v: N/A serial: <superuser required> Chassis:
type: 3 serial: <superuser required>
Mobo: Dell model: 0KV3RP v: A00 serial: <superuser required> UEFI: Dell v: 2.2.0
date: 09/04/2021
CPU:       Info: 6-Core model: Intel Core i5-10400 bits: 64 type: MT MCP arch: Comet Lake family: 6
model-id: A5 (165) stepping: 3 microcode: EA cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 69597
Speed: 887 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 887 2: 1077 3: 974 4: 1765 5: 1214
6: 2797 7: 1593 8: 2261 9: 4029 10: 3944 11: 4013 12: 1779
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel
bus-ID: 0000:00:02.0 chip-ID: 8086:9bc8 class-ID: 0380
Device-2: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 0000:01:00.0 chip-ID: 10de:1b81 class-ID: 0300
Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: intel,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3760x1920 s-dpi: 95 s-size: 1005x513mm (39.6x20.2") s-diag: 1128mm (44.4")
Monitor-1: HDMI-0 res: 1200x1920 hz: 60
Monitor-2: HDMI-1 res: 2560x1080 hz: 60 dpi: 94 size: 690x291mm (27.2x11.5")
diag: 749mm (29.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3 chip-ID: 8086:06c8
class-ID: 0403
Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:10f0 class-ID: 0403
Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek vendor: Rivet Networks driver: r8169 v: kernel port: 3000
bus-ID: 0000:02:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell
driver: ath10k_pci v: kernel bus-ID: 0000:03:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp3s0 state: down mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 0cf3:e009
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:      Hardware-1: Intel Device driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
chip-ID: 8086:06d6 rev: class-ID: 0104
Drives:    Local Storage: total: 1.29 TiB used: 52.42 GiB (4.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KBG40ZNS256G NVMe KIOXIA 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
rev: 10410105 temp: 54.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EADS-00M2B0 size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 0A01
scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: A-Data model: SU800 size: 119.24 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 8BS scheme: MBR
ID-4: /dev/sdc maj-min: 8:32 type: USB model: Mass Storage Device size: 29.81 GiB block-size:
physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 52.42 GiB (22.0%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 52.42 GiB (22.0%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 52.42 GiB (22.0%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 52.42 GiB (22.0%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.36 GiB used: 97.8 MiB (0.6%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 27.8 C pch: 53.0 C mobo: N/A gpu: nvidia temp: 55 C
Fan Speeds (RPM): cpu: 811 fan-2: 998 gpu: nvidia fan: 26%
Info:      Processes: 364 Uptime: 2h 45m wakeups: 0 Memory: 15.36 GiB used: 7.27 GiB (47.3%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1555 lib: 457
Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09

This may be an incredibly stupid question. I feel dumb even asking it. But I'm new to this. Anyways, I run a dual monitor setup, but whenever something is full screen on my secondary monitor, I can't make it smaller or move the window around. This is because the dock at the top that says "Firedragon" "File" etc; is only on my main monitor. Even the top "title" bar isn't there. I can't resize from the edge of the screen either. Any help would be appreciated!

UPDATE: Simply changed the display in Layouts to an extended display

IIRC the config isn't good for multiple monitors. You'll need to tweak it to how you want it to work.

Here's one of mine (right click the top bar and edit dock to open these settings).
N.B. I'd advise to first do right click -> layouts -> dr360nized -> Export, to save the default config and to continue exporting as you tinker around and learn it.



Thank you. I went to the layouts and played around with the different kinds, creating new ones, switching, etc. It seems the Extended layout works the best and shows the "titles" at the top of the windows. I can now freely move my stuff, make it smaller, and so on. Thanks again!

I know this is marked as solved but wanted to put this here if needed to position a window before setting up a different layout.

If the window doesn't respond to the double click command of the top bar on the other screen to resize it down, you can move a window to the other monitor that does has the top bar by using Meta (Windows key or similar) + shift + directional key (direction depending on your monitor setting position), and then it should respond to commands as normal

If you want your top latte panel to handle windows onnall screens you need to enable this with: right click top panel, Behavior advanced settings, Track Window:From All Screens

An alternative solution could be to duplicate your top panel, right click dock, Add dock..., Duplicate panel.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.