[Solved] Touchpad Tap-to-Click grayed out

I am looking to have Tap-to-Click enabled on KDE Plasma, but the setting is not able to be selected. I obviously have mouse movement and page scroll with two-finger, but I can only use physical left press to click. Is there a reason why this option is disabled?

What does pacman -Q | grep synaptics bring back for you? I had this once, and I used the wrong touchpad driver. . .

As always, please post up relevant specs with inxi so we can help you more. This is a pretty vague question without knowing your hardware a bit more. Thanks!


Thank you for your response, you'll have to pardon my lack of details since I've been a Linux user for just under a month now and was not even sure about how to provide you with what details you need, so thank you for educating me on the commands.

  Host: scott-81em Kernel: 5.10.15-120-tkg-bmq x86_64 bits: 64
  Desktop: KDE Plasma 5.21.0 Distro: Garuda Linux
  Type: Convertible System: LENOVO product: 81EM
  v: Lenovo ideapad FLEX 6-14IKB serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
  serial: <superuser required> UEFI: LENOVO v: 7QCN44WW date: 06/22/2020
  ID-1: BAT0 charge: 29.4 Wh condition: 36.2/45.5 Wh (80%)
  Info: Quad Core Intel Core i5-8250U [MT MCP] speed: 400 MHz
  min/max: 400/3400 MHz
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org 1.20.10 driver: loaded: intel
  unloaded: modesetting resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
  driver: rtw_8822be
  Local Storage: total: 1.86 TiB used: 19.92 GiB (1.0%)
  Processes: 292 Uptime: 1d 11h 38m Memory: 7.56 GiB used: 4.19 GiB (55.5%)
  Shell: fish inxi: 3.3.01

╭─scott at scott-81em in ⌁
╰─λ pacman -Q | grep synaptics
╭─scott at scott-81em in ⌁
╰─λ System:

Running the query command pacman -Q | grep synaptics brings back nothing.

So, I've always used the synaptic drivers on my Lenovo ( 3 so far)

Make a backup first just in case this doesn't work, but I'd

pacman -Syu xf86-input-synaptics

Reboot and you should have options for tap-to-click

This is the package details: Arch Linux - xf86-input-synaptics 1.9.1-2 (x86_64)

And read up more about it here:


Edit: Welcome to Linux! We're all learning here. Even after years, I'm still learning.


Cheers! Glad to be here!

Thanks for your assistance, this worked perfectly and now I have Tap-to-Click Control. I appreciate your help!


Glad to help! Enjoy!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.