[SOLVED] Ryzen 9 - Freezing, crashing

....Well I feel silly not looking for that first. :rofl:
thanks man!

1 Like
2 Likes

May be look on NVIDIA or Arch site to check your video config

https://wiki.archlinux.org/title/NVIDIA/Troubleshooting

https://forums.developer.nvidia.com/t/the-situation-on-kde-kwin-plasma-performance/57811

The 5.15 kernel bring better support for Nvidia ... So try to use the more recent kernel (5.15) and the more recent KDE (5.23).

Just my 0.02$,
BT

Alright, I went ahead and reinstalled pop-OS and Garuda Linux back on. I even went and applied the tweaks that you guys suggested. I also did the following in the bios:

  • Set M.2 PCI mode to Gen3

I also ordered new ram that was QVL approved for my motherboard as I suspect that the issues (not related to nvidia anyway) might be from ram as I did get BSOD when in windows (which led me to do Linux again) so hopefully that might help with the issues so far.

Also, when installing the Mainline Linux I see an error regarding the modules that also include the ones for Nvidia:

==> Starting build: 5.15.0-rc2-1-mainline-anbox
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [modconf]
-> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
-> Running build hook: [consolefont]
-> Running build hook: [plymouth]
-> Running build hook: [filesystems]
==> ERROR: module not found: `nvidia'
==> ERROR: module not found: `nvidia_modeset'
==> ERROR: module not found: `nvidia_uvm'
==> ERROR: module not found: `nvidia_drm'

Anyone have any ideas about this? I feel like I will need to install the nvidia drivers manually.

Also, as I was typing this in firefox, the tab (and then the browser itself) crash, according to the crash report it was nvidia's falt, so that's one mystery solved.

Last thing, Pop_OS is now showing the same behaviour I was seen in the Gnome version of Garuda Linux (which I did run into issues since my last replay....sadly). Like pacman, dpkg freezes/locks up when updating. Leading me to believe that something might be wrong with the computer itself (hence why I ordered QVL approved Ram).

What do you guys think?

Also be sure anylize your hard drives health with smartmon, as a bad hard drive can cause problems similar in appearance to bad ram.

If you were experiencing bsod in Windows then it's possible your hardware is responsible. Also be sure to check for a bios update.

I have also seen posts regarding freezes with Ryzen 9 CPU's that can be remidied by changing the c state in the bios. When searching for issues with Ryzen 9 be sure to limit your results to the last month or year at the most. If you don't you will get flooded by a ton of posts that were from when the new Ryzen chips were not well supported in the kernel. There are far less issues now, but this still could well be kernel (or bios) related.

2 Likes

TDLR; Turning global c-state off and changes to PBO settings in the bios seems to have worked!

Hey all, Just want to give you guys an update on what has happened within the last week:

So I got the new Ram that was QVL and it blue-screened/kernel panicked :disappointed_relieved:

I then got a new SSD, a Samsung 870 evo and it also BSOD/kernel panicked :sob:

So I went to the Ryzen/AMD forums to see if there's any suggestions similar to my situation.

One off the main ones was to turn off global c-state in the bios. Something that @tbg mentioned. I also took a suggestion regarding changing the PBO settings on that Asus motherboard

and lo and behold my computer is not crashing! (yay!) :tada: :confetti_ball:

Now I did just get it working tonight so I'm going to wait a couple of days first before concluding this, but at least I'm not getting any kernel panics or BSOD on the system!

Regarding Garuda Linux side, with the exception of the dock being kinda low FPS, which I'm assuming is a driver thing, is running great!

It is:

  • No more Complete Computer freeze
  • Pacman finishes and installs with no issues!
  • no Screen freeze
  • Kwin (desktop) still running for over 2 hours with no issues
  • Firedragon no longer randomly have tabs crash (on forms or text only sites like wiki's)
  • No more Freezes at Login screen

Now all that's left is to put in the original M.2 back in (I took it out for testing with just a SSD) and set the PBO settings back to see if global C-suite was the main issue.

That said, thank you all for helping me with this so far! If I no longer have issues, I will mark this or my next post the solution.

AKA I'm going to tweak it 'til it burns! :fire: :fire: :fire:
:wink:

2 Likes

Yes, I did read posts about changing that in the bios as well. I was unfamiliar with what those PBO settings alter, so I thought I'd skip that recommendation.

I'm glad my c-state suggestion helped with your issues. :+1:

And I'm glad you mentioned it. Though I don't really know what the pbo settings do, so I'm probably going to remove those settings and see what happens. I let you all know if this was needed or not.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.