[Solved] Rt8169 driver issues rt 8111 onboard lan

Hi;
Ok , so after deepin desktop issue i tried to switch to xfce then just downloaded the xfce version.
but right off the bat onboard lan no go.
tried this modprobe -v r8169 and got it working some how with one blacklisted on reboot
and tried with rt8168 driver no luck.
lucky I have an older wireless adapter that was known to work in Linux(why i got it).
no other issues thus far got coolbit issue figured and like a champ works(make a conf file in conf.d dir).
but this plan driver thing got me a bit perpeled the deepin release had the driver but this one doesn't and I've done updates etc. if anyone can help guide my lost soul to the fix I thank you.

please mark as closed it's working now .
thanks to this cmd in term I think. ty internet.
ip link show dev eth0
this was a solution for this plan chipset and seems to have worked or I got an update hardline is working yipee.

3 Likes

You can simply uninstall or blacklist the r8168 driver rather than manually modprobing the r8169 driver. If you manually modprobe the driver this needs to be repeated after every reboot (it does not persist).

This is a very common issue with these adapters. Depending on the revision of the chip inside, some versions work better using the r8168 driver. However, for most of these model Ethernet adapters the r8169 kernel module is usually the better choice.

So glad you figured that out for yourself. It's nice to see self starters on the forum who can research and cure their own issues without a lot of help.

Welcome to the forum, cheers.

:beers:

2 Likes

Hi;
Well thank you but it is working now. I have to say after my screwing up manjaro install in day one your distro is the new user Arch in my eyes. I'm a Ubuntu/Debian guy by default I've been at home there.
I've tried Mandrake,Redhat, Mephis, Linux mint, susu,,Antix,PClinux via Supergamer , I remember editing xorg.conf to put nvidia in to get it to work. your distro is now my daily a home in arch linux wow is all I can say.

2 Likes

How is Mandrake these days? :rofl:

I was toying around with libvirt today and noticed I was losing my internet on my host if I tried using a bridged adapter for my guest. Before that I noticed I was only getting 85Mbps down on a 275 connection. So, I am about to pacman -R 8168. Hope it works. I have never had this issue on this machine.

Check the networking sub-forum at Arch Linux. I'm pretty sure there is a recent post with regards to issues with bridged connections recently.

3 Likes

Also,

That command shows the status of the network link, it doesn't change anything.

Possibly you didn't wait long enough for the connection to come up, or you made some other change in the meantime.

Will look. I made another post. This chip has been around for ages and still somehow has these issues.

Ya, the chip has been around forever, but I think there's been over 30 revisions since it originally came out. The r8168 adapter and all it's variations is likely the most used Ethernet chip on the planet by a large margin.