[SOLVED] Realtek rtl8821cu driver needed

I rebooted and the wifi adapter is gone now.

Disable MAC address randomization.

Take all parameters from the command line


 * usb_modeswitch: handle USB devices with multiple modes
 * Version 2.6.1 (C) Josua Dietze 2017
 * Based on libusb1/libusbx

 ! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor=  0x0bda
DefaultProduct= 0xc811

StandardEject=1

Look for default devices ...
  found USB ID 07d1:3c0a
  found USB ID 1d6b:0002
  found USB ID 1d6b:0001
  found USB ID 1d6b:0001
  found USB ID 1d6b:0001
  found USB ID 0bda:c811
   vendor ID matched
   product ID matched
  found USB ID 1d6b:0002
  found USB ID 1d6b:0001
  found USB ID 1532:0200
  found USB ID 1532:0103
  found USB ID 046d:c068
  found USB ID 1d6b:0001
  found USB ID 1d6b:0001
 Found devices in default mode (1)
Access device 004 on bus 001
Get the current device configuration ...
Current configuration number is 1
Use interface number 0
 with class 255
Error: can't use storage command in MessageContent with interface 0; interface class is 255, expected 8. Abort

Reboot, then post lsusb

Did you disable MAC address randomization?

Not sure how I do that. I went to settings and saw where Mac address is and selected a specific one.

Did you search the forum for "Disable MAC address randomization"?

Do this^^^

Also post:

rfkill list

Rebooted and it is back. Network settings assistant asks for password and never opens. I went to wifi settings icon and selected the only mac address there. Here is lsusb and rfkill list.

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0bda:c811 Realtek Semiconductor Corp. 802.11ac NIC
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 004: ID 1532:0200 Razer USA, Ltd Gaming Keyboard [Reclusa]
Bus 004 Device 003: ID 1532:0103 Razer USA, Ltd Gaming Keyboard [Reclusa]
Bus 004 Device 002: ID 046d:c068 Logitech, Inc. G500 Laser Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Garuda Network Assistant ---> Disable MAC address randomization

Reboot computer & router.

Rebooted PC and router and PC still sees it. Garuda Network Assistant does not open though, just asks for my password and that is all that happens.

You have other problems going on.

Try reinstalling polkit:

sudo pacman -Syu polkit polkit-kde-agent polkit-qt5

Reboot.

Sorry, but I'm heading to bed now.

Bye for now.

2 Likes

Sorry, my apologies for recommending reinstalling the KDE versions of polkit. I was pretty tired at the time, and I now see you are on Gnome, not KDE.

You can Disable MAC Address randomization yourself without the need of the Garuda Network Assistant by creating a configuration file for Network Manager. This is all explained in the Archwiki and in countless posts on the forum. Be sure to reboot both the router and computer after creating the NM conf file.

3 Likes

Should I need to do that with it working and has for several reboots?

Not if it's working well now, leave things as is.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.