[SOLVED] Need to reinstall dependencies every time while trying to install any software from pamac-manager

When I am trying to install any new software using pamac-manager, It needs to reinstall each dependencies every time. The pamac-manager gives dialogs like this each time while installing any software,

This time I want to install privacy-badger extension ,

1

2

AFAIK, chosing provider is just an option. Here, as you selected bash, if you already have it then Pamac doesn't install it again, just uses it. If you don't have it then only it installs it. Just search for the differences between the available providers and chose the right one for you.

Someone please correct me if I'm wrong!

If anything needs to be reinstalled, here it will be listed as To reinstall, not under To install.

But, the issue here is that, I installed 3 to 4 applications, yesterday before privacy badger. Each time I got all these same windows. Each time I need to install that about 60MB additional reinstall. So I need to reinstall this additional 60+60+60+60 MB each time Iinstall new software.

I already have bash + ttf + all other dependencies but each time installing new software need to reinstall all.

Do not tell me that you use live ISO.
Post also

inxi -Fxxxza
paleofetch

as text no pictures.

2 Likes
inxi -Fxxxza
System:    Kernel: 5.10.7-111-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=4c7648ba-ff45-4432-b584-c68aaa1e518b rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Garuda Linux 
Machine:   Type: Laptop System: Acer product: TravelMate P243 v: V1.06 serial: <filter> 
           Mobo: Acer model: BA40_HC v: Type2 - Board Version serial: <filter> UEFI [Legacy]: Insyde 
           v: 1.06 date: 08/09/2012 
Battery:   ID-1: BAT1 charge: N/A condition: N/A volts: 7.9/11.1 model: SANYO AS10D31 type: Li-ion 
           serial: <filter> status: Unknown 
CPU:       Info: Dual Core model: Intel Core i3-3110M bits: 64 type: MT MCP arch: Ivy Bridge 
           family: 6 model-id: 3A (58) stepping: 9 microcode: 21 L2 cache: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19177 
           Speed: 2395 MHz min/max: 1200/2400 MHz Core speeds (MHz): 1: 2395 2: 2395 3: 2395 4: 2395 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Acer Incorporated ALI driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel 
           unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
           diag: 389mm (15.3") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.3.3 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Acer Incorporated ALI 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k5.10.7-111-tkg-bmq 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000 bus ID: 04:00.2 
           chip ID: 10ec:8168 
           IF: enp4s0f2 state: down mac: <filter> 
           Device-2: Broadcom BCM43228 802.11a/b/g/n vendor: Foxconn driver: wl v: kernel 
           modules: bcma port: 2000 bus ID: 09:00.0 chip ID: 14e4:4359 
           IF: wlp9s0 state: up mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 35.17 GiB (7.6%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD5000BPVT-22A1YT0 
           size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
           serial: <filter> rev: 1A01 
Partition: ID-1: / raw size: 465.76 GiB size: 465.76 GiB (100.00%) used: 35.17 GiB (7.6%) fs: btrfs 
           dev: /dev/sda1 maj-min: 8:1 
           ID-2: /home raw size: 465.76 GiB size: 465.76 GiB (100.00%) used: 35.17 GiB (7.6%) 
           fs: btrfs dev: /dev/sda1 maj-min: 8:1 
           ID-3: /var/log raw size: 465.76 GiB size: 465.76 GiB (100.00%) used: 35.17 GiB (7.6%) 
           fs: btrfs dev: /dev/sda1 maj-min: 8:1 
           ID-4: /var/tmp raw size: 465.76 GiB size: 465.76 GiB (100.00%) used: 35.17 GiB (7.6%) 
           fs: btrfs dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 2.39 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 2.39 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 2.39 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 2.39 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 71.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 206 Uptime: 2m wakeups: 5 Memory: 9.57 GiB used: 2.42 GiB (25.3%) Init: systemd 
           v: 247 Compilers: gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1272 lib: 300 Shell: fish 
           v: 3.1.2 running in: konsole inxi: 3.2.01

paleofetch 
                     .%;888:8898898:              [email protected]
                   x;XxXB%89b8:b8%b88:            --------------------------
                .8Xxd                8X:.         OS: Garuda Linux x86_64
              .8Xx;                    8x:.       Host: TravelMate P243 V1.06
            .tt8x          .d            x88;     Kernel: 5.10.7-111-tkg-bmq
         [email protected];          .db:              [email protected];   Uptime: 4 mins
       ,tSXX°          [email protected];  
     .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Packages: 1272 (pacman)
   ,888S                                     pd!  Shell: fish
  8X88/                                       q   Resolution: 1366x768
  GBB.                                            Terminal: konsole
   x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.        
     dxXd    dB8b8b8B8B08bB88b998888b88x.         CPU: Intel i3-3110M (4) @ 2.4GHz
      dxx8o                      [email protected]@;.            Memory: 1859MiB / 9799MiB (18%)
        dx88                   [email protected]              
          d:[email protected]                                        
            .d988999889889899dd.                                          

Sorry, its automatically solved after,

sudo pacman -Syu

and restart.
I installed privacy badger extension and its 1.2MB and installed. Don't know why?? But, yesterday and today morning faced same issue and at this time this solved. Plzz, close the topic.