[Solved by reinstall] Garuda Linux, Microphone problem

Hello, I encountered a problem with microphone on Garuda Linux.

ISO name: garuda-dr460nized-linux-zen-210720.iso
Environment: KDE

So this might look like i'm trolling, because of the situation, trust me i'm not.

Like 3 days ago, I installed this voice changer Lyrebird, i'm not gonna lie I don't know what i exactly did, but when i tried running it asked me to install and remove a few packages so i thought its some casual file check.

I found out that pulseaudio got removed. Now cant install it. Also my microphone device isnt detected. Ill send a few screenshots in a minute. Nevermind i cant attach images xD.

Aight so heres the output.

pulseaudio might be found in the following packages:
extra/pulseaudio 15.0-1 /usr/bin/pulseaudio

sudo pacman -S pulseaudio
resolving dependencies... looking for conflicting packages... :: pulseaudio and pipewire-pulse are in conflict. Remove pipewire-pulse? [y/N] y error: failed to prepare transaction (could not statisfy dependencies) :: removing pipewire-pulse breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth

Edit: im thinking maybe i should just reinstall garuda linux after all? I mean id lose some files, programs, but still. Mic will be necessary for me in a few weeks.

Maybe the best thing would be to restore the latest working snapshot

I didnt setup anything with snapshots. How do i do that (can i still do that)?

Timeshift autosnap is installed by default, so you should have some snapshots to recover. Check in the guide how to.

Great thx, ill try

1 Like

Next time please search the forums

I tried that, then it doesnt let me cause, unable to satisfy dependency 'pipewire-pulse' required by pipewire-support

I did it via terminal
sudo timeshift --restore
Chose the time, rebooted. Nothing changed at all even tho the timeshift was back at last months 27day, even the files didnt change.
(It does show that i restored tho)

That's really strange, never seen that.
Although recently I saw some posts on timeshift issues, but didn't read them in details.
Why don't you try to select that snapshot from the grub menu then confirm the restore of the same snapshot in the timeshift GUI?


Timeshift will not restore any audio
configuration files that were stored in your home directory. You could try restoring the default Garuda config using Garuda Assistant. This will reset your default configurations to the default state.

You could also try creating a new user account to see if your sound works correctly using a new account.


I will probably go with the option 1. How could i do that? I mean the default garuda config? That isnt reinstalling everything tho right?

P.S if i don't respond quick, i'm asleep xD, pretty late here

I thought of that. Tried it. Same result

pulseaudio can be provided by a number of other packages.
Check your audio settings to try fix your audio problem.
Before any new post, post your system info as you should have been informed registering the forum or creating a new topic.

It's easy-peasy from a terminal. Package Helpers can be so dumb.

I'm quite new on arch based distros.

How do i do that xD?

You need to remove pipewire-support through the garuds settings manager or garuda assistant can't remember really well open both of them and see if their is a settings tab if there is click on it and uncheck pipewire-support after doing that install pulseaudio with the Bluetooth extension.


But you can read and follow advice.

Unless you provide system info, this topic will be closed.


Sorry for wasting your time, it was smthing with the drivers definetely, i tried everything that was said there. Nothing worked. So i just reinstalled the system :confused:

Is your microphone working as expected then?

Yea everything works now