[SOLVED] Broken Garuda somehow

Hi everyone, my hp probook 430 g7, the orange light on the F11 wifi button is stuck on, no WiFi networks are available to connect to. It was going great up until around new years eve.

I left laptop open right next to my sleeping small breed dog, when he woke up, he literally stood up then stepped onto the keyboard and kind of stepped in place on so many keys.

The reason I left laptop like that was because my mobile phone which I use to hotspot to laptop, the charging port broke, phone went flat and I couldn't surf the web.

Just got a new phone today, tried to hotspot and found this issue.

I noticed the orange wifi disabled light a couple days ago, unsure how long it had been on, don't even know if my doggo done it but I thought nothing of it since couldn't connect anyway.
:red_circle:
After getting new phone today and realizing I was still locked out of internet on laptop, I thought now was a good time to switch back to/create a live boot of Garuda Linux Gnome DE because I like Gnome more than KDE, have just been trialing Garuda KDE Gamer version, but I can't get laptop to format the usb drive to then make a live boot usb to put Garuda Gnome back on laptop and start with fresh untainted version of Garuda.

I have only been using Garuda Linux for couple weeks. I have been usinMint for past year or so and ubuntu before that for similar amount of time.

If i have left out any important information, please let me know and I'll edit post or add comment to get that information
:red_circle:

garuda-inxi
System:
Kernel: 6.1.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1fd99b12-e05a-4a80-af9d-2df7298ee382 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP ProBook 430 G7 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 869B v: KBC Version 02.38.00 serial: <superuser required>
UEFI: HP v: S71 Ver. 01.13.01 date: 06/23/2022
Battery:
ID-1: BAT0 charge: 30.8 Wh (100.0%) condition: 30.8/45.2 Wh (68.0%)
volts: 12.4 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: full cycles: 176
CPU:
Info: model: Intel Core i5-10210U bits: 64 type: MT MCP
arch: Comet/Whiskey Lake note: check gen: core 10 level: v3 note: check
built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
stepping: 0xC (12) microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 3718 high: 4016 min/max: 400/4200 scaling:
driver: intel_pstate governor: performance cores: 1: 3982 2: 2100 3: 3847
4: 3963 5: 3942 6: 4016 7: 3918 8: 3977 bogomips: 33599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:9b41 class-ID: 0300
Device-2: Luxvisions Innotech HP HD Camera type: USB driver: uvcvideo
bus-ID: 1-2:2 chip-ID: 30c9:0009 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x08a6 built: 2019 res: 1920x1080
hz: 60 dpi: 166 gamma: 1.2 size: 294x165mm (11.57x6.5") diag: 337mm (13.3")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel UHD Graphics (CML GT2)
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-LP cAVS vendor: Hewlett-Packard
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:02c8 class-ID: 0401
Sound API: ALSA v: k6.1.1-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
IF-ID-1: enp0s20f0u6 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-10:5 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Device-2: Samsung Galaxy series misc. (tethering mode) type: USB
driver: rndis_host v: kernel bus-ID: 1-6:6 chip-ID: 04e8:6863 class-ID: 0a00
serial: <filter>
Drives:
Local Storage: total: 491.41 GiB used: 58.45 GiB (11.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
model: BC511 HFM512GDJTNI-82A0A size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: HPS0 temp: 47.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Verbatim model: STORE N GO
size: 14.47 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 58.45 GiB (58.5%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p4 maj-min: 259:4
ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%)
used: 58.45 GiB (58.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 58.45 GiB (58.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%)
used: 58.45 GiB (58.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.47 GiB used: 1024 KiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/dm-0 maj-min: 253:0 mapped: swap
Sensors:
System Temperatures: cpu: 60.0 C pch: 48.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 273 Uptime: 38m wakeups: 44544 Memory: 15.47 GiB
used: 2.69 GiB (17.4%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1899
libs: 531 tools: octopi,pamac,paru Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.12-1):
System install date:     2022-12-24
Last full system update: 2022-12-30
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            [email protected]

Have you shut down the laptop, and brought it up from a cold boot?

What is the F11 button? Airplane mode?

What is your method for formatting the drive?

1 Like

Methinks there's some Fn+something key to toggle wifi.
What does rfkill say?

2 Likes

This ^^^ above is the most likely explanation.

Run rfkill list and post the terminal output (no pics only text).

1 Like

rfkill list
0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: no

Search your laptops online documentation to see if there is a specific key combination that you need to press to turn off airplane mode.

Also check the network manager applet to see if airplane mode is turned on.

1 Like

On this laptop F11 is the wifi button.

Im used to the disks application, on Garuda I tried kde partition manager but i couldn't see an option in any menu to format.

Both wireless and bluetooth "soft blocked", I guess it's the airplane mode indeed.
image

1 Like

The bluetooth was off because i was button mashing trying to turn on wifi. Not trying to save face, the fix I stumbled onto might be more embarrassing than the possibility of not turning aeroplane mode off

Anyway, I done the cold boot suggested earlier, disconnected the battery and held power button down for 30 seconds then left laptop for approx an hour then put it back together. When i turned laptop on, still no wifi. I dont know if this done anything for the laptop but wifi was back on quickly after rebooting so it benefitted me taking a break

Turned out i had not looked at Garuda Network Manager, god knows how i missed it. i can turn wifi on from there, I can turn wifi off from system tray but still cant turn wifi back on from system tray but at least laptop back on line.

Going to reinstall Garuda but with Gnome DE now.

Thanks everyone for your help

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.