So after 5+ days of solid uptime

my 2tb wd mybook usb external drive decided to turn itself off and refuse to power on again.
i tried unplugging and replugging all the connectors and nothing.

after a few minutes of searching the issue (a rather prevalent one actually) i disassembled the case and stuffed the drive itself into an empty front bay, plugged it into my bluray drive connectors and bang, reconnected.

i checked out the connector board from the enclosure and couldn't see any damage.
i tested the power adapter and it shoves 12v, perhaps a usb cable failure?
i can't test it because these goofy drives have a custom plug on the drive end.

now it works and tomorrow i'ma dig up extra sata and psu cables to reconnect my bluray burner.

as far as i'm concerned, this problem is 95% solved and will be 100% when i get around to picking up an HDD frame to take space in an empty front drive bay under the burner. (my ssd's take up the 4 drive slots in this tower)

all in all this took about an hour to fix and now i get to watch a movie off my formerly usb external drive lmfao =-)

I LOVE LINUX - and that part is relevant because these WD mybook drives use a file format that windows can't read but is common for linux, some variation of ext.

but now i'm pissed because my uptime counter was reset >=-P


The reason, most probably, is dust. My hard drive, also wd, showed similar behavior. I used vacuum pump (a small one ) and boom, it worked fine. It was an year ago, and it is still working perfectly fine.


it may be, but it was plugged in and running for a couple days no problems and yesterday evening when i wanted to access it to watch a movie, it was no longer listed as a device.
it happened spontaneously while already connected.

i'll try your solution and also swab the contacts with isopropyl and see if it works later today.
thank you =-)

dusted swabbed reassembled and failed lmao

it's not dust. i'm not sure what exactly but the thing is around 8 years old so i'm not too worried. it works as an internal spinner drive so i'm ok with it not being a usb external. i just want my archive >.>

thanks for the tip either way =-)

Five days of uptime... was there a kernel update during that time? If a USB device connects (or reconnects) after a kernel update, but before a reboot, it won't register. All that's needed in that case is a reboot to load the new kernel.


nope not a kernel glitch -i looked it up- and i haven't been updating lately because my gtx 660's got "legacied" by ■■■■■■■ nvidia a few weeks ago so my system hangs on booting with the new 495 driver.

i am actually about to test an update with a modded pacman.conf to skip the nvidia-dkms package. i'll let you folks know how my new adventure goes.

this usb external drive has a little board in it that takes up the sata and power sockets on the hdd. i cannot see any damage to it, i think it's just had a component failure after nearly a decade.

i may also have a damaged usb wire for it, but i cannot test that theory as the input plug design is proprietary and i'm not gonna buy another to test that theory when i have a suitable fix already in place.

usb 3.0 and sata 2 are pretty close in data thoroughput anyway so i'm not losing much performance on this old spinner drive. it's just an archive and backup file space, the only things i run off it are game installers and movies.

thank you all =-)

1 Like

Switch to nvidia-470xx-dkms.

1 Like

oh, something to add - i usually leave it sitting with the usb unplugged to save power and wear and tear on the mechanical components, so the damaged usb connector or port on the device itself is reasonably probable.

Many of the proprietary external drives from Seagate/WD will not be readable when removed from the enclosure and placed inside a Linux based computer.

The formatting and security features of some of these type of drives is often incompatible/unreadable in Linux. In many cases (but not all) where the drive came preinstalled in an external enclosure it must be reformatted (preferably in a Linux native file format) to be made fully functional on a Linux system.

Many prepackaged external drives from the major manufactures can not simply be removed from the external case and plugged into a sata connection internally and be expected to be compatible. Even if the drive is readable in Linux you would be far better off formatting the drive to remove the complex partition schemes and proprietary security utilities that many manufacturers install on their external drive enclosures.

You likely should have backed this drives data up before it became an problem. After the fact, things get far more complicated and this is not a website dedicated to data recovery as that is a little out of the scope of our forum.

Good luck with your issue.


it's already been removed from the enclosure and stuck into my tower, it works fine.
the reason people can't get a read of one of these drives removed from it's enclosure is because they are all windoze users and these WD external spinners use an EXT format internally.
i'll reformat it when i get enough extra space to handle it all, it's a full 2 tb drive and twice my tower's regular drive space.

i looked into all this before i started =-)

thank you!

that's a good idea, ima look into this before my driver skipping causes other problems.
i'ma linux nub so some things i just don't know about yet lmao but i know that regular updates are important for security and such.

thank you! =-)

1 Like

done like dinner!
i took your suggestion but went with the 390.xx series since the Garuda Assistant chose it as the 'automatic driver choice' as it is better for my older hardware.

i had to manually remove the regular nvidia-dkms with console and then used the assistant to install the 390, totally painless!

thanks for the tip, rig runs flawlessly atm =-)
<3 Garuda!!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.