Slow / laggy video's

So I'm new to Garuda linux. So I got very excited about installing Garuda. I tried installing it on my nuc8i5 machine, but updating the system destroyed the GRUB menu, leaving only the option 'garuda snapshots'. I ended up reinstalling Manjaro again. Also, it was laggy somehow. Fixing grub and chrooting didn't help me out. But I think perhaps I don't know enough about chrooting and fixing Grub.

Today, I tried installing it on my main production machine. Garuda kinda works, but it wouldn't install nvidia-dkms through the 'Hardware Configuration' module. The script would just fail, it said. I ended up installing it by using the terminal for the nvidia-dkms package. After that I was able to complete the setup through 'Hardware Configuration' again. However, browsing and watching YouTube video's is still very laggy. Also the desktop experience seems laggy at times. I did not experience this on both Arch and Manjaro and Garuda is marketed as 'snappy' and 'speedy'.

What can I do to fix this? I don't want to switch back to Manjaro, but I might have to. Even Arch worked out of the box, what's the difference in this case?

System:    Kernel: 5.10.10-115-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=a066b548-e9f1-4bba-b361-9457dafa40ea rw [email protected] quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 resume=UUID=0a19e461-2d70-4e8c-a836-ac9ff878a3d4 
           loglevel=3 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: ASRock model: B85M-ITX serial: <filter> UEFI: American Megatrends v: P1.90 date: 12/10/2013 
Battery:   ID-1: hidpp_battery_0 charge: N/A condition: N/A volts: 3.8/N/A model: Logitech G Pro Wireless Gaming Mouse 
           type: N/A serial: <filter> status: Discharging 
CPU:       Info: Quad Core model: Intel Core i5-4670K bits: 64 type: MCP arch: Haswell family: 6 model-id: 3C (60) stepping: 3 
           microcode: 28 L2 cache: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27217 
           Speed: 800 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics vendor: ASRock driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0412 
           Device-2: NVIDIA GM204 [GeForce GTX 970] vendor: Micro-Star MSI driver: nvidia v: 460.39 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:13c2 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: nvidia display ID: :0 screens: 1 
           Screen-1: 0 s-res: 4480x1440 s-dpi: 92 s-size: 1237x402mm (48.7x15.8") s-diag: 1301mm (51.2") 
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") diag: 609mm (24") 
           Monitor-2: DP-0 res: 2560x1440 hz: 144 dpi: 93 size: 697x393mm (27.4x15.5") diag: 800mm (31.5") 
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 00:03.0 chip ID: 8086:0c0c 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:8c20 
           Device-3: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fbb 
           Device-4: Samson GoMic compact condenser mic type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1:2 
           chip ID: 17a0:0305 
           Device-5: Focusrite-Novation Scarlett Solo (3rd Gen.) type: USB driver: snd-usb-audio,usb-storage bus ID: 3-2:3 
           chip ID: 1235:8211 serial: <filter> 
           Sound Server: ALSA v: k5.10.10-115-tkg-bmq 
Network:   Device-1: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: ASRock driver: alx v: kernel port: d000 bus ID: 03:00.0 
           chip ID: 1969:10a1 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 20.97 GiB (1.8%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 023 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT256MX100SSD1 size: 238.47 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter

I edit your post, read wiki "reporting bugs". Seems there are missing parts. greetings SGS

There is no such thing as "Arch working out of the box". You have to install and configure everything manually with Arch. That is why the average user does not use Arch, but rather a derivative distro based on on Arch.

There has been a bug recently with the auto-cpufreq service. You may want to mask the service and reboot. I shouldn't need to post the relevant systemd link to the Archwiki for an accomplished Arch user. :wink:

2 Likes

I'm not that much of an experienced Arch user. And i'm certainly not trying to brag about it. 1 year ago, after about 2 working days I accomplished installing arch with KDE Plasma, I finally succeeded and managed to keep it running for about a year or so. But then I ran into a bug I couldn't fix, didn't have much time on my hands and installed Manjaro. However, Installing nvidia proprietary drivers worked very well on Arch by using the arch-wiki.

Are you willing to elaborate on that systemd link? I'm not sure what you mean.

Edit: NVM, I googled how to mask a service (never done this before). Thanks for your reply. I typed 'sudo systemctl mask auto-cpufreq.service' and it did the trick. Is there any disadvantage to keeping the service masked? Should I unmask it in the future?

2 Likes

The issue is being worked on by the distro devs ATM. For now simply keep it masked and make sure it isn't reactivated after the service is updated.

It hasn't been decided exactly what has to be done with this recent bug. Check the forum or the next release notice and it should contain info on what measures were taken to correct this.

2 Likes

Okay, thank you. My pc isn't laggy anymore and I will just check/follow the update news. :smiley:

2 Likes

The devs have responded to user input and these utils should be able to be uninstalled with future updates.

2 Likes

Had same issue. Solved.

Thank you!

4 Likes

Excellent; we need more people here like you. :wink:

5 Likes