SimpleScreenRecorder Blinking

Hello everyone. I'm getting some strange blinkings in my recordings on my "new" laptop and just wondering if anyone has seen it before, knows a fix, or can tell me a decent open source alternative. Thanks.

╭─user@karuda in ~ 
 ╰─λ garuda-inxi
  Kernel: 5.16.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6d00cdea-07f2-4376-822a-554629a103bf rw rootflags=subvol=@
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma 5.24.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 688528U v: ThinkPad Edge E531
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 688528U v: 0B98401 PRO serial: <superuser required>
    UEFI: LENOVO v: HEET52WW (1.33 ) date: 06/21/2018
  ID-1: BAT0 charge: 3.6 Wh (12.7%) condition: 28.3/40.4 Wh (70.0%)
    volts: 10.2 min: 10.8 model: LGC 45N1049 type: Li-ion serial: <filter>
    status: Discharging
  Info: model: Intel Core i7-3632QM bits: 64 type: MT MCP arch: Ivy Bridge
    family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1942 high: 2243 min/max: 1200/3200 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2066 2: 1226 3: 2122
    4: 1893 5: 2243 6: 1872 7: 2078 8: 2040 bogomips: 35119
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-1.6:5 chip-ID: 5986:0397 class-ID: 0e02
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102
    size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
    v: 4.2 Mesa 21.3.5 compat-v: 3.0 direct render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.16.9-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel
    bus-ID: 04:00.0 chip-ID: 8086:0888 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 2000 bus-ID: 05:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-1: Intel Centrino Bluetooth Wireless Transceiver type: USB
    driver: btusb v: 0.8 bus-ID: 1-1.3:3 chip-ID: 8087:07da class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 931.52 GiB used: 148.08 GiB (15.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000LPCX-75VHAT1 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A05 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi)
    model: HTS725050A7E630 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: B550 scheme: GPT
  ID-1: / raw-size: 64 GiB size: 64 GiB (100.00%) used: 8.14 GiB (12.7%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 100 MiB size: 98.4 MiB (98.42%)
    used: 562 KiB (0.6%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 401.66 GiB size: 401.66 GiB (100.00%)
    used: 139.94 GiB (34.8%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 64 GiB size: 64 GiB (100.00%)
    used: 8.14 GiB (12.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 64 GiB size: 64 GiB (100.00%)
    used: 8.14 GiB (12.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.58 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 29.8 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 269 Uptime: 9m wakeups: 1 Memory: 7.59 GiB
  used: 2.32 GiB (30.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1247 lib: 311 Shell: fish
  v: 3.3.1 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
  System install date:     2022-02-14
  Last full system update: 2022-02-17
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

These flickers are generally due to low spec hardware. Try

  1. Reducing fps of simplescreenrecorder. The video recorded might not look too good, maybe.
  2. Try different software, I personally like obs-studio. But screen may still flicker
  3. If nothing works, switch to lighter DE, maybe Cinnamon or xfce. Even gnome did help to remove these flickers in many cases.
  4. Also see the following thread

And btw,

Yeah, that's quite common issue.


Odd. I've got a quad 3rd gen i7 that scores 2700 in geekbench, but only intel 3rd gen graphics. Thanks for that informative answer. Definitely gives me some ideas of what to try.

And I bet it would be worse if this laptop had the 1080P display I thought it did when I ordered it.

Edit: Even at 30FPS it's blinking just as bad. I also messed with the encoding speed which hasn't helped.

Still have some ideas though.

It was launched in Q3 2012. And technology evolves too fast these days....

Btw, a little off topic, how much did you pay for it? And is this returnable??

1 Like

Yeah, but my other laptop that it's working fine in has a 2nd Gen i7. LOL.

I got it for $125 on ebay. Yes it's returnable, but it's hard to find this much processing power when you're as poor as I am. :rofl:

I buy broken ones with no hard drive and fix them. This one the seller thought had a charging problem, but It's worked great with both the charger from my T440p and my universal one.

On the other hand, I damned near returned it when I found it didn't have the Nvidia GeForce 740M I thought it had.

LOL. I just realized, my CPU is pegged running hashcat in the background. Let me turn it off and test again at 30FPS.

Nope didn't help.

Maybe try this

IIRC, it was quite effective on ivy bridge too.

Ok, that's understandable.


You know, I did a search in here and didn't see that one you linked. Thanks.

You're always welcome

So, I guess I should mark this thread solved now.

1 Like

No Sir. I haven't fixed it yet. I'm currently trying to learn to switch the video driver from video-linux to video-modesetting. It's apparently a hard thing to find out. All the instructions I've found so far assume you-re trying to switch from intel proprietary drivers. Sudo pacman -R intel-xxxxx isn't going to work for me. I installed with free drivers since NO NVIDIA.. @Naman (or anyone really), you wouldn't happen to know the command to switch video drivers, would you? If you could just tell me which command/program that does it I could read some man and --help pages and figure it out. But it's a tough search.


sudo pacman -R xf86-video-intel

and reboot do the trick?


I'm currently using video-linux. I don't have proprietary drivers.

okk, I have no idea about these. I don't have intel now

Maybe some other can help...

1 Like

I'll figure it out soon. I need to learn some search tricks.

I won't forget to come back and I'll put the command to switch to modesetting, since it's so hard to figure out, even if it doesn't fix it.


Because Garuda Settings Manager > Hardware Configuration didn't list video-intel I mistakenly assumed it wasn't installed because I didn't do the non-free driver installation. But, I saw my inxi said intel was the loaded driver and realized I was mistaken. It actually wouldn't uninstall by itself because of a dependency issue. I used

$ sudo pacman -R xf86-video-intel garuda-video-linux-config
$ reboot

Anyway, now modesetting is the loaded driver and simplescreenrecorder is working great now @ 60FPS. Thanks so much for your help @Naman!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.